Jump to content

QuotesUK

Member
  • Posts

    77
  • Joined

  • Last visited

Posts posted by QuotesUK

  1. At the end of the checkout process the customer clicks "secure checkout"  (/index.php?_a=confirm)

    Usually this would redirect to PayPal for payment

    However this step fails with a 504 Gateway Timeout error (/index.php?_a=gateway)

    I can't find anything in the error logs. 

    On the same server (but separate hosting) I have another cubecart installation with the same settings and that is running fine, so a server issue is not suspected

    I have tried switching from PayPal standard to PayPal Commerce, which sometimes generates a new button, however the existing "Secure Checkout" button remains, and has this error. So if I can't fix this timeout issue perhaps there is a way to disable this button and force usage of PayPal Commerce. Ideally though I'd just like to stay on PayPal Standard and fix this timeout issue.

  2. I have CubeCart v6.1.14 installed and my server is currently running MySQL v5.1.73 (even though cubecart.com says 5.5 minimum)

    I understand that you should not upgrade directly from 5.1 to 5.7, but should go 5.1 to 5.5, then 5.5 to 5.6, then 5.6 to 5.7.

    However Plesk does not yet support 5.7, so I won’t be going that far.

    1/ What do I need to do with my CubeCart database if my server is upgraded from MySQL 5.1 to MySQL v5.5?

    and then...

    2/ What do I need to do with my CubeCart database if my server is upgraded from MySQL 5.5 to MySQL v5.6?

  3. I have already upgraded using the auto-setup tool
    (as a known issue I’m puzzled why it wasn’t squished at the same time)

    I assume this is source code issue rather than a setting or database value

    Is there a specific directory that I can swap out?

    e.g. perhaps "sources/maintenance/*" from the current version of source code?

    Thank you in advance

  4. I have found an error affecting two different CubeCart installs with different hosts, so I think this may be a bug

    When choosing the standard Files Backup button, with checkboxes off, the backup proceeds and is created but then it tries to find this file...

    /admin_ZZZZZZZ/sources/maintenance/indexbackup.inc.php - not found.

    Where ZZZZZ is a novel admin location - it doesn’t appear to have been used before and doesn’t match the current.

    In one situation (it may have been a checkbox difference) I was warned about cross-site scripting on the dashboard page

    It appears as is something is not going well for the Files Backup feature, and could do with looking at by the software development team

    (I am not that bothered personally, there are other backup methods available)

  5. Thank you - I have now cleared all the warnings from the maintenance section.

    It was time consuming, but I suppose it will now mean the server resources are used more wisely.

    I will just keep my fingers crossed that this upgrade issue is a one off, and auto upgrades will start working again.

    ...now onto my next CC install for more of the same!

  6. I now have the database warnings down to the following:

    CubeCart_category.cat_parent_id has no key set. Expecting KEY.
    CubeCart_inventory.popularity has no key set. Expecting KEY.
    CubeCart_inventory.status has no key set. Expecting KEY.
    CubeCart_reviews.approved has no key set. Expecting KEY.
    CubeCart_seo_urls.item_id has no key set. Expecting KEY.
    CubeCart_seo_urls.type has no key set. Expecting KEY.
    CubeCart_sessions.customer_id has no key set. Expecting KEY.
    CubeCart_sessions.session_last has no key set. Expecting KEY.

    and

    CubeCart_currency.currency_id has a key type KEY but expecting PRIMARY.
    CubeCart_modules.module_id has a key type KEY but expecting PRIMARY.

    I have taken some screengrabs and wonder whether you can give me a few pointers on what to enter. On the first image I have clicked on the Go button you suggested. The other two look a bit trickier because they are about changing something rather than add/delete. Someone at CubeCart might also want to make a note about the warning for using the table field name of "default".

    Screen Shot 2017-03-08 at 17.16.07.png

    Screen Shot 2017-03-08 at 17.17.13.png

    Screen Shot 2017-03-08 at 17.17.42.png

  7. Okay, and for the benefit of anyone else following this, here is a new screengrab.

    I have used a red arrow to show you where to find this panel. The other two rows are now removed because I clicked on the word ‘Drop’ (just in case anyone is looking for a delete button). In my CubeCart admin panel this error is now cleared.

    Screen Shot 2017-03-08 at 14.21.39.png

    Here is the other type of error:

    CubeCart_category.cat_parent_id has no key set. Expecting KEY.

    And my screengrab... how do we fix this sort, there are no onscreen prompts?

     

    Screen Shot 2017-03-08 at 14.31.59.png

  8. I am using phpMyAdmin and looking at the table - CubeCart_admin_user

    There are 23 database fields, starting with admin_id

    At the bottom are two infopanels - Space Usage and Row Statistics - nothing about column indexes

    What am I looking for? I can see the data, I can see the structure.

  9. Okay, so I have manually upgraded to v6.1.5 and I can see the database now has some issues - this was to be expected.

    However, I wasn’t expecting the link to a "database checker tool" to be just a link to a discussion elsewhere and the comments by Al Brookbanks aren’t much help... “Please use a tool such as phpMyAdmin to make any required changes” ... erm, yes, so how exactly?

    There appear to be two types of error message.

    This is what I am looking at:

    CubeCart_admin_users.admin_id has a key type KEY but expecting PRIMARY.
    CubeCart_category_index.id has a key type KEY but expecting PRIMARY.
    CubeCart_category_language.translation_id has a key type KEY but expecting PRIMARY.
    CubeCart_category.cat_parent_id has no key set. Expecting KEY.
    CubeCart_currency.currency_id has a key type KEY but expecting PRIMARY.
    CubeCart_image_index.id has a key type KEY but expecting PRIMARY.
    CubeCart_inventory_language.translation_id has a key type KEY but expecting PRIMARY.
    CubeCart_inventory.popularity has no key set. Expecting KEY.
    CubeCart_inventory.status has no key set. Expecting KEY.
    CubeCart_modules.module_id has a key type KEY but expecting PRIMARY.
    CubeCart_order_summary.cart_order_id has a key type KEY but expecting UNIQUE KEY.
    CubeCart_reviews.approved has no key set. Expecting KEY.
    CubeCart_seo_urls.item_id has no key set. Expecting KEY.
    CubeCart_seo_urls.type has no key set. Expecting KEY.
    CubeCart_sessions.customer_id has no key set. Expecting KEY.
    CubeCart_sessions.session_last has no key set. Expecting KEY.
    CubeCart_transactions.id has a key type KEY but expecting PRIMARY.

     

  10. My last upgrade took me to version 6.1.1 on 14th-Nov-2016

    My admin folder is on a custom URL - I have php 7.0.16 - ZipArchive check has passed.

    Dashboard prompts me to upgrade but the upgrade/maintenance section says I have the current version. I can see other posts talking about stalled upgrades, upgrades failing, database crashes and things like that and wonder whether it may be best to wait a while for these issues to be worked out. Or should I put myself through the time and effort of a manual upgrade. All previous admin section upgrades have gone well so I am a but surprised to see I am now 4 updates behind, and yet there is no prompt to upgrade. A bit of a puzzle.

  11. kurouto/templates/content.category.php - line 40

    {if isset($PRODUCTS)}
      {foreach from=$PRODUCTS item=product}
    <form action="{$VAL_SELF}" method="post" enctype="application/x-www-form-urlencoded" class="addForm">

     

    classes/gui.class.php - line 203

           //Assign common GUI parts
            $GLOBALS['smarty']->assign('VAL_SELF',        currentPage());

     

    Maybe gui.class.php is out of date? - line 13 says...

     * CubeCart is NOT Open Source.

  12. "custom-name" doesn’t contain any special words that are likely to affect processing.

    I have just tested with a different category that ends with /phrase.html and that is affected in the same way, so it affects numbers and letters for the page name

    I think this is a URL nesting issue, the custom URL has a path that is longer than just a page name, and the form script is not pulling in the full custom URL

    For clarification I use the URL structure of /category/product.html so that Google sees them as a distinct directory, and it helps with SEO (which is the whole point of having a custom URL).

    This only appears to be an issue in category list view.

×
×
  • Create New...