Jump to content

harrisorganic

Member
  • Posts

    381
  • Joined

  • Last visited

  • Days Won

    4

Posts posted by harrisorganic

  1. I think the server is in USA, probably Denver. I am pretty sure( from memory) the stores time zone is set for perth. However there is an issue with logging in as the 403 Forbidden raises its head with shop/admin.

    re  home1/maketext/public_html/ admin I will change the name from admin to administ and see what happens. with the result of No change to shop and no change re login to admin. :( 

     

  2. Thats true Brian, and I do not know why there is an admin folder under /home1/maketext/public_html/  anyway

    Here is the current globals.inc.php, without any of the above

    <?php
    $glob['adminFile'] = 'admin.php';
    $glob['adminFolder'] = 'admin';
    $glob['dbdatabase'] = 'mart1';
    $glob['dbhost'] = 'localhost';
    $glob['dbpassword'] = '0i0';
    $glob['dbprefix'] = '';
    $glob['dbusername'] = 'ma1';
    $glob['encoder'] = 'ioncube';
    $glob['installed'] = '1';
    ?>

  3. AND here are some more:

    /home1/maketext/public_html/admin/error_log: [28-Nov-2015 08:35:19 America/Denver] PHP Notice: Undefined index: logout in /home1/maketext/public_html/admin/index.php on line 11 [28-Nov-2015 08:35:19 America/Denver] PHP Notice: Undefined index: db_name in /home1/maketext/public_html/admin/index.php on line 79

  4. What has changed with your hosting provider?   Nothing that I can think off, have used this server for over 2 years. There was an issue with the SSL certificate some months ago. I did not renew it in the required time. I have a dedicated IP address for SSL, which is 173.254.45.80

    Meanwhile the changes above have not changed the /admin.php

    The main error log has changed
    [Sun Dec 27 00:08:01 2015] [error] [client 74.220.215.221] Premature end of script headers: index.php
    [Sun Dec 27 00:08:06 2015] [error] [client 42.60.20.26] Zend Guard Loader requires Zend Engine API version 220100525., referer: http://www.ambassador-baptist.org/category/media/videos/
    [Sun Dec 27 00:08:06 2015] [error] [client 42.60.20.26] The Zend Engine API version 220131226 which is installed, is newer., referer: http://www.ambassador-baptist.org/category/media/videos/
    [Sun Dec 27 00:08:06 2015] [error] [client 42.60.20.26] Contact Zend Technologies at http://www.zend.com/ for a later version of Zend Guard Loader., referer: http://www.ambassador-baptist.org/category/media/videos/
    [Sun Dec 27 00:08:06 2015] [error] [client 42.60.20.26] , referer: http://www.ambassador-baptist.org/category/media/videos/
    [Sun Dec 27 00:08:08 2015] [error] [client 77.75.76.171] Failed loading /usr/php/54/usr/lib64/php/modules/ZendGuardLoader.so:  /usr/php/54/usr/lib64/php/modules/ZendGuardLoader.so: undefined symbol: zend_new_interned_string

    I have looked for more info on Zend and cannot find any info regarding php setup

    but in the php.ini file I see
    zend_loader.disable_licensing=0
    extension=magickwand.so
    zend_extension=/usr/php/54/usr/lib64/php/modules/ioncube_loader_lin.so
    zend_extension=/usr/php/54/usr/lib64/php/modules/ZendGuardLoader.so

    I contacted the hosting company and they provided the code for zend optimiser which is:

    zend_extension=/usr/php/54/usr/lib64/php/modules/ZendGuardOptimizer.so  I added this to php.ini with no difference to login to admin

    In error logs I found many days of this:

    PHP error_log:

    /home1/maketext/public_html/error_log: [26-Dec-2015 15:30:26 America/Denver] PHP Fatal error: require(): Failed opening required '/home1/maketext/public_html/wp-includes/load.php' (include_path='.:/usr/php/54/usr/lib64:/usr/php/54/usr/share/pear') in /home1/maketext/public_html/wp-settings.php on line 21

    I installed wp in November but did not use it on this site, I use it on another site on this server

    Hope that sheds some light.

  5. Brian,

    I found these in the /shop/error_log 

    [22-Dec-2015 21:44:42 Australia/Perth] PHP Warning:  curl_exec() has been disabled for security reasons in /home1/maketext/public_html/harrisorganicwine/shop/classes/request.class.php on line 251
    [24-Dec-2015 11:21:14 Australia/Perth] PHP Warning:  Invalid argument supplied for foreach() in /home1/maketext/public_html/harrisorganicwine/shop/modules/shipping/Postage/shipping.class.php on line 46

    noting these is nothing today.

    in shop/admin/ the last error_log was last made on 5th December 2013.

    Back soon.

     

  6. Firstly the CHMOD permissions are 644 for the file /shop/admin.php.

    php errors in ? 

    here are some Error Logs
    [Sat Dec 26 20:47:53 2015] CURRENT SERVER TIME
    MAIN error_log:
    [Sat Dec 26 20:47:01 2015] [error] [client 74.220.215.221] Contact Zend Technologies at http://www.zend.com/ for a later version of Zend Optimizer.
    [Sat Dec 26 20:47:01 2015] [error] [client 74.220.215.221] 
    [Sat Dec 26 20:47:01 2015] [error] [client 74.220.215.221] Premature end of script headers: index.php
    [Sat Dec 26 20:47:02 2015] [error] [client 74.220.215.221] Premature end of script headers: index.php
    [Sat Dec 26 20:47:04 2015] [error] [client 180.76.15.5] Zend Guard Loader requires Zend Engine API version 220100525.
    [Sat Dec 26 20:47:04 2015] [error] [client 180.76.15.5] The Zend Engine API version 220131226 which is installed, is newer.
    [Sat Dec 26 20:47:04 2015] [error] [client 180.76.15.5] Contact Zend Technologies at http://www.zend.com/ for a later version of Zend Guard Loader.
    [Sat Dec 26 20:47:04 2015] [error] [client 180.76.15.5] 
    [Sat Dec 26 20:47:07 2015] [error] [client 208.115.111.69] Request exceeded the limit of 10 internal redirects due to probable configuration error. Use 'LimitInternalRecursion' to increase the limit if necessary. Use 'LogLevel debug' to get a backtrace.
    [Sat Dec 26 20:47:07 2015] [error] [client 208.115.111.69] Request exceeded the limit of 10 internal redirects due to probable configuration error. Use 'LimitInternalRecursion' to increase the limit if necessary. Use 'LogLevel debug' to get a backtrace.
    [Sat Dec 26 20:47:07 2015] [notice] [client 80.82.70.106] mod_rbl: 80.82.70.106 is listed in RBL.

     

    Have included admin.php

    admin.php

  7. Hi Brian,

    I took your last paragraph first: "Then, just requesting /shop/admin.php where admin is possibly renamed has the 404 document you have created and the web server is delivering because the (possibly renamed) admin.php does not in fact exist."

    Yes I forgot to change admin****.php name back to admin.php. So once I had made the change, I thought that may be the last piece of the jig saw. NO.

    I now get a 403 Forbidden error.with https://www.harrisorganicwine.com.au/shop/admin/index.php which changes to https://www.harrisorganicwine.com.au/shop/admin.php  Brian  - Changed url

    regards Duncan

  8. Hi Brian,

    When I type in /shop/admin/  I get a system 404 error

    The requested URL /shop/admin/ was not found on this server.

    If I use /shop/admin.php I get my 404 error page.

    re ioncube, I cant remember  uploading any new plugins recently for this to happen. However I checked the php config. on host and found ioncube turned on and using PHP 5.4 (FastCGI) was  PHP 5.4 (Single php.ini) but seems to make no difference.

    Additional extensions available for Installation
    Http
    Magick Wand  XX turned on
    Mail Parse
    OAuth
    OCI8
    Upload Progress
    IonCube        XX turned on
    SourceGuardian

  9. Hi Brian, Merry Christmas.

    I started on reducing the security issues that came up on CC6 security plugin. I made some changes to php.ini and includes/global.inc..php and found that I could not log in as admin any more.

    So I "undid all the changes" and am still unable to login as admin. :(  see https://tinyurl.com/gru44qq for more info

    During that period of time I also found that the category bar gives an unusual url where as mousing over an item on the front page gives the correct url.

    eg. https://www.harrisorganicwine.com.au/shop/ Hover over the word category sparkling gives https://www.m.harrisorganicwine.com.au/shop/sparkling.html where there should be no "m."

    When I reversed the changes to php.ini (in the root directory) the above went away, but now it is back again. I emptied cache and checked the php.ini file again to find it was without changes.

    todays error log shows:

    [Fri Dec 25 17:13:17 2015] CURRENT SERVER TIME
    MAIN error_log:
    [Fri Dec 25 17:13:02 2015] [error] [client 74.220.215.221] Premature end of script headers: index.php
    [Fri Dec 25 17:13:03 2015] [error] [client 66.249.69.104] Failed loading /usr/lib64/php/modules/ioncube_loader_lin.so:  /usr/lib64/php/modules/ioncube_loader_lin.so: undefined symbol: execute
    [Fri Dec 25 17:13:03 2015] [error] [client 66.249.69.104] Zend Optimizer requires Zend Engine API version 220060519.
    [Fri Dec 25 17:13:03 2015] [error] [client 66.249.69.104] The Zend Engine API version 220131226 which is installed, is newer.
    [Fri Dec 25 17:13:03 2015] [error] [client 66.249.69.104] Contact Zend Technologies at http://www.zend.com/ for a later version of Zend Optimizer.

    Any suggestions please?

    regards Duncan

  10. I have the same issue: After editing ini.php and adding  

    disable_functions =exec,passthru,shell_exec,system,proc_open,popen,curl_exec,curl_multi_exec,parse_ini_file,show_source,pcntl_exec  for security and

    editing global.inc.php to change the admin folder and file name

    $glob['adminFile'] = 'admin.php';
    $glob['adminFolder'] = 'admin';

    I am unable to login to admin as the old /admin or the changed admin name. I then returned the global.inc.php

    back to the above initial/original and am still unable to login with shop/admin or shop/admin.php and unable to turn bold text off. php.ini remains with the above changes.

     

    The error log for 

    [Wed Dec 23 23:39:09 2015] CURRENT SERVER TIME
    MAIN error_log:
    [Wed Dec 23 23:39:01 2015] [error] [client 74.220.215.221] 
    [Wed Dec 23 23:39:01 2015] [error] [client 74.220.215.221] Zend Optimizer requires Zend Engine API version 220060519.
    [Wed Dec 23 23:39:01 2015] [error] [client 74.220.215.221] The Zend Engine API version 220131226 which is installed, is newer.
    [Wed Dec 23 23:39:01 2015] [error] [client 74.220.215.221] Contact Zend Technologies at http://www.zend.com/ for a later version of Zend Optimizer.
    [Wed Dec 23 23:39:01 2015] [error] [client 74.220.215.221] 
    [Wed Dec 23 23:39:02 2015] [error] [client 74.220.215.221] Premature end of script headers: index.php
    [Wed Dec 23 23:39:02 2015] [error] [client 74.220.215.221] Premature end of script headers: index.php
    [Wed Dec 23 23:39:03 2015] [error] [client 104.217.216.173] Premature end of script headers: index.php
    [Wed Dec 23 23:39:03 2015] [error] [client 104.217.216.173] Zend Guard Loader requires Zend Engine API version 220100525.
    [Wed Dec 23 23:39:03 2015] [error] [client 104.217.216.173] The Zend Engine API version 220131226 which is installed, is newer.
    [Wed Dec 23 23:39:03 2015] [error] [client 104.217.216.173] Contact Zend Technologies at http://www.zend.com/ for a later version of Zend Guard Loader.
    [Wed Dec 23 23:39:03 2015] [error] [client 104.217.216.173] 
    [Wed Dec 23 23:39:04 2015] [error] [client 104.217.216.173] Premature end of script headers: 500.php
    [Wed Dec 23 23:39:05 2015] [error] [client 104.217.216.173] Failed loading /usr/php/54/usr/lib64/php/modules/ioncube_loader_lin.so:  /usr/php/54/usr/lib64/php/modules/ioncube_loader_lin.so: undefined symbol: execute
    [Wed Dec 23 23:39:05 2015] [error] [client 104.217.216.173] SourceGuardian requires Zend Engine API version 220100525.
    [Wed Dec 23 23:39:05 2015] [error] [client 104.217.216.173] The Zend Engine API version 220131226 which is installed, is newer.
    [Wed Dec 23 23:39:05 2015] [error] [client 104.217.216.173] Contact SourceGuardian Ltd. at http://www.sourceguardian.com/ for a later version of SourceGuardian.
    [Wed Dec 23 23:39:05 2015] [error] [client 104.217.216.173] 
    [Wed Dec 23 23:39:05 2015] [error] [client 104.217.216.173] Zend Guard Loader requires Zend Engine API version 220100525.
    [Wed Dec 23 23:39:05 2015] [error] [client 104.217.216.173] The Zend Engine API version 220131226 which is installed, is newer.
    [Wed Dec 23 23:39:05 2015] [error] [client 104.217.216.173] Contact Zend Technologies at http://www.zend.com/ for a later version of Zend Guard Loader.
    [Wed Dec 23 23:39:05 2015] [error] [client 104.217.216.173] 
    [Wed Dec 23 23:39:05 2015] [error] [client 66.249.69.112] Failed loading /usr/lib64/php/modules/ioncube_loader_lin.so:  /usr/lib64/php/modules/ioncube_loader_lin.so: undefined symbol: execute
    [Wed Dec 23 23:39:05 2015] [error] [client 66.249.69.112] Zend Optimizer requires Zend Engine API version 220060519.
    [Wed Dec 23 23:39:05 2015] [error] [client 66.249.69.112] The Zend Engine API version 220131226 which is installed, is newer.
    [Wed Dec 23 23:39:05 2015] [error] [client 66.249.69.112] Contact Zend Technologies at http://www.zend.com/ for a later version of Zend Optimizer.
    [Wed Dec 23 23:39:05 2015] [error] [client 66.249.69.112] 
    [Wed Dec 23 23:39:06 2015] [error] [client 66.249.69.112] Premature end of script headers: index.php
    [Wed Dec 23 23:39:06 2015] [error] [client 66.249.69.112] Failed loading /usr/lib64/php/modules/ioncube_loader_lin.so:  /usr/lib64/php/modules/ioncube_loader_lin.so: undefined symbol: execute

     

    Any suggestions on this before we all get merry? Ho ho ho!  Best wishes to all those who have been a great source of info and assistance. May you have a good time with friends and family over the holiday period.

     

  11. Hello Mario,

    I used a coupon to give free shipping. Once the coupon was made, I then messaged all my customers to say they could use it.

    If you want to give free shipping over a certain $ amount, all I can suggest is to advertise the coupon code on all the pages (and the checkout) where you want the customer to have the free shipping. They will then have to insert the coupon code then selves.

    Thats the only way I can think of doing it at this time without some indepth programming.

    Lets see what other forum people suggest.

  12. All was working well this morning and suddenly tonight, with no input from myself, I have no shopping cart.  I can access shop/admin.php but no other files.  CC6.07

    Here is the Error log from the server.

    [Thu Nov 05 05:59:38 2015] [error] [client 2.90.246.165] Zend Optimizer requires Zend Engine API version 220060519.

    [Thu Nov 05 05:59:38 2015] [error] [client 2.90.246.165] The Zend Engine API version 220131226 which is installed, is newer.

    [Thu Nov 05 05:59:38 2015] [error] [client 2.90.246.165] Contact Zend Technologies at http://www.zend.com/ for a later version of Zend Optimizer. 

    Any suggestions. My hosting company talked about changing php.ini, however I am not sure.

    regards

    Duncan

  13. Hi Brian, 

    If your browser is giving a URL such as : example.com/store/cat/prod.html  thats OK.

    then if it is an https secure site the url will be https://example.com/store/cat/prod.html

    However if you have external links with http://example.com/store/cat/prod.html   (ie. no s in http) the resultant url for the customer will be something like https://example.com/store/index.php?seo_path=cat/prod.html

    I would want the end result to be https://example.com/store/cat/prod.html

    regards Duncan

     

     

  14. Hi Brian et al. 

    I have changed my site over from http://... to https://www.harrisorganicwine.com.au

    I see there are a few parts to this.

    1. changing code in htaccess to the root domain

    2. reviewing htaccess to CC6 shop with START v4 SEO URL BACKWARD COMPATIBILITY .. cant see anything to change

    3. Turn on or OFF SSL in CC store settings - does not seem to make any difference whether on or off.

    4. Test the site by changing the URl, two options removing www and using http, without 's"

    All seems to work fine, until I found out old links to the site dont have either www or https in the url. Therefore when I make some changes to the root htaccess file a few things happen.

    This is only part of the file below:

    RewriteEngine on

    RewriteCond %{HTTPS} off   # Using this one stops /404 errors and adds index.php?seo_path= to the URL.
    RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI} [R,L]

    RewriteCond %{SERVER_PORT} 80  # redirect for global SSL
    RewriteRule ^(.*)$ https://www.harrisorganicwine.com.au/$1 [R=301,L]

    When I add RewriteCond %{HTTPS} off etc  it  stopped the site giving 404 errors and adds index.php?seo_path=  to the url when I test it by removing the s in https

    eg.

    http://www.harrisorganicwine.com.au/shop/dry-whites/chilli-white.html  becomes

    https://www.harrisorganicwine.com.au/shop/index.php?seo_path=dry-whites/chilli-white

    and when I remove the www.

    https://harrisorganicwine.com.au/shop/dry-whites/chilli-white.html

    https://harrisorganicwine.com.au/shop/dry-whites/chilli-white.html no change,

    however if I add a wildcard redirect through the hosting panel ie, from

    http://harrisorganicwine.com.au to http://www.harrisorganicwine.com.au all I get is a 404 error.

    Any thoughts how to fix these issues as I have little experience in htaccess code.

    Duncan

     

  15. Hi, The SEO on cubecart is not up to scratch. If you run "traffic Travis" it will tell you all the parts that are missing for the best SEO.  

    As Sailing123 mentions H1 and the Meta tag title are normally treated differently. 

    I would like to see the SEO tabs on all products, categories and other pages, such as gift certificates, login, register etc with tags for SEO. 

    Meta Title
    Custom SEO URL Path *
    Meta Keywords
    Meta Description etc
     
    With the ability to add H1 and H2 tags also.
    I would be pleased if this issue was raised with the cubecart team.
    regards
    Duncan
×
×
  • Create New...