Jump to content

RogerM

Member
  • Posts

    27
  • Joined

  • Last visited

RogerM's Achievements

Apprentice

Apprentice (3/14)

  • Dedicated Rare
  • Collaborator Rare
  • First Post
  • Conversation Starter Rare
  • Week One Done

Recent Badges

0

Reputation

  1. Hi OK I just tried again and got the verification code error as before but my basket didn't empty this time?! That's an improvement! So then I disabled the reCaptcha and now it works fine, but I've no idea why my PC wouldn't connect to the reCaptcha on my site when it does to others? Inconsistency isn't helpful! I'm guessing you had no issue with the reCaptcha appearing? I'm now in a dilemma - is reCaptcha going to work for everybody OK as I suspect you found, and was this just an issue with my PC alone, or are others going to have a problem too? Do I really need reCaptcha? The lost basket contents issue seems to have resolved on its own which is good, as long as it doesn't return! Thanks for looking. Roger
  2. Has anybody got any suggestions for this please? Thanks Roger
  3. After choosing a product and going to secure checkout, the buyer is required to input their name, address, cellphone number, choose one the shipment options on offer and the method of payment. If no account set up is chosen then the following occurs. Having done all that, the buyer clicks through to secure payment and the following screen appears You'll see at this point that the basket has been emptied for some reason? If the buyer does as directed and clicks on checkout of course it just says the basket is empty. If the buyer then goes back to continue shopping and reselects products and checks out again their address is remembered and the process continues OK and gets through to the payment screen. If the buyer chooses to set up an account and inputs/confirms a password, chooses their preferred shipping and then goes to secure checkout the following message appears at the top of the same profile page where address details etc are input. The password input/confirmation must then be input again, and if the same one as before is re-entered then the checkout goes smoothly thereon in, which indicates that the password first input/confirmed has been remembered and presumably verified OK. I have also seen this error message when trying to checkout without setting up an account, but because no password is then being asked for, if the buyer chooses secure checkout again it all works fine. Why it does this sometimes and at other times just clears the basket doesn't make sense to me. Whilst the checkout procedure can be made to work by either re-selecting products again (guest buyers), or re-entering passwords/re-selecting secure checkout (account set-up/guest) the checkout process is not free-flowing and this increases the chance of losing the buyer. If anybody wants to try this for themselves (and stop before inputting credit card numbers of course!) then the shop URL is https://shop.naturalhealingsolutions.co.uk/cube/ I think this is the last glitch! Best regards Roger
  4. Thank you so much - solution 1 of the suggested 3 worked great. Hopefully any updates to Stripe and/or CC won't interfere with the solution... I just have to work out why when a new customer checks out and inputs their address it clears the basket!! At least they can choose again and then it works fine, but it's not ideal and the 2nd easiest way to lose a sale, now the first has been solved! Many thanks once again. Best Roger
  5. Hi Thanks for trying. I really appreciate it, but unfortunately it does exactly the same - no different at all. I guess I'll have to wait for a core update? Many thanks. Best Roger
  6. OK thanks for establishing what the problem is and that at least I'm not going mad! Hopefully the update will be swift so I can get up and running soon. Best R
  7. Hi Thanks. It looks like it's more complicated than my ability to know what I'm doing to sort it. Is this something there will be a CC update for? If so, is it imminent?!! R
  8. Hi Given that this Gateway extension was written by CubeCart and isn't functioning I'm disappointed by the lack of support in terms of helping find a real resolution. I'd at least expect an own brand extension to work. R
  9. OK thanks. So if that's not the issue, what's the solution as to why this gateway doesn't function at all how its supposed to? Best R
  10. I have checked the error log and found the following entry if this helps anybody identify a solution. It would seem to be an error in the extension [<strong>Exception</strong>] /home/customer/www/shop.naturalhealingsolutions.co.uk/public_html/cube/modules/gateway/Stripe/stripe-php-7.83.0/lib/Service/AbstractService.php:73 - The resource ID cannot be null or whitespace. According to my CC php Info I'm using php7.4.30 I see the error log mentions php-7.83.0. Is this difference the issue? If so how do I upgrade my php to the right one? Thanks. Roger
  11. Hi Thanks for your thoughts but if that were the case then I presume that my Stripe back office would not be able to tell that the API keys are set up correctly, and I would have the same issue with the Stripe extension on my other website that uses a different eCommerce solution. It works perfectly. On reflection it seems strange that the Stripe extension for CC asks to choose between element or checkout mode when neither are really what is required - I just need the payment processing, not a checkout solution that CC already provides. Best R
  12. Hi I have just been in chat with Stripe and it seems that there is an issue with the Stripe extension. They can see nothing from their end that I need to do. I shouldn't need to add their checkout when CC does it already. How do I resolve this please? thanks best Roger
  13. Hi I have installed Stripe payment gateway. Status is active. I have chosen the "Checkout" option for the mode and successfully, chosen priority order, checked default and added the published & secret live API keys. Capture charge is set to Yes. Card payment method is enabled in my Stripe back office. When I test to purchase a product (in live mode) all seems to go OK until the point where I choose to pay by card using stripe on the Basket page and click on the "Secure Checkout" button. The Checkout page tells me the amount due but then there is nothing showing from Stripe to insert the card details and pay. Looking on Stripe it looks like coding is required to set up and customise a checkout page, but CC does this already - I just need the card payment bit to appear for people to insert their card details to be processed and accept to pay. I assumed that the Stripe extension would just link to the payment bit via the API keys and no coding would be required. That's what happens when I used other gateway extensions in the past for Paypal, and when I used Stripe on another website that uses another eCommerce solution. The whole point of an extension is that it does all that bit for me. Am I missing something in CC or is there something that's really easy I have to do in my Stripe account back office that I'm missing? Thanks. Best regards Roger
  14. Hi, Al Brookbanks posted one solution on 28th July that worked for me if you're having trouble installing it. I presume you have set up your account with Stripe OK. Best R
  15. Sorted. Great! That looks like it's worked thanks. Will configure later. Cheers Roger
×
×
  • Create New...