Jump to content

Shari Marie

Member
  • Posts

    71
  • Joined

  • Last visited

Posts posted by Shari Marie

  1. 22 minutes ago, havenswift-hosting said:

    You need to delete the /admin directory then upload everything from /admin directory in distribution zip file (for the version of core you are running) into your admin_abcdef directory

    I appreciate your info but its Greek to me. I delete the two admin items I had in the photo? create a new one? I don't know where to begin uploading from distribution file nor where to find any of it. I think I'm in over my head. uggggh. Should I upgrade to newest version. would that automatically. resolove? feeling lost and defeated.

  2. Just now, havenswift-hosting said:

    You may be back in but the very fact that you have two admin directories shows that you have had a failed or partial upgrade at some stage in the past and are almost certainly running a mixture of files from different versions of CubeCart

    Thank you, how do I resolve this? what do I do next?

  3. 53 minutes ago, bsmither said:

    Somehow, the name of your administration script filename did change. Perhaps your store was upgraded but you are not aware of it?

    Anyway, please edit the URL of your bookmark to use the admin_Ulmf5J.php (the image is not too clear - I cannot tell if that is a lowercase 'L' or a Capital "I" after the "U").

    Also, looking at the files and folders, look at the contents of /public_html/includes/global.inc.php. The value of $glob['adminFile']  and $glob['adminFolder'] needs to be exactly the same as you see it spelled.

     

    I had tried the UImf5J prior and I didn't have success, I must have had a typo. I just had success upon. trying it again. 

    Thank you so much for your patience and help. I'm in!!!!

     

  4. 3 hours ago, havenswift-hosting said:

    It wouldnt just suddenly change but if the store has been upgraded incorrectly it is possible to get a situation where you have multiple admin_abcde.php files and only one is correct but that differs from what it is supposed to be as far as your config file is concerned.

    You will have one (or maybe incorrectly more) directories with admin in the name and you should have one (and again maybe incorrectly more than one) files with admin and ending .php

    I've been scouring my cpanel. I did a search for "admin_".  This is what I found. I tried both and still takes me to what looks like my home page. I don't know what to do with this I fo to get to my log in page.

     

    Screenshot (16)_LI.jpg

  5. 7 hours ago, Al Brookbanks said:

    Check via FTP of your web hosting file manager if that file exists. It's likely to be wrong. 

    There may be another file admin_{something}.php to try.

    Thanks for your reply! Why would it suddenly be changed? I have not logged into it for a long time, I didn't change anything. I am very unfamiliar with this and trying to reacquaint myself on how to . I did manage to figure out how to get I to my Cpanel and I see the cube cart file but nothing jumps out with 'admin' as far as an admin____php.   Under the Admin folder im not seeing a php file. Where would I look to find this admin_{something}.php?

    Sorry for my ignorance, its like I'm starting from scratch as far as knowing what I'm doing. once I can get into my cube cart dashboard, I think it will come back to me a little but I can't log in. 

  6. When I go to my admin log in page, it looks like my site's home page. I've not accessed it in about a year , what am i doing wrong. where can I log in with my password?

    Feeling silly, but honestly can't find it haha. http://sharimariecreations.com/admin_FHt5tg.php that is what had bookmarked as my 'control panel' log in for cube cart. Can someone shed some light? Thank you, really feeling dumb here . I think I'm using version 6.1.3. Thanks so much. 

    Shari Marie

     

  7. Don't spend a lot of time on that BSmithers,  I was just checking it was not already an option that was easy to achieve. If that my biggest problem, life is good :)

    I posted another question on the technical help section  about the photo/banner/slider thing ( Sorry for not being technical here, I cant think of its actual name) Anyway, I found it distracting at first , and deleted it before I should have.  I'd like to see how it looks after all. That will teach me not to "delete" on a whim.  haha  Can I get it back?

  8. Thanks DB!!!!   I must say it did feel good to do it myself.  I feel like the little engine that could,  "I think I can, I think I can".

    Without this forum though, I would never have made it this far. Bsmithers has really gone above and beyond helping redirect my

    old site pages to the new product pages.  I can not thank him enough.

    I'm SO appreciative of everyone's help and input and I'm learning so much.  I'm determined!!! 

    Thanks again DB

  9. Well, I went ahead and did what I thought you meant,  and put it before the page##html directives.  It seems to have worked. The link I had tried earlier on Pinterest, now take me to my CC404 page, (that I edited to read like a quasi home page, in actuality the 404)

    That's much better than HostGators 404 page. 

  10. 3 minutes ago, bsmither said:

    Near the top, there should be these directives:

    ### Rewrite rules for SEO functionality ###
    <IfModule mod_rewrite.c>
      RewriteEngine On
      RewriteBase /

    Add the following to just after them:

    RewriteCond %{HTTP_HOST} ^www\.sharimariecreations\.com$
    RewriteRule ^(.*)$ http://sharimariecreations.com/$1 [R=301,L]

    Delete the three lines you have at the very end (those directives after "End CubeCart .htaccess"). That's the wrong place for those directives.

    Then, near the bottom, there are two lines missing. Add the missing lines:

    </IfModule>
    
    ### Default store 404 page ###
    ErrorDocument 404 /index.php
    
    ## Override default 404 error document for missing page resources ##

     

    In that first edit, do I put that coding before the rewrites that I have been doing this afternoon or after them?

  11. Here's what I've got.

    RewriteCond %{REQUEST_FILENAME} !-f
      RewriteCond %{REQUEST_FILENAME} !-d
      RewriteCond %{REQUEST_URI} !=/favicon.ico
      RewriteRule ^(.*)\.html?$ index.php?seo_path=$1 [L,QSA]
    </IfModule>

    # Override default 404 error document for missing page resources ##
    <FilesMatch "\.(gif|jpe?g|png|ico|css|js|svg)$">
      ErrorDocument 404 "<html></html>
    </FilesMatch>
    ##### END CubeCart .htaccess #####

    RewriteCond %{HTTP_HOST} ^sharimariecreations\.com$ [OR]
    RewriteCond %{HTTP_HOST} ^www\.sharimariecreations\.com$
    RewriteRule ^idc\/index\.php$ "http\:\/\/sharimariecreations\.com\/" [R=301,L]
     

  12. I am still in the process of deleting these php's .   I clicked on a link I had for one of them that i found on Pinterest and I am directed to the Host Gator 404 page.  Is that what was expected to happen?

  13. Ok,  I will stick to the SEO address and leave it at that. I have been able to redirect/rewrite many of my products thus far and will continue to do so as I add more products. So on that note, I think I am good where it comes to this. 

    The only exception has been of the old pages that had page_.php extentions that created the fatal error page. I would love to be able to resolve those.  Should I begin a new topic for this?

    I suspect that those php pages were connected to the old Instant Download Cart (the folder was called idc in my cpanel)  had everything to do with it,  I knew I was not going to use the idc as it was no longer working out so I deleted the idc file. I don't know how to proceed with eliminating those fatal error links.  Anything with the php extention seems to be giving that fatal result.  I think for those products I did not have a html page, at all, just the idc cart page that created those page_.php pages that are no longer working. The reason for doing that was I had a page limit with my hosting package and I found that was a way to get around to add additional products. Anyway,

    Example:   http://sharimariecreations.com/page95.php


    Warning: require_once(init.php): failed to open stream: No such file or directory in /home1/sharimw/public_html/page95.php on line 2

    Fatal error: require_once(): Failed opening required 'init.php' (include_path='.:/opt/php56/lib/php') in /home1/sharimw/public_html/page95.php on line 2

  14. yes, my example left off the ,L   I have it correct in the cpanel htaccess.  oversite when I copied and pasted it here. Thank you.

    I wondered why some products in sub categorys do not show the sub categories in the address bar. like this one,

    http://sharimariecreations.com/paper-doll-collection.html     (Paper Dolls Product)

     

    Others are showing the subcategory but not the product name like this one. Seems odd to me.

    http://sharimariecreations.com/design-collections/children-s-collections/.html     (Furry Friends Product)  

    BOTH are in the Children's category.   Just courious.  I have gotten both re directed successfully by closely adhering to your instructions about using exactly what is in the address bar, but still, made me courious.

    As always, thanks again.

  15. Thanks, I just meant the line spacing,  I wont change spacing in the command itself.   That 500 scared the dickens out of me but ill give it another shot with line spaces so I can clearly see what I am pasting in.

    Tell me if this is wrong or right.  As I am rewriting,  I have been going to the product online, (meaning not in the cpanel).  If when I am viewing the actual product page for that item, the address bar shows the /catagory/sub catagory/product.html  do I also include the sub catagories in the rewrite? or just the product itself as you indicated below.

    RewriteRule ^page89\.html$ http://sharimariecreations.com/hen-house-collection.html [NC,R=30]

    OR for example for my Bug Jar Collection  that has a sub category, found at   http://sharimariecreations.com/best-sellers/bug-jar-collection.html

    RewriteRule ^page35\.html$ http://sharimariecreations.com/best-sellers/bug-jar-collection.html [NC,R=30]     

    Could have adding that sub category caused the 500 disaster last night?

  16. 13 hours ago, havenswift-hosting said:

    The 500 error you received was due to incorrectly editing the .htaccess and either deleting or adding something that shouldn't been there - it is very unforgiving of any tiny mistake.

    It is 100% worth the effort of adding every single old style URL that is either embedded on any other site or is already indexed by Google (try the following search in Google but without the quotes   "site:sharimariecreations.com"   and see what it returns !). Benefits include retaining Google link juice (which is very important for rankings) and user experience (you don't want people ever seeing the 404 if it can be helped).

    I agree, I don't want them seeing the 404 so I did edit the content wording  to mimic what my home page reads.  I still do want to rewrite as you and Bsmithers suggested. I guess I will give it another go.  Just to be clear , you said the 500 was due to my personal error. I do not want to give up . I want to proceed, but SAFELY  so if I create a empty space by spacing a few  lines in the area where I would be rewriting to so that i can clearly see what I am pasting in,  the spacing  will not create an issue will it? 

    I did google site:sharimariecreations.com as well and wow, tons of links to my site, new and old.  The only ones that do not seem to direct to my cc 404 page is the links that have  page__.php.  I guess I will ask the server host about that.

  17. I gave the Rewrite a try. copied, pasted, inserting the required info. in the same place,   we talked about before.

    ### Rewrite rules for SEO functionality ###
    <IfModule mod_rewrite.c>
      RewriteEngine On
      RewriteBase /         (here)

     The two you posted  worked, as did the next two I did  but when I got to the 5th one, the whole site crashed with 500 error, site not available. So, I immediately deleted the changes, all of them, and contacted my host server via chat. He said I was incorrectly using my htaccess before I even told him what I had done. It took him a while but he was able to get it restored to where it was before I made the changes to the htacess.  I was VERY careful not to delete a single thing when I added the rewrites. I don't really understand what went wrong. I was shocked that even after carefully removing the edits, I still was getting the 500 not available internal error. That was scary LOL  I thought, oh no....what have I done.  I'm not doing anything else tonight. Ill check back tomorrow to see what ideas you may have.  Thank you again Bsmittles, this  process is so interesting and I am learning so much. I have a long way to go obviously haha but I'm trying.

  18. I've  added those changes: 
    Redirect 301 /page89.html http://sharimariecreations.com/hen-house-collection.html
    Redirect 301 /page61.html http://sharimariecreations.com/paper-doll-collection.html
     

    When I type in     http://sharimariecreations.com/page89.html  it takes me to http://sharimariecreations.com/hen-house-collection.html?seo_path=page89

    it lands on the 404 page that I edited not on the new product page. (in this case the hen house collection page)

×
×
  • Create New...