Jump to content

stevebo

Member
  • Posts

    56
  • Joined

  • Last visited

Posts posted by stevebo

  1. That worked!!!

    Now I just have to figure out how to send the right fields to the gateway.  I hope I won't have to come begging for help with that.

    Many thanks.

    PS: Now that I look at it, I think as long as I use the right API Login ID in Cubecart, it should work (I hope!).  

  2. Under Manage Extensions, I have installed Authorize.net Gateway (SIM) installed.  It works great for accepting credit cards. [Note: I know this is deprecated in favor of Authorize.net Accept Hosted].

    Anyway, I would like to have a 2nd copy of this extension appear on my Checkout page so that I can separate e-Checks from Credit Cards.  One extension would be Priority 1  with the Description an image of a credit card, and the other would be Priority 2 with the Description an image of a check.

    Is this possible?  I just need a way for the Gateway to know whether a user will be entering ACH numbers or credit card numbers.

  3. 5 hours ago, Dirty Butter said:

    But it's NOT a plugin.

    While I am probably able to write the code, I would feel much better with a plugin.

    Do ACH transactions typically use a Gateway?  Or is it just that some platforms included it as an all-in-one solution?

  4. I have a Cubecart shopping cart that works great for processing credit card transactions using the Authorize.net extension.

    I would like to start accepting e-Checks or ACH payments as well but I am unsure how to accomplish this.  I know that e-checks and ACH are different, but I just don't know how to integrate them with my cart. I also don't know if I have to run these payments through my bank, my credit card merchant account, some other entity or the gateway itself.

    Everything I've read assumes I already know the ins and outs of such payments and how they work together, but it's all very confusing to me.  I would be ecstatic to learn how to start accepting such payments and integrate them with Cubecart.  

    Thanks,

    Steve

  5. On 12/28/2020 at 1:17 PM, Bill in Kansas City said:

    I'm on a Windows server, so it uses IIS' URLRewrite module.

    Hi Bill,

    I have the same problem but I cannot change my ISP's IIS server, much less its URLRewrite Module (whatever that is).  Would you let me know how to get my Cubecart installation to read .htaccess?  Do I need to create a web.config?  Or something else?

    Many thanks for any help,

    Steve

    Apparently I battled this same exact problem 3 years ago: 

    https://disqus.com/home/discussion/cubecartknowledgebase/iis_rewrite_rules_to_prevent_page_not_found_errors_powered_by_kayako_help_desk_software/?utm_source=reply&utm_medium=email&utm_content=read_more#comment-3643669502

    Only now, my web.config doesn't seem to be read (maybe because it's in a parent directory?):

      <!--This is for Cubecart!!!-->
      <system.webServer>
        <httpErrors errorMode="Detailed"/>
        <rewrite>
          <rules>
            <rule name="rule 1R" stopProcessing="true">
              <match url="^cubecart/(.*)\.html?$" />
              <action type="Rewrite" url="/cubecart/index.php?seo_path={R:1}" appendQueryString="true" />
            </rule>
          </rules>
        </rewrite>
      </system.webServer>

     

    Please let me know how to "hook this up" to my new cubecart installation.

  6. 10 hours ago, bsmither said:

    MS-IIS does not use the .htaccess file.

    While this seems to be the problem, my previous CubeCart installation, 6.1.13 seemed to read the file just fine.  Or at least didn't fail.  Maybe the SEO functionality was missing in the earlier version I was running.

    But now I have to contact my ISP to hack up IIS and I know that this will take at least a week for them to do, especially since I'm not all that clear on how rewrite rules work myself.

  7. Very sorry to hear about the earthquake @NebojsaIt makes our installation problems seem very small.

    I still have the problem, but it seems that my installation is not reading .htaccess at all on my Windows server.  It seems that it doesn't matter how I change .htaccess, the changes are ignored.  I even changed the 404 error in the code to throw different errors just to see if anything changed, and it didn't.

     

  8. I just upgraded from Cubecart 6.1.13 to 6.4.2.  Progress was slow but steady.

    When everything was in place, I tested out the shopping cart and every category (or document) I click on gives a 404 error.  Everything points to the mappings in the .htaccess file because this link https://fitpacking.com/cubecart/trips.html gives me an error, but this one works fine: https://fitpacking.com/cubecart/index.php?seo_path=trips.html.

    It seems that this line in .htaccess does the translation:

      RewriteRule ^(.*)\.html?$ index.php?seo_path=$1 [L,QSA]

    But no matter what I do to .htaccess nor how I change it, it does not seem to affect anything at all.  Is there some config or ini file in which you specify .htaccess?  I have attached the file although I think it's not getting read in at all (yes, it's in my CubeCart root directory).

     

    .htaccess

  9. 5 hours ago, bsmither said:

    RewriteRule ^(.*)$ index.php?seo_path=$1 [L,QSA]

    I am having the exact same problem with 404 when I click on any category, page or item.  I tried changing the line in .htaccess but it didn't work.

    Any other ideas?

    Thanks,

    Steve

  10. SemperFi contacted me and said that all the Token does is extract a folder from the Zip file (which I am able to download) and place it in the /modules/plugins directory.  Once I did that, I could configure the extension.

    They also said that the Token was something they had no control over.  But the workaround worked well.

  11. I just purchased Google Tag Manager Extension but am unable to get the Token to work in Manage Extensions.  I get

    "Error: Token was not recognised or has expired"

    I sent a message to SemperFi, but figured I'd ask here as well.  Any ideas?

  12. CubeCart has been working great for me.  However, I just received an order whose Order Status is "pending" instead of "processing".  I log into my Payeezy Gateway and don't see the transaction at all.

    I am trying to figure out what happened.  There's no record of it in the Transaction Log or Error Log.  Just a pending transaction in Orders.

    Does this typically mean the transaction was declined?  Or does it indicate something else?  What else can I check?

    Thanks, Steve 

  13. Good idea!  I don't see anything in the error logs, but in the transaction logs, 3 of the 7 orders were declined.  The others appear to be pending.

     

    The customer saved their profile.  Is it possible that the credit card was entered erroneously and saved into the profile so that every time the person came back to try to place the order again that it got rejected?

  14. My Cubcart installation has been working just fine for several weeks now.  However, one customer last night was denied for some reason

    Quote

    I tried several times to put a deposit but was sent a message denied due security

    I received several confirmation emails from Cubecart that did not indicate any problems, as the customer tried repeatedly to submit the payment.  The Cubecart Admin > Dashboard > Orders show all these transactions as Pending.  The First Data Payeezy Global Gateway shows nothing at all, as if the transactions never happened.

    I received a confirmation from Cubecart about an order from someone else last night as well.  Same situation ... it appears in Cubecart Admin as Pending but it never made it to the Gateway. The customer didn't contact me.

    Just to be sure, I ran a test transaction myself this morning, and it worked fine just as expected.

    Does anyone know what might be going on?

    Thanks,

    Steve

  15. Well what do you know?  It was an issue with the hosting company, maybe the IIS server as you indicated (they didn't tell me) but they fixed it.  So all of your settings worked, it was an issue on their end.  I very much appreciate your sage advice.  Thank you!

  16. I checked .htaccess and no changes in either folder.

    One possibility is that because this runs on a windows server, https://www.fitpacking.com/cubecart won't see index.php, so I wrote up a re-direct page index.html that uses this:

    <meta http-equiv="refresh" content="0; URL=https://www.fitpacking.com/cubecart/index.php">

    This re-directs to https://fitpacking.com/cubecart/index.php where I receive the Too Many Redirects error.  Maybe it's a Windows thing?

    But even when I directly type in the URL https://fitpacking.com/cubecart/index.php, I still get the error although sometimes the error is: 503 Service Temporarily Unavailable

    I feel like I'm missing something really obvious.

  17. Hi Cubecart community!

    I just upgraded my website to have an SSL secure certificate.  However, this seems to break Cubecart.  Well maybe not exactly break it, but it isn't secure.

    The shopping cart still works fine in an un-secure mode: http://fitpacking.com/cubecart/index.php, as it bypasses SSL.  But when I get to the checkout screen, I see this "not secure" browser window:

    image.png.60511b1f4d324d76036035892de717ef.png

     

    I have tried to force the issue using https://fitpacking.com/cubecart/index.php but this somehow ruins the markup or breaks the Javascript or something.

    Do you have any suggestions on how to get the SSL certificate working with Cubecart?

    Thanks,

    Steve

     

×
×
  • Create New...