Jump to content

WSD

Member
  • Posts

    33
  • Joined

  • Last visited

Posts posted by WSD

  1. Hi Guys

     

    I have a quick question relating to the store collection module. Is it possible to add a second location to this module or do i have to install another copy of the module for each location?

     

    Thanks

  2. Hi Guys,

     

     I need your help again, Very recently i am having a problem with the order emails from cubecart not being sent to the customer.

    I receive the confirmation emails but the customer emails are blocked and I get a notification email to say the email was "blocked by the security gate way". It says in the email it was blocked due to the "message content".

    Any ideas on where to start with this?

     

    Thanks

    Wil

    Screenshot 2021-09-04 143546.png

  3. I have decided to start a new thread instead of keep adding to an somebody elses old one.

    Last week i upgraded to the lastest version of all in one shipping module and now any time i try to make a change i get a CSRF warning.

    Bsmither was trying to help me get this sorted but we never managed to find a solution.

    I really need to get this sorted.

    Any ideas?? Bsmither was working on the admin file not being correct but when we changed that then i was unable to login to admin side of my website.

    Starting to wish i never bothered with the update now 😭

     

    Thanks for your help 

    Wil

  4. Hi everyone

     

    I have tried searching for answers to this question and cannot seem to find an answer.

    I have been working heavily on my meta data recently and having searched the main go to search engine i am seeing my results coming back showing the products meta data title but instead of the meta data description it is pulling information from the product description. Is there something i can change on the site settings or files to stop this happening or is this the search engine in question just pulling up this information?

  5. I am currently running 6.2.9 version of cubecart.

     

    Would it be easier if i was to private message you with admin logins?

     

    so you could do the debug thing yourself as you know what it is you are looking for and im just guessing

  6. 1 hour ago, bsmither said:

    In admin, Store Settings, Advanced tab, enable the Debug mode and enter your workstation's IP address in the adjacent field (www.showmyip.com).

    Then, in the AIOS module, Save some changes.

    On the next page shown, at the bottom will be a grey section showing debug info. There will be two iterations: when data was processed from the POST, and when new data was collected to be shown on the next screen.

    Find the POST: list in the first iteration of debug data. There could be a complicated array, but what you are looking for is a 'token' element at the bottom of the POST: list.

    If it is not there, we need to find out why.

    If it is there, then compare it with SESSION:, '__system', 'token_acp'. (Mine isn't changing after every POST for some reason.)

     

    Is this what you are looking for? 

    debug.png

    Not sure if this helps but have cleared the error logs as well then tried to make the changes and this is what is showing in the error logs

     

      Date Message
    Today, 21:49 File: [controller.admin.pre_session.inc.php] Line: [26] "SET @@time_zone = 'Europe/London'" - Unknown or incorrect time zone: 'Europe/London'
    Today, 21:49 File: [controller.admin.pre_session.inc.php] Line: [26] "SET @@time_zone = 'Europe/London'" - Unknown or incorrect time zone: 'Europe/London'
    Today, 21:49 File: [controller.admin.pre_session.inc.php] Line: [26] "SET @@time_zone = 'Europe/London'" - Unknown or incorrect time zone: 'Europe/London'
    Today, 21:49 File: [controller.admin.pre_session.inc.php] Line: [26] "SET @@time_zone = 'Europe/London'" - Unknown or incorrect time zone: 'Europe/London'
    Today, 21:49 File: [controller.admin.pre_session.inc.php] Line: [26] "SET @@time_zone = 'Europe/London'" - Unknown or incorrect time zone: 'Europe/London'
    Today, 21:49 File: [controller.admin.pre_session.inc.php] Line: [26] "SET @@time_zone = 'Europe/London'" - Unknown or incorrect time zone: 'Europe/London'
  7. 19 hours ago, bsmither said:

    A CSRF warning will happen if the collection of key/value pairs in the POST (what gets sent back to CubeCart when you click Save) exceed the number of pairs allowed by PHP - thus cutting off the final key/value pair that contains CubeCart's security key.

    This module is known for having an elaborate array of shipping rates that could easily exceed 1000 key/value pairs when only a few dozen rate tables are created amongst a few shipping zones.

    The solution to this is to configure PHP to accept more key/value pairs in POST. However, there are several ways to do this and depending how your environment is setup, only some of the methods will work. So, you may need to get your hosting provider involved.

    What you want is PHP's config key max_input_vars to have a value of 5000 (currently, defaults to 1000). This setting is available in PHP.INI, and can also be made in .user.ini, and/or .htaccess depending how PHP interacts with the server (CGI/FastCGI or Apache mod).

    If you have cPanel as your hosting account's control panel, there may be this:

    Look for that panel.

    Hi Bsmither

     

    My max_input_vars is already set to 8000 so increased it to 10000 and still the same problem.

    I have cleared all cache data and still getting the same issue

  8. Hi guys

     

    I have tried searching for the answers to my questions but cant seem to find the answer.

     

    I want to make a couple of small changes to the invoice layout in my cubecart 6 store but cant seem to find the correct file to make them work.

     

    1st - I would like to get the 'Thanks for shopping with us' footer to move to the bottom of the page rather than just at the end of the product info which leaves it floating around the middle of the page

     

    2nd - is there a way i can set the customers postcode to show on the next line down rather than beside their county?

     

    As always all help much appreciated.

     

    Thanks

    Wil

  9. I have a problem with this payment gateway again.

     

    It will not process any payments if i have new recaptcha(recommended) turned on. The site is just telling customers that their order is pending and nothing else happens. However if i turn recaptcha off everything goes through immediately, and changes the order status to processing. For obvious reasons i would like to leave recaptcha running to stop all bogus constant form enquiries. Is there anyway to turn recaptcha off for this module or a fix that means i can get it to work?

     

    Lost a big sale due to this today, customer went else where.

     

    As always all advice and help appreciated.

    Wil

×
×
  • Create New...