Jump to content

Robo

Member
  • Posts

    153
  • Joined

  • Last visited

Everything posted by Robo

  1. Robo

    multisafepay

    there are several gateway class modules maybe they are all the same as for every type of payment there is one thanks in advance gateway.class.php
  2. Robo

    multisafepay

    will try to find the original install as it dates back.....
  3. Robo

    multisafepay

    to be short multisafepay does not have a module for cubecart , or will develop it sorry to hear that , they said maybe you can go back to php 5 ...
  4. Robo

    multisafepay

    OK thanks for the info, lets see what they can do for me
  5. What happened to the multisafepay payment ? i have it for many years but i do get errors now , multisafepay says it is not a know platform for them , this is th error Methods with the same name as their class will not be constructors in a future version of PHP; MspAlternateTaxRule has a deprecated constructor https://www.rbckits.com/shop/index.php?_a=gatewaymutingErrorHandler() (gateway.class.php:26) require() (gateway.class.php:26) transfer() (cubecart.class.php:1957) _displayGateways() (cubecart.class.php:2173) _gateway() (cubecart.class.php:448) loadPage() (controller.index.inc.php:90) include() (index.php:20) Apr 04 2022, 16:59 pm [<strong>Deprecated</strong>] /home/u68474p65147/domains/rbckits.com/public_html/shop/modules/gateway/Multisafepay/api/MultiSafepay.combined.php:3373
  6. ok that is good to know, first lets see what my bookkeeper says about this brexit tax thing else it is not neccesary .. i hope
  7. That is for max amount , maybe there is a workaround like shipping value ? if the minimum is set to for example €155 then there would be no shipping option , or am i mistaken ?
  8. is it possible to have a minimum sales amount for the uk only ? this has to do with the brexit as under the 135 pound we must pay tax to uk (this is problematic) and above the 135 pound no tax but the customer is controlling it , Any help would be appricieated , as i also heard that per June or July more of these things happening in all eu so limkits are helpfull for this Thanks in advance
  9. a few new ones File: [seo.class.php] Line: [726] "INSERT INTO `CubeCart_seo_urls` (`type`,`item_id`,`path`,`custom`) VALUES ('prod','','-p.html','0');" - Duplicate entry '-p.html' for key 'PRIMARY' Nov 21 2020, 12:28 pmFile: [catalogue.class.php] Line: [1051] "SELECT SQL_CALC_FOUND_ROWS * FROM `CubeCart_inventory` WHERE `product_id` IN (913,996,468,469,470,471,472,473,474,475,992,606,627,686,713,714,760,1009,838,873,875,889,891,965,921,939,940,941,942,943,944,981,983,1015) AND CubeCart_inventory.status = '1' AND `live_from` < UNIX_TIMESTAMP() ORDER BY `name` ASC LIMIT 12 OFFSET 2.6545345345453E+14;" - You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near '2.6545345345453E+14' at line 1
  10. sorry no time to check for this it is so busy here will try to do asap
  11. sorry no gift certificates, just orders
  12. the errors started directly after the latest upgrade 6.4.1
  13. same here File: [seo.class.php] Line: [726] "INSERT INTO `CubeCart_seo_urls` (`type`,`item_id`,`path`,`custom`) VALUES ('prod','','-p.html','0');" - Duplicate entry '-p.html' for key 'PRIMARY'
  14. yes it worked thanks a lot btw i have a lot of errors after upgrading like these ones any thougths ? File: [seo.class.php] Line: [726] "INSERT INTO `CubeCart_seo_urls` (`type`,`item_id`,`path`,`custom`) VALUES ('prod','','-p.html','0');" - Duplicate entry '-p.html' for key 'PRIMARY'
  15. maybe i am dumb so these 2 lines $same_site = CC_SSL ? 'samesite='.$params['samesite'] : ''; return setcookie($name, $value, replace with $same_site = CC_SSL ? 'samesite='.$params['samesite'] : ''; if (PHP_VERSION_ID < 70300) { return setcookie($name, $value, $expire, $params['path']."; $samesite", $params['domain'], $params['secure'], $params['httponly']); } else { return setcookie($name, $value, [ 'expires' => $expire, 'path' => $params['path'], 'domain' => $params['domain'], 'secure' => $params['secure'], 'httponly' => $params['httponly'], 'samesite' => (CC_SSL ? $params['samesite'] : ''), ]); } is this correct or ?? i do not understand as this is exact what you wrote in previuos post
  16. again it does not work , in the admin site we get a 500 error all blank what we did $same_site = CC_SSL ? 'samesite='.$params['samesite'] : ''; return setcookie($name, $value, 'expires='.$expire.';path='.$params['path'].';domain='.$params['domain'].';secure='.$params['secure'].';httponly='.$params['httponly'].';'.$same_site); } replaced with $same_site = CC_SSL ? 'samesite='.$params['samesite'] : ''; if (PHP_VERSION_ID < 70300) { return setcookie($name, $value, $expire, $params['path']."; $samesite", $params['domain'], $params['secure'], $params['httponly']); } else { return setcookie($name, $value, [ 'expires' => $expire, 'path' => $params['path'], 'domain' => $params['domain'], 'secure' => $params['secure'], 'httponly' => $params['httponly'], 'samesite' => (CC_SSL ? $params['samesite'] : ''), ]); }
  17. that is what i did in the begin, but it is not working , will give it another try
  18. we did exactly as given In /classes/session.class.php, near line 583, find the public function set_cookie(). Find: $same_site = CC_SSL ? 'samesite='.$params['samesite'] : ''; return setcookie($name, $value, 'expires='.$expire.';path='.$params['path'].';domain='.$params['domain'].';secure='.$params['secure'].';httponly='.$params['httponly'].';'.$same_site); Change to: $same_site = CC_SSL ? 'samesite='.$params['samesite'] : ''; if (PHP_VERSION_ID < 70300) { return setcookie($name, $value, $expire, $params['path']."; $samesite", $params['domain'], $params['secure'], $params['httponly']); } else { return setcookie($name, $value, [ 'expires' => $expire, 'path' => $params['path'], 'domain' => $params['domain'], 'secure' => $params['secure'], 'httponly' => $params['httponly'], 'samesite' => (CC_SSL ? $params['samesite'] : ''), ]); } please what ? should be replaced with what ?, as i do not understand , as this was posted by you and it is not clear for me , thanks anyway
  19. wel replaced $same_site = CC_SSL ? 'samesite='.$params['samesite'] : ''; return setcookie($name, $value, 'expires='.$expire.';path='.$params['path'].';domain='.$params['domain'].';secure='.$params['secure'].';httponly='.$params['httponly'].';'.$same_site); } with $same_site = CC_SSL ? 'samesite='.$params['samesite'] : ''; if (PHP_VERSION_ID < 70300) { return setcookie($name, $value, $expire, $params['path']."; $samesite", $params['domain'], $params['secure'], $params['httponly']); } else { return setcookie($name, $value, [ 'expires' => $expire, 'path' => $params['path'], 'domain' => $params['domain'], 'secure' => $params['secure'], 'httponly' => $params['httponly'], 'samesite' => (CC_SSL ? $params['samesite'] : ''), ]); } and it did not work
  20. the core changing did not work, it all quit error 500 does not laod anything skin change .. now it loads the privacy document when clikking the link in the cooky banner error report [<strong>Exception</strong>] /home/u68474p65147/domains/rbckits.com/public_html/shop/classes/session.class.php:611 - syntax error, unexpected 'private' (T_PRIVATE)
  21. yes i did check that and put it to on (it was off) , but it does not change anything just get a bad request same as before
  22. the cooky dialog is on top of the screen you can not click it away it stays there and the link in the coocky dialog does not work try it i have no foundation skin used btw i only did the upgrade and that worked fine , on some 404 s but that was solved quick and before the upgrade it worked all ok
×
×
  • Create New...