Jump to content

sleepyfrog

Member
  • Content Count

    82
  • Joined

  • Last visited

Community Reputation

0 Neutral
  1. sleepyfrog

    Pending to Process Problems - tried fixes on Forum

    Doh! You have found my stupid error! On our hosting we have multiple areas/sites which all have their own 'admins' - so I had renamed the cubecart admin folder with a suffix. Whilst I remembered to change the location for anything referencing it, including our .htaccess set up, I had forgot about the global.inc.php file. The page is now redirecting as it should. (Weird how everything else worked, but hey ho.) No idea why it's started to auto update from the Paypal notifications again - no doubt it'll go funny again the next time they 'upgrade' the hosting. Thank you for all your help - wishing you a Happy New Year and all the best for 2018 :-) Carol
  2. sleepyfrog

    Pending to Process Problems - tried fixes on Forum

    Ok - weird things lol. Enabled debugging and tried again - this time it worked, sort of: Can manually change status from Pending to Processing when going to the order via the Orders option in the left nav bar. However, if you click on the order via the Dashboard > Unsettled Orders link it updates the status ok, but returns the 404 error page as it's adding characters to the URL - admin_MxFTXQ.php#orders - when I assume it should just be admin.php#orders No errors shown in the debugging text and nothing logged in System Logs. I need to verify with the person who handles the orders, but I think it may have also gone back to updating the status to Processing from the code returned by Paypal; if so then I also assume this means it was something to do with the hosting rather than the store code. I'm definately getting too old for all this - maybe 2018 is the year I finally run off to join a circus....... :-D
  3. sleepyfrog

    Pending to Process Problems - tried fixes on Forum

    Nope - nothing logged at all :-/
  4. sleepyfrog

    Pending to Process Problems - tried fixes on Forum

    Thanks - no idea who deleted the code, but uploaded the file from the base code, changed lines from 309 as you suggested, cleared caches and still having the same problem. Happens from either the Dashboard or within the Orders section - try to change an order status from Pending to Processing and just goes to a blank screen. It's not due to multiple windows open as I tried it with nothing open but the store admin. Unfortunately I don't have access to the server logs, just the log Cubecart creates and there was nothing logged at the time I was testing.
  5. sleepyfrog

    Pending to Process Problems - tried fixes on Forum

    This is from line 309 to the end: $tmp1 = 0; $tmp2 = 0; $system = array( 'cc_version' => CC_VERSION, 'cc_build' => null, 'php_version' => PHP_VERSION, 'mysql_version' => $GLOBALS['db']->serverVersion(), 'server' => htmlspecialchars($_SERVER['SERVER_SOFTWARE']), 'client' => htmlspecialchars($_SERVER['HTTP_USER_AGENT']), 'dir_images' => dirsize(CC_ROOT_DIR.'/images', $tmp1), 'dir_files' => dirsize(CC_ROOT_DIR.'/files', $tmp2), ); $GLOBALS['smarty']->assign('SYS', $system); $GLOBALS['smarty']->assign('PHP', ini_get_all()); $GLOBALS['smarty']->assign('COUNT', $count); $GLOBALS['main']->addTabControl($lang['common']['search'], 'sidebar'); foreach ($GLOBALS['hooks']->load('admin.dashboard.custom_quick_tasks') as $hook) include $hook; if(isset($custom_quick_tasks) && is_array($custom_quick_tasks)) { $GLOBALS['smarty']->assign('CUSTOM_QUICK_TASKS', $custom_quick_tasks); } $page_content = $GLOBALS['smarty']->fetch('templates/dashboard.index.php');
  6. sleepyfrog

    Pending to Process Problems - tried fixes on Forum

    1) I didn't have multiple windows open 2) The entire code you referenced doesn't appear in my dashboard.index.inc.php at all. The only place where $GLOBALS['session'] is referenced is ## Save notes if (isset($_POST['notes']['dashboard_notes']) && !empty($_POST['notes']['dashboard_notes'])) { $update = array('dashboard_notes' => $_POST['notes']['dashboard_notes']); if ($GLOBALS['db']->update('CubeCart_admin_users', $update, array('admin_id' => Admin::getInstance()->get('admin_id')))) { $GLOBALS['session']->delete('', 'admin_data'); $GLOBALS['main']->setACPNotify($lang['dashboard']['notice_notes_save']); } else { $GLOBALS['main']->setACPWarning($lang['dashboard']['error_notes_save']); } httpredir(currentPage()); } I am running 6.1.1
  7. sleepyfrog

    Pending to Process Problems - tried fixes on Forum

    Thanks for responding. The only errors logged during the time I was testing the system are: Invalid Security Token in /home/cluster-sites/4/m/***.co.uk/public_html/classes/sanitize.class.php on line 149 array_keys() expects parameter 1 to be array, boolean given in /home/cluster-sites/4/m/***.co.uk/public_html/admin_TMo7iI/sources/dashboard.index.inc.php on line 311 I assume these are when trying to manually change the status from Pending to Processing. There are no errors logged with respect to Paypal and why the orders aren't being changed to Processing automatically.
  8. Store version 6.1.1 (can't upgrade yet as lots of changes made to templates) Gateway; Paypal Standard - latest mod Store is registering order but not updating to 'Processing' when payment made and can't manually change as just get a blank screen. Getting paypal notifications through OK if payment refunded - order status changes to Cancelled. Changed timeout to 45 in request.class.php Uploaded latest sanitize.class.php from GitHub Recently installed an SSL on website so checked all referenced URLs are https Anyone any other ideas? It's driving me mad!
×