Jump to content

scythe000

Member
  • Posts

    155
  • Joined

  • Last visited

Everything posted by scythe000

  1. Does this mean it looks like it is actually a Cubecart bug?
  2. I mean, it’s GoDaddy. I would think that if it were misconfigured by default on one of their standard packages, that would get noticed pretty quick
  3. I think it’s when I switched from 7.2 to 7.4 that it broke things, and I just didn’t notice. Under my cPanel hosting, memcached is selected. It wasn’t before, and I was getting even more of those errors, then I made sure to select it, and I get much less of them.
  4. Since the store front and the admin page goes to white screen, I can’t access the admin backend. Switching to 'file' fixes it. Now...it's been working fine for years on memcached...is it a php 7.3/7.4 bug?
  5. Was on php 7.4, tried rolling back to 7.3 but similar issues: PHP Warning: Cache data not written (Memcached). in /home/xxxxxx/public_html/tingyen/classes/cache/memcached.class.php on line 255 that section reads: //Write to file if ($this->_memcached->set($name, $data, (!empty($expire) && is_numeric($expire)) ? $expire : $this->_expire)) { return true; } trigger_error('Cache data not written (Memcached).', E_USER_WARNING); Any ideas?
  6. Luckily, they did have memcached as a PHP option. I enabled it, and edited the global.inc.php, and all seems to be running fine on php 7.1!
  7. I can't even get phpinfo to load on the CC sites, but heres one from my wordpress site on the same host. Could it be an issue with my php.ini? session.save_path = "/tmp/" register_globals = off allow_url_fopen = off expose_php = Off max_input_time = 60 variables_order = "EGPCS" extension_dir = ./ upload_tmp_dir = /tmp precision = 12 SMTP = relay-hosting.secureserver.net url_rewriter.tags = "a=href,area=href,frame=src,input=src,form=,fieldset=" [Zend] zend_extension=/usr/local/zo/ZendExtensionManager.so zend_extension=/usr/local/zo/4_3/ZendOptimizer.so zend_extension=/home/content/xxx/html/ioncube/ioncube_loader_lin_5.2.so
  8. Hmm...apcu is enabled they say...but still getting this: Fatal error: Uncaught Error: Call to undefined function apc_fetch() in /home/store/classes/cache/apc.class.php:172 Stack trace: #0 /home/store/classes/cache/apc.class.php(235): Cache->read('sql.empties') #1 /home/store/classes/cache/cache.class.php(113): Cache->_getEmpties() #2 /home/store/classes/config.class.php(78): Cache_Controler->enable(true) #3 /home/store/classes/config.class.php(97): Config->__construct(Array) #4 /home/store/controllers/controller.index.inc.php(22): Config::getInstance(Array) #5 /home/store/index.php(20): include('/home/xxx...') #6 {main} thrown in /home/store/classes/cache/apc.class.php on line 172 Interestingly, I'm seeing a lot of comments on various threads that APC is no longer being actively developed and alternatives should be used? https://www.inmotionhosting.com/support/website/php-configuration/install-apc-for-php It does look like my server supports memcached and redis. Would one of those be a better choice than file?
  9. Aha, ok, let me call them about that. Thank you!
  10. Hi all! I'm on 6.2.0 and PHP 5.6. I'd like to upgrade to PHP 7.0 or 7.1, but i get this error on both my sites: Fatal error: Uncaught Error: Call to undefined function apc_fetch() Any thoughts? GoDaddy cPanel Linux hosting.
  11. i got this error going from 6.1.8 to 6.1.10 and i'm still getting it going from 6.1.10 to 6.1.12. Any thoughts?
  12. ok, got it sorted out. Doing a manual install, setup mentioned that Zip was still missing. I found it in another section of cPanel and enabled it, and all seems well again.
  13. I'll try a manual install next. Restarting PHP didn't seem to help.
  14. It's on a godaddy linux server wit hcPanel. I went and installed Archive_Zip (0.1.2) Zip file archiving management class, but it seems to not have helped. Do i need to restart PHP? The weird thing is, i think it was working before, because i believe i ran backups right after moving it.
  15. When I try to run a file backup, db backup, or upgrade I get this error: This page isn’t working mysite.com is currently unable to handle this request. HTTP ERROR 500 This site had recently been moved to a new host, but all other functions seem to work ok.
  16. Is it a problem if I just leave my .htaccess file deleted? Everything seems to be working now with it gone.
  17. AFAIK, it was working fine before i migrated it to my new host. It's a Linux cPanel host. aha! It's something to do with the .htaccess file. If I delete it, the site looks weird, but i can browse just fine. Got a vanilla one i can try?
  18. I can try swapping it with the one from my working site on the same host. Edit: no luck Actually, it's worse than i thought, all links are giving the same error.
  19. I think i have a default .htaccess: ##### START CubeCart .htaccess ##### ## File Security <FilesMatch "\.(htaccess)$"> Order Allow,Deny Deny from all </FilesMatch> #### Apache directory listing rules #### DirectoryIndex index.php index.htm index.html IndexIgnore * #### Rewrite rules for SEO functionality #### <IfModule mod_rewrite.c> RewriteEngine On RewriteBase / ######## START v4 SEO URL BACKWARD COMPATIBILITY ######## RewriteCond %{QUERY_STRING} (.*)$ RewriteCond %{REQUEST_FILENAME} !-f RewriteRule cat_([0-9]+)(\.[a-z]{3,4})?(.*)$ index.php?_a=category&cat_id=$1&%1 [NC] RewriteCond %{QUERY_STRING} (.*)$ RewriteCond %{REQUEST_FILENAME} !-f RewriteRule prod_([0-9]+)(\.[a-z]{3,4})?$ index.php?_a=product&product_id=$1&%1 [NC] RewriteCond %{QUERY_STRING} (.*)$ RewriteCond %{REQUEST_FILENAME} !-f RewriteRule info_([0-9]+)(\.[a-z]{3,4})?$ index.php?_a=document&doc_id=$1&%1 [NC] RewriteCond %{QUERY_STRING} (.*)$ RewriteCond %{REQUEST_FILENAME} !-f RewriteRule tell_([0-9]+)(\.[a-z]{3,4})?$ index.php?_a=product&product_id=$1&%1 [NC] RewriteCond %{QUERY_STRING} (.*)$ RewriteCond %{REQUEST_FILENAME} !-f RewriteRule _saleItems(\.[a-z]+)?(\?.*)?$ index.php?_a=saleitems&%1 [NC,L] ######## END v4 SEO URL BACKWARD COMPATIBILITY ######## RewriteCond %{REQUEST_FILENAME} !-f RewriteCond %{REQUEST_FILENAME} !-d RewriteCond %{REQUEST_URI} !=/favicon.ico RewriteRule ^(.*)\.html?$ index.php?seo_path=$1 [L,QSA] </IfModule> ## Default store 404 page ErrorDocument 404 /index.php ##### END CubeCart .htaccess ##### I tried switching to the Foundation skin, and the same error happens.
  20. Whenever I click on a category link I get this error: Internal Server Error The server encountered an internal error or misconfiguration and was unable to complete your request. Please contact the server administrator at [email protected] to inform them of the time this error occurred, and the actions you performed just before this error. More information about this error may be available in the server error log. Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.
  21. That did it! Phew! Now, for the issue with my other site, should I do it as a seperate thread, or continue here?
  22. yeah, but i've been upgrading pretty regularly throughout the years. You'd think that the Maintenance/Database tab would be telling me i'm missing things.
×
×
  • Create New...