Jump to content

Search the Community

Showing results for tags 'cubecart v6'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • CubeCart News & Announcements
    • News & Announcements
  • CubeCart Support Forums
    • Issue / Bug Reporting & Feature Requests
    • Install & Upgrade Support
    • Official CubeCart Hosting
    • Technical Help
    • Customising Look & Feel
  • CubeCart Extension Marketplace
    • Visit the CubeCart Extension Marketplace
    • Extension Discussion
    • Developer Forum
  • General
    • General Discussion
    • Show Off

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Location

  1. I've noticed since 6.4.0 there is a template file: main.stream.php, but there doesn't seem to be anything in the admin panel that references streaming. What is it's purpose and how do I use/access it?
  2. Hi, After managing to recover my site Delightful Hair & Beauty to a functional state I have now discovered that when using the Search function I sometimes encounter an ISE 500 error. This seems to be caused by certain words. If you search for 'OSMO' the website functions as expected. However if you search for 'Wella' the ISE can be seen. This happens with other word/letter combinations too. It also happens using the 'Search Product' function in the Admin of the store. Any ideas? I am about to pull my hair out, of which I don't have much left!
  3. I'm wondering if there is a Wordpress plugin so CubeCart integrates as smoothly as Woo Commerces does.
  4. I recently upgraded to 6.4.3 and now am having serious issues with 500 errors. Especially when trying to access the Image File Manager in the Admin. I also get it sometimes on the main page of my site but will go if I refresh a few times. I did a backup before upgrading and would like to roll back to 6.4.2. What is the easiest way? Is the file listed in the Backups as 'Cubecart-6.4.3.zip' all the affected files as they were BEFORE the upgrade? Do I just need to extract these to my site? I get the following error when in debug mode....
  5. I work on a Mac and use Safari more often than not, but I have both Chrome and Firefox loaded. I've noticed before and again today, that the two browsers report differently. Today, Chrome informed me via the Admin/dashboard page, that 6.4.3 was available and that PayPal commerce had an update available. Neither of these appear in Safari. From previous experience it may be a few days before Safari shows these things. Whilst its not a big problem, I'd like to understand what causes the problem and what I can do to change it. I'm sure it must be "something" to do with the way the cache works on each of the browsers, but ... An help would be appreciated
  6. I use the "By weight" shipping module and it works really well for what I need. However, I often get rung by people wanting to buy things and needing to know a shipping cost before placing an order. So, what I think I need is either a spreadsheet (I use Apple numbers on my phone at work) or a dummy page in Cubecart so that I can put a weight into it and the formula will work out what the shipping would be. I think all the information is in the By Weight module, in shipping.class.php. I guess I could use the code in this module and a code hook to produce another page in Cubecart that I could then use an input box to provide the data into the shipping.class code? I'm getting to the outside limits of my knowledge and experience on code hooks, so whilst this is the most elegant solution (it'll always work with the real data in Cubecart) it may not be the simplest way of getting what I need. Has anyone any thoughts on doing this, or done anything similar? Thanks N
  7. Hello Everyone. The database for my cubecart 6.0 installation is missing the geo_country table. File: [cubecart.class.php] Line: [1193] "SELECT * FROM `CubeCart_geo_country` WHERE status > 0 ;" - Table 'jumperman_store.CubeCart_geo_country' doesn't exist Since we use Stelle's All-in-one-shipping module, it creates a problem where our users see this message when trying to check out. The following errors were detected: Unfortunately there are no suitable shipping methods available for your order. This may be because the total weight of your order is too high or we cannot ship to your country. Please contact a member of our staff for any further inquiries. We hadn't made any change on our end, so we have NO IDEA how the table came to be missing (PHP injection???), but we already checked through phpMyAdmin that the table indeed does not exist. Would somebody have a .sql.zip file with the countries table, or any other method to fix this problem. Will greatly appreciate!
  8. Hi I am trying to alter the layout of the categories menu and think I need to look at where this gets defined {if $CATEGORIES} {$CATEGORIES} {else} Can anyone point me to the right file please? thanks Paul
  9. Hello All, How do I edit the social media links in my backend? I try but the edits don't save. Any help is appreciated.
  10. how do you make the all in one shipping add say $5 for the first item and $1.00 for each additional item per category with free shipping over $100. some items are bigger than others and need to add differently for up to $100
  11. i am using 6.4.2 and karuto. when i add an item and then try to add another item, the picture from the last item i put on is in the new item i am trying to put on and i have to find the pic and disable it to put in the correct pic needed. any idea why this happens?
  12. i am upgraded to 6.4.2 and using karuto. when i use mozilla and go through check out it only goes to credit card check out and doesnt show the money order option. it also wont work with tablets.
  13. Under Manage Extensions, I have installed Authorize.net Gateway (SIM) installed. It works great for accepting credit cards. [Note: I know this is deprecated in favor of Authorize.net Accept Hosted]. Anyway, I would like to have a 2nd copy of this extension appear on my Checkout page so that I can separate e-Checks from Credit Cards. One extension would be Priority 1 with the Description an image of a credit card, and the other would be Priority 2 with the Description an image of a check. Is this possible? I just need a way for the Gateway to know whether a user will be entering ACH numbers or credit card numbers.
  14. I have latest version of cubecart 6.4.2 and creating products with product options, but when i choose price inc. VAT is calculated wrong in basket. when price is set without VAT than correct amount is added on top of option price and total is correct, also when main price is set to £0, option prices are calculated correctly but I need to have Main price displayed. Main Price set £10 inc. VAT Model A - £10 - absolute Model B - £20 - absolute Basket total for Model A is : £6.67 + VAT £1.13 = £8 ( this is if tax inc. is set in price tab) When I have 1 absolute price set it does not override main price in price tab which has to be £0 to calculate VAT correctly it will show product price still £0. Any advise would be great.
  15. I have a Cubecart shopping cart that works great for processing credit card transactions using the Authorize.net extension. I would like to start accepting e-Checks or ACH payments as well but I am unsure how to accomplish this. I know that e-checks and ACH are different, but I just don't know how to integrate them with my cart. I also don't know if I have to run these payments through my bank, my credit card merchant account, some other entity or the gateway itself. Everything I've read assumes I already know the ins and outs of such payments and how they work together, but it's all very confusing to me. I would be ecstatic to learn how to start accepting such payments and integrate them with Cubecart. Thanks, Steve
  16. What's the difference of these two? In my setup, is Status is checked and Available for purchase unchecked, users can buy the item. If status is unchecked, then it does not matter what Available is, the item is not available for purchase.
  17. This may be a feature request or impractical, but at the moment I cannot see a way to break the all in one shipping extension in to regions for the United Kingdom unless you enter all the UK postcodes. In particular I want to be able to exclude Northern Ireland from UK shipping due to changes brought about by Brexit which will come in to effect on 1st April. Ideally rather than entering all the postcodes for the UK which is a lot! it would be possible for the United Kingdom regions to include an option to exclude Northern Ireland however I appreciate this may not provide a perfect solution or even be possible.
  18. I'm having issues with customers unable to double opt in via our newsletter sign up when registering as a customer or subscribing from the newsletter sign up box, in the worst case senario the error message "sorry but we have not been able to validate your email address" is displayed across the top of the home page on a red banner. I have also noticed that when a customer is opted in and signed up the template box.newsletter.php is returning the message "you are not subscribed to our newsletter" when in fact they are subscribed and opted in. I have checked that I have the correct newsletter box template uploaded for the version of cubecart I am using but I just don't know where else to look to fix this problem which is loosing me customers. The screenshot shows one example of part of the problem I am having, the customer is in their account area, they are signed up and have a validated email yet it still says you are not signed up. Cubecart version is 6.4.2
  19. Hi All, I upgraded my store from v6.2.8 to v6.4.2 a couple days ago. The upgrade finished without any errors/warnings, and the store appears to be operating OK (I think)...however... I am unable to see any Transaction Logs in the Admin Control Panel. Zero. It's blank. I did use Maintenance > Rebuild > Clear transaction logs PRIOR to the upgrade to 6.4.2. I wanted a clean log and felt the in-built Maintenance tool would do not harm. But since I brought the store back online, I have had a handful of new orders (I only sell digital download products) and I have successfully received the payments in PayPal Business. It appears my customers have also received their emails with the links... BUT... its been really bothering me that I cannot view any transaction log details in Customers > Transaction Logs. Looking at the ccrt database through phpMyAdmin I do see transaction entries in table CubeCart_transactions. I presume this is where the Transaction Logs UI in Admin Control Panel is pulling information from. So question is, if data exists in the table, why is the View not working when I access my store Admin Control Panel? I think the errors below may be what's causing this.... I don't know how to fix them though. 1) In System Error Logs I have these entries... Today, 12:28 File: [settings.index.inc.php] Line: [276] "SELECT SQL_CALC_FOUND_ROWS id FROM `CubeCart_order_summary` WHERE `custom_oid` <> '' LIMIT 1;" - Unknown column 'id' in 'field list' Today, 12:26 File: [orders.transactions.inc.php] Line: [87] "SELECT SQL_CALC_FOUND_ROWS DISTINCT `T`.`order_id`, `T`.`time`, `T`.`amount`, `T`.`gateway`, `T`.`trans_id`, `S`.`id`, `S`.`custom_oid`, `S`.`cart_order_id` FROM `CubeCart_transactions` AS `T` INNER JOIN `CubeCart_order_summary` AS `S` ON `T`.`order_id` = `S`.`cart_order_id` ORDER BY `T`.`time` DESC LIMIT 20 OFFSET 0;" - Unknown column 'S.id' in 'field list' Today, 12:25 File: [settings.index.inc.php] Line: [276] "SELECT SQL_CALC_FOUND_ROWS id FROM `CubeCart_order_summary` WHERE `custom_oid` <> '' LIMIT 1;" - Unknown column 'id' in 'field list' Today, 12:23 File: [orders.transactions.inc.php] Line: [87] "SELECT SQL_CALC_FOUND_ROWS DISTINCT `T`.`order_id`, `T`.`time`, `T`.`amount`, `T`.`gateway`, `T`.`trans_id`, `S`.`id`, `S`.`custom_oid`, `S`.`cart_order_id` FROM `CubeCart_transactions` AS `T` INNER JOIN `CubeCart_order_summary` AS `S` ON `T`.`order_id` = `S`.`cart_order_id` ORDER BY `T`.`time` DESC LIMIT 20 OFFSET 0;" - Unknown column 'S.id' in 'field list' 2) In Maintenance > Database there are some Index related warnings/possible errors that seem to match the System Errors above... <myusername>_ccrt1.CubeCart_order_summary CubeCart_order_summary.id has no key set. Expecting PRIMARY. CubeCart_order_summary.custom_oid has a key type KEY but expecting UNIQUE KEY I'm not savvy at the SQL/database level so I appreciate if anyone has suggestions to fix this problem. My guess is the issue with my missing Transaction Logs has something to do with this Unknown column S.id that is being expected in the order_summary table.
  20. Hi again, I'm aware this sounds like a very amateur question, but we all have to start somewhere. I am doing courses in html, and seo and things, and would like to be able to apply bits to my CubeCart store (after practising obviously!) So...how do I actually edit a CubeCart pages html...where is each of my individual pages within my file manager? (I have access to this via my hosting provider). I understand about FTP and downloading / editing / re-uploading etc (unless there's a way of just editing the pages without doing this?). I am able to inspect pages in a browser, view (and largely understand) the html source, but I can't find the individual pages to edit. Thank you for your help.
  21. The experts at Google have advised I should add ther following code at the end of content.receipt.php to track successful orders generated by ad words. I would appreciate a view from anyone that has done this previously - it just does not look right. {literal} <!-- Global site tag (gtag.js) - Google Ads: 106nnnnnnn --> <script async src="https://www.googletagmanager.com/gtag/js?id=AW-106nnnnnnn"></script> <script> window.dataLayer = window.dataLayer || []; function gtag(){dataLayer.push(arguments);} gtag('js', new Date()); gtag('config', 'AW-106nnnnnnn'); </script> gtag('event', 'conversion', { 'send_to': 'AW-106nnnnnnn/K_-QCMrvlt4BEJSnsfsD', 'value': '{/literal}{$GA_SUM.total}{literal}', 'currency': 'GBP', 'transaction_id': '{/literal}{$GA_SUM.cart_order_id}{literal}' // order ID - required }); {/literal}
  22. Hi, Happy New Year everyone! My logo has stopped showing at the top of my emails to customers and admin have stopped showing - It's just showing the logo path in full (store.co.uk/images/logos/logoname.png). I'm not sure when this started happening, but i've checked the Store Settings/Store Logo settings and they seem ok, and also that the logo is actually in the folder that is now being show on the top of the emails, which it is, with the correct name. Any suggestions would be gratefully received. Thanks very much
  23. Hello all, I have seen on another shop site a popup that "Pop's Up" which looks like PayPal reminder that says "Before you go" would you like to email to yourself the cart contents or to someone else"! so you can return later and purchase the items in the cart. Is this something in CubeCart that can be added or PayPal coding that can be added. Thanks, Malcolm
  24. Firstly, I am so so sorry if this has already been asked before, I have trawled the forum and couldn't see anything similar. I am creating a website providing for several clubs. I have 3 delivery options, but not all clubs use all three. For example, for members of one club they want me to provide Home delivery (£5), collect from their club HQ (Free), and collect from my shop (Free). For another club they may only want collect from their club HQ. Do any of the shipping extensions allow this configuration by product or category. I can see the 'by category' option, but it looks like i can only choose one delivery method then adjust cost. I want to present the customers with the delivery options approved by their club. Thank you in advance for any help! :) Sam
  25. Strangest thing - I upgraded from 6.1.13 to 6.2.9 a little bit ago and my client just noticed that there is no GA feed to his GA account. The really strange part of it is that it isn't an instant drop off. It goes from Feb 2 to Feb 17 in a sharp decline to zero over days. I don't know if the upgrade has anything to do with it or not. If it did, you would think it would have dropped to zero instantly when the upgrade was done. I have diffmerged all of the files to make sure that everything is the same on my installation as the clean version of 6.2.9, including matching my custom skin to the foundation skin with only my css changes the difference. Everything seems to be there. Also, I noticed that Google Tag manager shows no Google Pixel on the site when I go to it in Chrome. I also checked to make sure the element.google_analytics.php file is there in the skin templates file. Not sure where to start looking for this.
×
×
  • Create New...