Jump to content

Archived

This topic is now archived and is closed to further replies.

Guest ColeFlournoy

PayPal PRO Order Failed

Recommended Posts

Guest keschrich

Shared Certficates are Hard to control, will show a URL other than yours and are very buggy...

I would personaly recomend if you can get a dedicated SSL certificate for a decent price then do so...

Just an added note i really think shared SSL are pointless as the idea of a SSL is to confirm the ownership of the domain name is a reputable company and not just to encript web transmition...

Just my 2 cents and i know the question wasn't aimed at me and my opinion may be unwelcome but that is all that i know...

After thinking on it a little bit after posting, I am in agreement. Not to mention the fact that a) a warning pops up stating that the certificate was issued to a different domain and B) the shared certificates are generated by the host and not a reputable CA.

How about the question as to whether or not I can support foreign customers using Paypal's web payments pro? Any thoughts regarding that?

Thanks all

Share this post


Link to post
Share on other sites

Guest inquarta

Hi there, I'm also having problems with PayPal Pro, so I'm asking for any help you have to give.

Here's the setup- we have a shared hosting Linux account on Godaddy, where I've installed CC. We were just recently approved by PayPal (even though it still says that I need to generate an API certificate, which I've already done). I've got the correct API username and password from the API cert in the account name and password fields in the PayPal Direct and Express Checkout gateway admin. However, whenever I test it out (by using my own card, which I know is good), it just goes to a blank page and hangs for about 4 minutes before just giving up. The PayPal log gives me this error: "Mar 22 14:34:04 info_api1.inquarta.com [error] curl_exec error 28 socket error: 110". Any ideas? I'm in a real bind here- my boss wants results. Thanks, guys.

Share this post


Link to post
Share on other sites
Guest

Hi there, I'm also having problems with PayPal Pro, so I'm asking for any help you have to give.

Here's the setup- we have a shared hosting Linux account on Godaddy, where I've installed CC. We were just recently approved by PayPal (even though it still says that I need to generate an API certificate, which I've already done). I've got the correct API username and password from the API cert in the account name and password fields in the PayPal Direct and Express Checkout gateway admin. However, whenever I test it out (by using my own card, which I know is good), it just goes to a blank page and hangs for about 4 minutes before just giving up. The PayPal log gives me this error: "Mar 22 14:34:04 info_api1.inquarta.com [error] curl_exec error 28 socket error: 110". Any ideas? I'm in a real bind here- my boss wants results. Thanks, guys.

Do not worry about paypal they still tell me I need to

Configure API Settings

and

Implement Website Payment Pro

And I have done over 45K in sales with it in 3 months.

Share this post


Link to post
Share on other sites
Guest inquarta

Do not worry about paypal they still tell me I need to

Configure API Settings

and

Implement Website Payment Pro

And I have done over 45K in sales with it in 3 months.

Thanks, that's good to know. It's still hanging at https://inquartashop.com/store/cart.php?act=step5 when I try to buy something, though.

Share this post


Link to post
Share on other sites
Guest inquarta

Not to be a pest, but I could really use some help here... anyone?

Share this post


Link to post
Share on other sites
Guest design@jlum.com

I am having the same problem and coming up to a blank page and nothing.

Very intreseted if anyone has recieved help on this.

Still looking in the forum.

Urgent. the item my client wants registrants for is May 19th.

Share this post


Link to post
Share on other sites
Guest nickparry

Hi anyone help i have read this forum so many times and still cant see what i need i have a business account with paypal all done api done with user and password all in place in the paypay config all works fine until i get to payment step 5 it gives me an eror--

Warning: fsockopen(): php_network_getaddresses: getaddrinfo failed: Name or service not known in /home2/simpsat/public_html/shop/classes/smtp.php on line 87

And

Warning: fsockopen(): unable to connect to smtp.localhost:25 in /home2/simpsat/public_html/shop/classes/smtp.php on line 87

in paypal i told it to give me the paypal form but it gives me a custom form i did when i 1st set up the shop

the shop all works 100% until the paymet page i have tride to sort this out over the last month with no sucsess can anyone point me in the right direction

Nick

Share this post


Link to post
Share on other sites
Guest simplistik

In the cert_key_pem.txt how should the API code look?

right now I have:

Credential: API Signature

API Username: 'Username'

API Password: 'Password'

Signature: 'SignatureString'

Request Date: May 20, 2006 23:44:20 PDT

Share this post


Link to post
Share on other sites
Guest Dooley

I must be stupid

I have had a merchant account with paypal for a couple years, and here's the thing I am having trouble with, I was able to get my certificate without being approved for the Pro yet ( I signed up for it last night..... still waiting ) anyway, is this correct that I should have been given a certificate prior to being approved for the pro plan ??

Because all I get when ordering a test product is

Sorry, your order failed!

You can attempt to purchase your basket contents again below:

I have no idea what to do, wait , remove, try again ?

help ??

Thanks

Share this post


Link to post
Share on other sites
Guest RicoEQ

I too am having the same trouble with PayPal Direct. I always get the ORDER FAILED! I've read and tried everything on this thread (which is a great thread, BTW) but still no luck!

I have nothing to go on because I never get any error messages in the pear/tmp directory (and it is set to 777). This makes me think that I've got something set wrong that has not been covered in these threads.

I've tried using PayPal API certs from both Live and Sandbox. I've set up business accounts on both Live and in the Sandbox.

I can make purchases via Standard (IPN), if that means anything. But the goal is to use the Direct credit card method (that I'm paying $20/month for!!).

What can I try that will give me some clue as to what is wrong?

Thanks.

Rich

Share this post


Link to post
Share on other sites
Guest

In the cert_key_pem.txt how should the API code look?

right now I have:

Credential: API Signature

API Username: 'Username'

API Password: 'Password'

Signature: 'SignatureString'

Request Date: May 20, 2006 23:44:20 PDT

I also stuck at the same point. Even though I requested for a certificate, there was no file to download. It only ask to view or remove the certificate. I use a mac so maybe thats the problem, but as this person requests, I could do a simple txt file, if it looks as similar as above. Awaiting everyones answer

Share this post


Link to post
Share on other sites
Guest Insurrectus

It should look something like this PayPal has to approve your use of the Live API (NOTE this is just a bunch of garbled text, the stuff you get will make sense to the servers):

-----BEGIN RSA PRIVATE KEY-----

MIICXAIBAAKBgQC3RoX8WxNGIl2ia8NIOZqgv3JSPVLDpo7n599gKcKr0CjyyfqM

pvRnsx/AosQ9PGUa8IGvXdGUNEoX9YH9YYyz9209PajAjYP8ZYMZTug7UDujLJkfCR2IBE

HrIrZnTBAkEAw3peLm3eeg78nsxCaYxkGNVaG6l+oSt1Eqo6OT5HwH1jXvXqbmP7

us+vFrxC4li1TgaLOyBXBPaLptdXSHAhcwJAb+kS8qMrwFvlgliPm9NlhnTZv4toSeoMdbkN

ILFlx6rkkSadfas0dfas0df98as0df98as0df98as0df8sdfkjasdkfja;dfkj2udA

bMvtvpjCzzzwfB9vAE39sIbK6KLGGnQeBuDjjCRljNKOv4Q8vFPiEINTswIDAQAB

AoGAX+utHFKeVECQQDwBPsnyNjCnT5NjfTnecqiit4yndDkTfGEvh5F+eDs6nggyVOv

LR1x38GBq3nlntQo483w91jhNadfabjaoidfjadf;lakjdfp0a9dufj;alkdfamgiW

JGaDlAHkHeBAXAy7O/doWmD31fsHOlnmVXPUsuHunIC/32OzgUzO38pxywKqsveK

szs+qERoSrbwloUbQNFEyWJkHP6OQZRhMF0B17b8Iu59CgpakrEAq7CvQedXM+/Oycz6Lv

zBNfggS+2Hr3m1XhAGmiBOt4EEQkGej8VP2J//PoTD3EmmwE2j4purypwQJATVg+

qapJTAxgAkkZwf+Nn5HTfHx9ITI7uW3nabzt0QkL54fwAUvIT6tbQOiuojatTjki

n/t00v7mVNaBr6TGZwJBAL3MbJnXVFqoK6h58GX0k0T1kcBKn4c1pd8s5t9t25Tk

lurWc3yUFPyBH8xfmZy59VtIWaeUEBnaggpMznUpYadsfj0au0faus0d9foI=

-----END RSA PRIVATE KEY-----

-----BEGIN CERTIFICATE-----

MIICiTCCAfKgAwIBAgICJUwwDQYJKoZIhvcNAQEFBQAwgZkxCzAJBgNVBAYTAlVT

MRMwEQYDVQQIEwpDYWxpZm9ybmlhMREwDwYDVQQHEwhTYW4gSm9zZTEVMBMGA1UE

ChMMUGF5UGFsLCBJbmMuMRMwEQYDVQQLFApsaXZlX2NlcnRzMRgwFgYDVQQDFA9s

aXZlX2NhbWVyY2hhcGkxHDAaBgkqhkiG9w0BCQEWDXJlQHBheXBhbC5jb20wHhcN

MDUxMDA2MTQyNjU4WhcNMTUxMDA0MTQyNjU4WjBrMSUwIwYDVQQDFBxzYWxlc19h

cGk0Lm9uZWNyYWZ0eW1hbWEuY29tMRgwFgYDVQQKEw9PbmUgQ3JhZnR5IE1hbWEx

DjAMBgNVBAcTBVNhbGVtMQswCQYDVQQIEwJVVDELMAkGA1UEBhMCVVMwgZ8wDQYJ

KoZIhvcNAQEBBQADgY0AMIGJAoGBALdGhfxbE0YiXaJrw0g5mqC/clI9UsOmjufn

32ApwqvQKPLJ+oym9GezH8C5/xKdcKAoSTmMGoCz7X7R/5mzixD08ZRrwga9d0

ZQ0W+WCWI+XXadfadfjobalkdjfaiefraedfadfabe323dfasdfXXXX02WGdNm/i2hJ6gx1

uQ0gsWXHquSRJ0Bsy+2+mMLPPPBcebNYj+RYQvUxZ+8zSdLadfad-f09D+9

E4r1z1NfSSVaMtnn4i1M24EWPYcS/iCNgSjRo+UERZuoKTbjTOak9N8H28AT

2whsroosYadB4G4OOMJGWM0o6/hsadfasdlfkj0ojfdas0df9234;lkadflkajsd0ruDy8

U+IQg1OzAgMBAAGjDTALMAkGA1UdEwQCMAAwDQYJKoZIhvcNAQEFBQADgYEAuFvx

mApp2yj/zgyyc8GRfHXss8oN0+

VqsgQE5NklSMnhDjhn6z3DDy0y+mdHvoj9CzJ7E=

-----END CERTIFICATE-----

Share this post


Link to post
Share on other sites
Guest

It should look something like this PayPal has to approve your use of the Live API (NOTE this is just a bunch of garbled text, the stuff you get will make sense to the servers):

-----BEGIN RSA PRIVATE KEY-----

MIICXAIBAAKBgQC3RoX8WxNGIl2ia8NIOZqgv3JSPVLDpo7n599gKcKr0CjyyfqM

pvRnsx/AosQ9PGUa8IGvXdGUNEoX9YH9YYyz9209PajAjYP8ZYMZTug7UDujLJkfCR2IBE

HrIrZnTBAkEAw3peLm3eeg78nsxCaYxkGNVaG6l+oSt1Eqo6OT5HwH1jXvXqbmP7

us+vFrxC4li1TgaLOyBXBPaLptdXSHAhcwJAb+kS8qMrwFvlgliPm9NlhnTZv4toSeoMdbkN

ILFlx6rkkSadfas0dfas0df98as0df98as0df98as0df8sdfkjasdkfja;dfkj2udA

bMvtvpjCzzzwfB9vAE39sIbK6KLGGnQeBuDjjCRljNKOv4Q8vFPiEINTswIDAQAB

AoGAX+utHFKeVECQQDwBPsnyNjCnT5NjfTnecqiit4yndDkTfGEvh5F+eDs6nggyVOv

LR1x38GBq3nlntQo483w91jhNadfabjaoidfjadf;lakjdfp0a9dufj;alkdfamgiW

JGaDlAHkHeBAXAy7O/doWmD31fsHOlnmVXPUsuHunIC/32OzgUzO38pxywKqsveK

szs+qERoSrbwloUbQNFEyWJkHP6OQZRhMF0B17b8Iu59CgpakrEAq7CvQedXM+/Oycz6Lv

zBNfggS+2Hr3m1XhAGmiBOt4EEQkGej8VP2J//PoTD3EmmwE2j4purypwQJATVg+

qapJTAxgAkkZwf+Nn5HTfHx9ITI7uW3nabzt0QkL54fwAUvIT6tbQOiuojatTjki

n/t00v7mVNaBr6TGZwJBAL3MbJnXVFqoK6h58GX0k0T1kcBKn4c1pd8s5t9t25Tk

lurWc3yUFPyBH8xfmZy59VtIWaeUEBnaggpMznUpYadsfj0au0faus0d9foI=

-----END RSA PRIVATE KEY-----

-----BEGIN CERTIFICATE-----

MIICiTCCAfKgAwIBAgICJUwwDQYJKoZIhvcNAQEFBQAwgZkxCzAJBgNVBAYTAlVT

MRMwEQYDVQQIEwpDYWxpZm9ybmlhMREwDwYDVQQHEwhTYW4gSm9zZTEVMBMGA1UE

ChMMUGF5UGFsLCBJbmMuMRMwEQYDVQQLFApsaXZlX2NlcnRzMRgwFgYDVQQDFA9s

aXZlX2NhbWVyY2hhcGkxHDAaBgkqhkiG9w0BCQEWDXJlQHBheXBhbC5jb20wHhcN

MDUxMDA2MTQyNjU4WhcNMTUxMDA0MTQyNjU4WjBrMSUwIwYDVQQDFBxzYWxlc19h

cGk0Lm9uZWNyYWZ0eW1hbWEuY29tMRgwFgYDVQQKEw9PbmUgQ3JhZnR5IE1hbWEx

DjAMBgNVBAcTBVNhbGVtMQswCQYDVQQIEwJVVDELMAkGA1UEBhMCVVMwgZ8wDQYJ

KoZIhvcNAQEBBQADgY0AMIGJAoGBALdGhfxbE0YiXaJrw0g5mqC/clI9UsOmjufn

32ApwqvQKPLJ+oym9GezH8C5/xKdcKAoSTmMGoCz7X7R/5mzixD08ZRrwga9d0

ZQ0W+WCWI+XXadfadfjobalkdjfaiefraedfadfabe323dfasdfXXXX02WGdNm/i2hJ6gx1

uQ0gsWXHquSRJ0Bsy+2+mMLPPPBcebNYj+RYQvUxZ+8zSdLadfad-f09D+9

E4r1z1NfSSVaMtnn4i1M24EWPYcS/iCNgSjRo+UERZuoKTbjTOak9N8H28AT

2whsroosYadB4G4OOMJGWM0o6/hsadfasdlfkj0ojfdas0df9234;lkadflkajsd0ruDy8

U+IQg1OzAgMBAAGjDTALMAkGA1UdEwQCMAAwDQYJKoZIhvcNAQEFBQADgYEAuFvx

mApp2yj/zgyyc8GRfHXss8oN0+

VqsgQE5NklSMnhDjhn6z3DDy0y+mdHvoj9CzJ7E=

-----END CERTIFICATE-----

I guess I have to email paypal and get the correct download. Its probably why I get errors.

Share this post


Link to post
Share on other sites
Guest designbyfox

I have adjusted my shop to your setiings posted in the beginning of this thread. I am running CubeCart Version: 3.0.8, using PayPal Pro or Direct Payment and I am getting this error once a customer finalizes their payment. Meaning they put their CC info in, then press Continue and they get this...

Fatal error: Class 'PEAR_Error' not found in /home/spunaut/public_html/shop/pear/Services/PayPal/Error.php on line 18

Now this is what Line 18 says on this file...

class PayPal_Error extends PEAR_Error {

--------------------------------------------------------------------------------

The whole file looks like this...

<?php

/**

* @package Services_PayPal

*

* $Id: Error.php,v 1.18 2005/06/23 17:03:21 chagenbuch Exp $

*/

/**

* Load parent class.

*/

require_once 'PEAR.php';

/**

* A standard PayPal Error object

*

* @package Services_PayPal

*/

class PayPal_Error extends PEAR_Error {

/**

* Standard error constructor

*

* @param string The error message

* @param int An optional integer error code

*/

function PayPal_Error($message, $errorcode = null)

{

parent::PEAR_error($message, $errorcode);

}

}

-------------------------------------------

I really need someone to guide me on how to fix this.

Many thanks

Heather

Share this post


Link to post
Share on other sites
Guest RicoEQ

I had a server-savvy guy look into my Order Failed problem and he was able to fix it. I don't know if this will help the rest of you but it got me up and running:

The problem with the CC processing was that CubeCart uses curl to send the information to PayPal. Although curl (with SSL enabled) was installed on the server, PHP was not compiled with curl functionality. Recompilled php with the --with-curl option.

Share this post


Link to post
Share on other sites
Guest Antivirus

I'm getting an error as well, during step 5 (running v3.0.12):

Warning: main(PEAR.php): failed to open stream: No such file or directory in D:\webppliance\conf\domains\eclipse\Inetpub\wwwroot\store\pear\Services\PayPal.php on line 11



Fatal error: main(): Failed opening required 'PEAR.php' (include_path='D:\webppliance\conf\domains\eclipse\Inetpub\wwwroot\store/pear;.;c:\php4\pear') in D:\webppliance\conf\domains\eclipse\Inetpub\wwwroot\store\pear\Services\PayPal.php on line 11

Share this post


Link to post
Share on other sites
Guest Antivirus

still getting same error and curl is installed & configured on server...

Share this post


Link to post
Share on other sites
Guest mashurst

still getting same error and curl is installed & configured on server...

just a stab in the dark, but it sounds like your permissions might not be set right, i.e. pear/tmp or something like that. it looks like you are on a windows server based on the d: path, on a unix, you would make it 777 on windows I guess just make it writable?

Share this post


Link to post
Share on other sites
Guest Steven Mc Nulty

still getting same error and curl is installed & configured on server...

just a stab in the dark, but it sounds like your permissions might not be set right, i.e. pear/tmp or something like that. it looks like you are on a windows server based on the d: path, on a unix, you would make it 777 on windows I guess just make it writable?

I had the same error and it wasn't just curl. I had my host install curl and pear support. You'll notice that in the error it's looking in C:/PHP4/pear and not finding what it wants.

Share this post


Link to post
Share on other sites
Guest thomaswhiteeagle

greetings all:

I'm having the same sort of problem. I'm the type of person that installs something, reads through all of the documentation, searches for the answer if their is a prob then when all else fails. asks for help- now I am asking for help if that is possible. I recently installed the program and am testing it for possible use on multiple sites I host for clients. BTW, compared to other programs I have used such as oscommerce and others overall I think it is a very pleasant program and already does some things much better.

Payment processing isnt working with paypal pro though. Everything is correct on the surface. My cert is where it should be and valid. My credentials, login and password are accurate- I've been using payments pro for some time elsewhere. I have triple checked everything. What happens when I process a sample payment is nothing. Just sits there and acts like it is doing something then eventually goes to a blank page for about 5 minutes then goes back to "Sorry your order failed" whole process takes about 8 minutes. which is nice it at least comes back to a real page asking if want to try again but not helpful. My pear/temp dir is writable but there is no error log message or anything in there as suggested. This is when I use the direct payments module or the express payments module. With the paypal standard and ipn it works great at least as far as going to paypal havent completed a transaction to see how it notifies but the most important part worked fine but obviously would like to figure out how to make the other work. I am using the latest version on this site which is 3.0.12 and php 4.3.11 and has been enabled --with-curl on an apache server. Not sure what other info I can provide to maybe figure this out but maybe someone has some ideas I can try.

Thanks, TWE

Share this post


Link to post
Share on other sites
Guest Steven Mc Nulty

Well I don't have an answer for your problem. What I can tell you is that I had major issues with Paypal API. Supposedly tons of people have used it without issues but I sure had plenty. I spent approx. 2 weeks e-mailing alistair (tech support and the creator of cubecart). The result was he re-wrote all the Paypal modules and I assume they will be available soon. (probably through a new rev. of the shopping cart) Mine work great now so I can only tell you to sit and wait for the new modules/version to be released.

Share this post


Link to post
Share on other sites
Guest Lyzard914

I finally got this working! I'm a very technical person so the instructions were easy to follow, but what took me so long was I forgot to actually sign up for website payments pro! This seems obvious in hind sight, and I'm sort of embarassed to admit this, but I thought it might help some others so:

1. Don't forget, you actually need to go to your paypal account and apply for website payments pro which takes a few days to be approved. Unless you do this, it will appear to be working, but you will just get back esoteric error messages.

2. More importantly, after you are approved, you need to agree to the website payment pro "billing agreement". It is stated in the email that paypal sends you (upon being approved) that you just need to login and click "my account" and a link will be there. Well I never saw this, and so I assumed it was something I'd already agreed to. Not the case. The only place i ended up finding it was hidden away in the right hand column of this page:

https://www.paypal.com/us/cgi-bin/webscr?cm...pro-integration

Hope this helps.

Brian

THANK YOU!!! Couldn't figure out what was going on - this is exactly what the problem was. This message should be moved to the #2 slot - right after the instructions on how to get this working... saving many of us the hunting around for the fix.

Lyzard

www.lpstuff.com

Share this post


Link to post
Share on other sites
Guest Mohegan

cANT GET PAYPAL DIRECT OF EXPRESS TO WORK ON MY SITE.. DONT KNOW WHAT IM DOING WRONG.. COULD SOMEONE PLEASE HELP..

Ok. Just got off the phone with Pay Pal. I'm a Canadian customer and as such Pay Pal Pro is not (yet) available to me. My business account allows me to generate an API Certificate (instantly) but this is for something entirely different. This is where I was getting confused.

They suggested that I use Standard Web Payment for now until PP Pro is available to Canucks!

Bottom line: I assumed my acount was a "Pay Pal Pro" account because it's a Merchant account and I could generate the API Certificate as per the instructions. So that's what I get for assuming. 4 or 5 hours wasted and long distance phone call that I could have avoided.

Share this post


Link to post
Share on other sites

×
×
  • Create New...