Jump to content

Archived

This topic is now archived and is closed to further replies.

Guest

V3.0.5 Admin E-Mail Fix in HERE!

Recommended Posts

Guest

GoodLiteCandles

Can you please confirm that your Customers are receiving automatic order confirmation after placing an order when using Postal order payment option?

Looking back at your previous post I think Customers should get an automatic email even if using the postal order payment option! After all what would happen if their printer was out of ink or they didn’t have one at all!

A lot of PC users might not think to or know how to save a web page from within a browser!

Can someone from CC please give some input to what they think the problem is with Automatic Customer emails, why it stopped working and a stab in the dark at least when it might be fixed?

Has anyone reported this as a Bug?===============================

Groovejuice

Thanx again for the feedback!

No luck as yet for me with this problem!

Did you ever have Customer email working with the Mail() option? Not using SMTP!

I might try an upgrade to 3.0.5 but with the advised changes I made this shouldn’t make any difference I think!

Do you or anyone else have a complete list of all the files and folders that should be in place on a live site after a fresh install? Or should these just simply be an exact match to the Upload folder prior to uploading!

Cheers B)

Share this post


Link to post
Share on other sites

Guest GoodLiteCandles

GoodLiteCandles

Can you please confirm that your Customers are receiving automatic order confirmation after placing an order when using Postal order payment option?

Looking back at your previous post I think Customers should get an automatic email even if using the postal order payment option! After all what would happen if their printer was out of ink or they didn’t have one at all!

A lot of PC users might not think to or know how to save a web page from within a browser!

I dont use postal order form.

I use authorize.net (which automatically sends an email)

and I use print order form for checks (but no email is sent, even with the fix)

So as of now the only time the customer is getting an emila is if they choose credit card payment (authorize.net) and they are getting 2 emails.

So it seems that I dont need this email fix.

Share this post


Link to post
Share on other sites
Guest

This e-mail fix is for the admin to get a better e-mail, not the customer. Does the e-mail from Authorize.net contain a list of purchased products? I kinda doubt it. So I'd think you'd be better off just adding some text to the customer e-mail stating something like, "This e-mail confirms your order and lists the products you are purchasing. You will also get a separate payment confirmation e-mail from Authorize.net, our card processor. Please feel free to contact us if you have any questions or problems with your order or the processing of it."

B)

Share this post


Link to post
Share on other sites
Guest groovejuice

My auto emails to customers and admin was the last thing I got to work. Turned out I had a typo in the email user name. Duh. I've only selected SMPT, so can't comment on mail(). I also kept getting the "transaction failed" message on autoreturn UNTIL I found the typo. Then everything worked. Perhaps someone with much more experience than I could comment here (i'm a novice with php scripting) - it seems that if one of the parameters fail, then the subsequent ones will also.

I found that the solutions I discovered along the way were mostly common sense ones, but it took many mistakes to arrive at a successful destination. That is the irony of this great application. Brooky has generously made it virtually free and with the help of contributors like Sir William, Estelle and many others, I was able, without scripting experience, to make it work. The lack of concise documentation is a challenge, but if one is willing to search the archives and make their own small contributions to others along the way, the journey and destination have been valuable and fulfilling. Although by definition, I don't think CC is categorized as 'open source' it is still a collaborative project. And frankly, I find more bugs everyday in the IE browser rendering of CSS than I've found in the 4 weeks I've been using CC.

Share this post


Link to post
Share on other sites
Guest GoodLiteCandles

This e-mail fix is for the admin to get a better e-mail, not the customer. Does the e-mail from Authorize.net contain a list of purchased products? I kinda doubt it. So I'd think you'd be better off just adding some text to the customer e-mail stating something like, "This e-mail confirms your order and lists the products you are purchasing. You will also get a separate payment confirmation e-mail from Authorize.net, our card processor. Please feel free to contact us if you have any questions or problems with your order or the processing of it."

B)

Yeah, that will work. Thanks.

Share this post


Link to post
Share on other sites

Id just turn off the email receipt to customer at authorize.net....

OR write up some sontent for email reciepts at authorize.net to EXPLAIN to customer what the email reciept from authnet is ALL about

I wouldnt change a thing in your stores admin...

you should REALLY take a tour round your authnet control panel...

Share this post


Link to post
Share on other sites

Sir William (or anyone else),

I am designing my store for someone else, and with 3.0.4 there was a link to the admin section (to see your order)..

I just did this update, and the 3.0.5 update, and the link is no longer there.. Any way to put it back??

Share this post


Link to post
Share on other sites

Hello CCers.

I'm working hard on 3.0.6 which I want to release at the end of next week.

Thanks to you all here especially Sir Will (again) for your wonderful work.

I'm testing this now and as per Sir Will kindness I will add it to 3.0.6.

My absolutely fundamental problem is that I dont actually use CubeCart! Ironic isn't it?

Sooo... I miss things like this.

Keep them coming and well make CubeCart the best and biggest solution in the world!! :unsure:

We're not far off!! :)

Share this post


Link to post
Share on other sites

If shipping is 0.00 postage and packing may not show up.

Here is the fix:

Change:

################################################################################

##

	## Admin E-Mail Fix by Sir William -- http://www.swscripts.com/

	// notify shop owner of new order

	include("classes/htmlMimeMail.php");

	$mail = new htmlMimeMail();



	$text = sprintf($lang['front']['gateway']['admin_email_body_1'],

    $cart_order_id,

    formatTime(time()),

    $ccUserData[0]['title']." ".$ccUserData[0]['firstName']." ".$ccUserData[0]['lastName'],

    $ccUserData[0]['email'],

    priceFormat($basket['subTotal']),

    priceFormat($basket['shipCost']),



To:




################################################################################

##

	## Admin E-Mail Fix by Sir William -- http://www.swscripts.com/

	// notify shop owner of new order

	include("classes/htmlMimeMail.php");

	$mail = new htmlMimeMail();



if($basket['shipCost']>0){

  

  $emailShipCost = $basket['shipCost'];

	

	} else {

	

  $emailShipCost = "0.00";

	

	}



	$text = sprintf($lang['front']['gateway']['admin_email_body_1'],

    $cart_order_id,

    formatTime(time()),

    $ccUserData[0]['title']." ".$ccUserData[0]['firstName']." ".$ccUserData[0]['lastName'],

    $ccUserData[0]['email'],

    priceFormat($basket['subTotal']),

    priceFormat($emailShipCost),

Share this post


Link to post
Share on other sites
Guest johnkolk

Hi I'm new so sorry if I'm asking silly questions???

Firstly Sir Will fix for email? Can I use this and not worry about the new 3.0.6 as I think I may run into even more problems trying to upgrade what I have now and the only thing I don't have working ok at this stage in the email??

will I have your attention... can anyone tell me if I can have product numbers on an attribute like a color? as i may have a product item number 123 which comes in red and white and I may have 3 of each in stock but if i sell out of the white how will my customer know as it still says i have 3 of the original 6 left? At the moment I don't use the stock amount but i would like to, any ideas?

Share this post


Link to post
Share on other sites
Guest johnkolk

I ment "while I have your attention" but I quess I havn't got anyones attention as nobody has answered my questions:-)

Share this post


Link to post
Share on other sites
Guest theorbo

I'd be willing to bet you'll get more answers if you start a new thread....

Share this post


Link to post
Share on other sites
Guest edgeways

Brooky, I was excited to see the fix and applied it right away. Unfortunately, it did not work for me. I used a print order form and did not receive an e-mail. I do have my shipping set for 0.00. Any suggestions would be greatly appreciated. I have read the forums religeously and I'm just plain stuck.

Share this post


Link to post
Share on other sites
Guest

Hello CCers.

I'm working hard on 3.0.6 which I want to release at the end of next week.

Thanks to you all here especially Sir Will (again) for your wonderful work.

I'm testing this now and as per Sir Will kindness I will add it to 3.0.6.

My absolutely fundamental problem is that I dont actually use CubeCart! Ironic isn't it?

Sooo... I miss things like this.

Keep them coming and well make CubeCart the best and biggest solution in the world!! :sourcerer:

We're not far off!! :rolleyes:

Hi Brooky

I’m hoping to launch my 1st site soon using CC and could do with a little reassurance on just one question!

As you will see from my posts on this subject I and a few others have problems with Automatic Customer emails! It doesn’t work!

I will only be using the Postal Order form and not any of the on-line payment systems so it’s very important this feature works for me using this set-up!

Will this problem be resolved in Ver. 3.0.6 ?

Many thanx

Share this post


Link to post
Share on other sites
Guest GoodLiteCandles

Okay I have 2 question about the email that is ordered to the customer.

1.

"Thank you for your order no: 051102-062659-2741 placed on Nov 02 2005, 06:26 AM"

The time is 3 hours behind. Where is this set up. Or am I able to just take the time out? The code is:

Thank you for your order no: %s placed on %s

...so I am not sure how to take the time out and keep just the date.

2. In the email I wanted to make the headers bold (i.e. "Billing Address", "Shipping Address" etc) But when I put the <b></b> around the words they literally showed up in the email. Are these tags not able to be used? I used them in the order success information a few lines up. Am I able to bold these headers?

I am pretty much done with the cart and now I just want to add things here and there to make it even better.

Any help would be appreciated. Thanks.

Share this post


Link to post
Share on other sites
Guest GoodLiteCandles

anyone??? ^^^^^

Share this post


Link to post
Share on other sites
Guest timecrisis

Have you tried the "Time offset" setting in your general settings?

Share this post


Link to post
Share on other sites
Guest

anyone??? ^^^^^

Sorry for saying it but maybe a new post might have been better bet! You’re a little bit off topic Hehe…

Under Store Settings:

“Look for Time Offset:

(Seconds - Used for servers in different timezone)

Date Format:â€

I think this might be

what your lookin for!

Share this post


Link to post
Share on other sites
Guest timecrisis

Hi All,

Getting back to the topic in question..well sort of

I have applied Sir's email patch on .5 and the customer is getting blank emails..

I would go into it but was hoping there is some more news about .6 as many people seem to be having a multitude or various and unconsistent errors, I am crossing my fingers and hoping .6 will save my email soul...

If anyone has more news on .6 or has a quick solution to balnk emails feel free to help me out...

Thanks as always!

;)

Share this post


Link to post
Share on other sites
Guest trevorrnz

Thank you Sir William for a brilliant mod.

I've made a very minor tweak to gateway.inc.php to re-include the admin link, which I personally found quite useful:

Here's the tweak:

replace lines 222 to 224 in gateway.inc.php

$text .= sprintf($lang['front']['gateway']['admin_email_body_1'],

$cart_order_id,

formatTime(time()),

with:

$text .= sprintf($lang['front']['gateway']['admin_email_body_1'],$cart_order_id."\n\n"."Admin Link: ".

$GLOBALS['storeURL']."/admin/orders/index.php?oid=".$cart_order_id,

formatTime(time()),

Cheers

T

Share this post


Link to post
Share on other sites
Guest ColeFlournoy

Hi -- Brooky please let me know if you read this..

I am using PayPal Pro on v3.0.5 and so I don't have any e-mail issues as far as I know. My customers get a conformation and it shows everything. It looks like this thread has gotten way off topic so I have just scanned but it looks like this mod changes the e-mails to be sent out when the order is processing, instead of pending. If this is so - this would really cause me problems! I have orders that are "processing" but were never completed. If I am reading correctly this will send out a conformation to the customers before the credit card transaction has gone through -- if so that would cause major obvious problems. I would be scared to install v3.0.6 if this were so!

PS: Seeing that this thread is so off topic, can someone give a brief summary of what the heck this mod does and is for in case I am wrong -- so people like me don't have to study 5 pages of ramblings (no offense to the contributing members of course!)

Thanks!

PPS: Just an idea (and although off topic, I’ll respond) I think it would be a great idea for you (brooky) to open a test store and actually sell a few products -- such as paper clips or something (something less than a dollar) and I'm sure many of us would volunteer to make some orders just so you could see a real world example.

Share this post


Link to post
Share on other sites
Guest

Cole, I think there needs to be some clarification on orders...

Pending - Customer has filled their cart and made it to the payment (gateway) page.

Processing - Customer has paid but the order has not yet been processed by the store owner.

Completed - Order has been shipped and there is nothing further to do.

Now, if you have orders that have been marked as "Processing" but you haven't been paid, then there is a problem with your payment gateway processing. The order should only go to processing if the gateway tells CubeCart that it's been paid for.

An e-mail should go to the customer when they leave the gateway and go on to pay. If they don't indeed pay, oh well. So I guess I'm a lost as to what you're trying to say? The order confirmation e-mail is just that, confirmation that they placed an order, not confirmation that they paid for and completed the ordering process.

I hope this helps you and anybody else with questions over the e-mail process. I believe it's going to be streamlined even further and made more friendly in 3.0.6 and 3.0.7. :rolly:

Share this post


Link to post
Share on other sites
Guest

Hi Sir Will

I think it might be a good idea if some posts like your last were saved to Q & A page or something like an unofficial manual page! Just an idea!

It can be hard searching for stuff sometimes!

Can Sir Will or Brooky please confirm is there acknowledgment of a problem with Automatic Customer email delivery?

I need to give my customer a guide to when their website will be able to automatically email customers!

I know some have it working and some do not.

Mine does not but all other email including Bulk, Order status change etc works just fine!

I need to go live soon so very worried this not working will put customers off!

Cheers.

Share this post


Link to post
Share on other sites
Guest ColeFlournoy

I apologize I had processing and pending backwards, you are absolutely right there. But what I am worrying about lies in your first statement “before any of the order details had really been processed. Instead, I build and send the message after the order has already been inserted into the database†– does this mean that the e-mail is sent before the user actually has a confirmed payment? Correct me if I’m wrong but is this how it would be set up with your mod (or 3.0.6):

1. Customer adds products and clicks checkout

2. Customer registers and goes to payment window

3. Customer is sent e-mail that the order is complete

4. Customer enters payment info and completes order (or just closes the window and doesn't pay)

In my order conformation e-mail it basically says “Thanks, your credit card has been charged and your items will be shipped out immediatelyâ€, I don’t see any reason the customer would get a conformation of the order if there is a chance they didn’t actually pay. For example, I’ve tried to order products before but at the last minuet just decided I didn’t want to spend the money and closed the page – I shouldn’t then get a message that my products are soon to be shipped out…

Thanks,

Cole

Share this post


Link to post
Share on other sites
Guest

Cole, I think I see your problem. The e-mail sent from the server is NOT supposed to say that it's paid for until it is set to "Processing". The initial e-mail should simply verify that an order has been placed and is awaiting payment. If you're telling them at that point that it's paid for, you need to edit that text...it's wrong. :homestar:

Share this post


Link to post
Share on other sites

×
×
  • Create New...