Jump to content

Print Order form disappears 3.0.6


Guest muircockhall
 Share

Recommended Posts

Guest muircockhall

Hi

I've been using cubecart for a few months and upgrading as the new versions come out. I offer two payment options 1. paypal or 2. postal. Paypal seems to work okay and the postal works does not; I get an email and an order on cubecart but the customer has a frustrating experience:

The cart shows it is now empty and they nothing to print. It looks and feels like they have been dumped out the system with no acknowlegement or anything to print. The general comments I get back from the customer is that the system has failed.

I have the following files in ./modules/gateway/Print_Order_Form

orderForm.php, orderForm.tpl, transfer.inc.php

I've had a cursory look and they seem okay.

Any thought or ideas would be welcome.

www.marystewart.co.uk/shop3 (it is live....)

Link to comment
Share on other sites

  • Replies 52
  • Created
  • Last Reply

Top Posters In This Topic

I tink it has to do with the if($result == FALSE){

the print order form dosent pop up, insted it goes back to "step2"

look below...

$print_order_form = new XTemplate("orderForm.tpl");

$result = $db->select("SELECT * FROM ".$glob['dbprefix']."CubeCart_order_sum INNER JOIN ".$glob['dbprefix']."CubeCart_customer ON ".$glob['dbprefix']."CubeCart_order_sum.customer_id = ".$glob['dbprefix']."CubeCart_customer.customer_id WHERE ".$glob['dbprefix']."CubeCart_order_sum.cart_order_id = ".$db->mySQLSafe($basket['cart_order_id']));

if($result == FALSE){

header("Location: ".$glob['rootRel']."cart.php?cart.php&act=step2");

is it a session problem with the db?? it return "FALSE"

Please any advance member, help !!

Rekos

Link to comment
Share on other sites

Ok, i solved this by uploading th "print_order_form" module from cc 3.01. Not sure what was wrong with the one in 3.06 but you could compare them i suppose. I've got too much else to do to look :wub:

Link to comment
Share on other sites

FWIW, I recently had a brief encounter with "your shopping cart is empty" while checking out using a username I created called MANUAL ORDER, for customers who just can't cooperate and use the shopping cart or for when I crash my R/C micro-heli and need parts for me (It's a way easier than reducing stock manually, item by item). ANYWAY, this was just after upgrading to 4.0.6 and I rolled my eyes back in my head and said "here we go...", but then I realized that it was just that one username. So if you encounter this with a test username, perhaps just try another. This doesn't repair or explain anything, I know, but Mr. MANUAL ORDER is no longer a customer because of all the trouble he caused ;)

Link to comment
Share on other sites

Guest claesmagic

Hi,

Got almost the same problem with 3.0.6 - but:

1. When using the "Postal Form" alternative at checkout, I get returned to the 2:nd page...

2: When logging out from my account, the cart says "Your session in destroyed" but when using my 2nd test account, logging in, the old items from my first account still exists in the shopping basket. Bug?

Please help!

/claesmagic

Link to comment
Share on other sites

Guest estelle

Micky, you could be on to something there! I think you should contact Brooky about this, because its obviously an issue thats affecting lots of people, and it could very well have an easy fix such as the one you suggested (but instead of calling session_start() directly you should probably be including sessionStart.php, similar to how it is done in index.php and cart.php).

Link to comment
Share on other sites

Yep spot on

I took away the

session_start();

& it went back to how it was, with the form disappearing

I then replced that with




include_once("../../../includes/sessionStart.inc.php");

& it's working again so i would defo say it has something to do with that.

Bloody 'ell can it be that I fixed my own problem :):lol: :)

Link to comment
Share on other sites

Guest arrabalero

Hi. Upgrading always destroys lots of work done and is very painful for me. Everything works well and I want to make no changes nor remake anything except for the Print From issue.

Link to comment
Share on other sites

Guest megaline

I have put this lines in orderForm.php :

// get session data

include_once("../../../includes/sessionStart.inc.php");

include_once("../../../includes/session.inc.php");

instead of :

// get session data

include_once("../../../includes/session.inc.php");

and IE browser goes well and shows the order form, but when I try in Firefox (1.06) I am returned back to step2.

Has anyone any idea?

I am using cubecart 3.06.

Regards,

Ali

Link to comment
Share on other sites

Guest esthervdwal

This could just be coincidence so if someone wants to correct me please do

but i added on line 30 in orderform.php

session_start();

& this seems to have fixed it :P

GREAT!!!

Did it too and it worked!!!

Thank you very much!!

I had the same problem only the cart didn't empty it sets back to step 2.

I am realy greatfull!!

:D

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share




×
×
  • Create New...