Jump to content

No Shipping to my country??

Guest Andrew T.

Recommended Posts

Guest anakin827

Goober helped with this issue. Below is the steps you need to take to resolve this.
  1. Go into the admin session
  2. Select Shipping Module
  3. Select Per Category
  4. Under National put US
  5. Under the International put the countries you will ship to only.
  6. DO NOT ENABLE THIS MODULE Unless you intend to use it.
  7. TEST - Should work.
  8. You are done. :wacko:
Hope this helps.

Scott :sleep:


Once again, THANKS GOOBER! You are the MAN!

Yeah this didn't work either, I'm actually not using his shipping module, I'm trying to get UPS to work again, ugh the f'n upgrade has caused more issues!!!!

Link to comment
Share on other sites

Guest sgleaton

My I please interject something here? I would greatly appreciate it if no one would make any hints to foul language in these forums. There is no need in such. We are all here to help and in my humble opinion it is offensive to some on here.


Link to comment
Share on other sites

Guest shannonlp

I have had this error as well. I had to just switch the product they were trying to buy to a digital just to get the credit transaction finished. Have not had a chance to look at the problem since.

I have UPS configured. And have weights entered on all items.

Link to comment
Share on other sites

Guest Rock Star* Pets

I got reminded of something today.....before it will work, you HAVE to have weights added to all your products. :lol:


hey thanks! I'll try that and see if it works.


:w00t: ames

Link to comment
Share on other sites

Here is the exact message that I am getting:


We cannot ship our products to your country.

I am using 3.0.6 and have the same error/problem...

Just did a lot of customizing and added imported 2500 products the hard way by .csv.

I do not want to use any gateway just the printform.

I use only free shipping with no extra's.

Anyone any idea's?

Link to comment
Share on other sites

In the /modules/shipping/UPS/calc.php find this line near the end:

$shippingPrice .= $rate->getOpt($sum,$productCode,$desc);

Add this right below it:

$shippingAvailable = TRUE;

That should take care of your problem. I spotted this issue when I was doing the USPS module. That line should be near the end of EVERY shipping module's calc.php.


And so, for me, I had to change it in the Modules/Shipping/FreeShipping/calc.php file and it works!

It should be near EVERY shipping module!!!

Thank you very much Sir Williams for your fantastic support... ;)

Link to comment
Share on other sites

I have tried all the same options posted here. I still get the "cannot ship to your country"

Info: 3.0.7pl

All products have weight

Checked UPS.php for shippingavailable=true, it's there.

Added US to the national catecory but left the module disabled.

any ideas?

****So I don't know what I just did but it's working now******

Link to comment
Share on other sites

  • 1 month later...
Guest phenonm

Hi there

i am trialing cubecart version 3.08 and it looks like the goods for what i need it to do. I have really looked through the forums on this one but cant seem to find an answer. I get the no shipping method for your country error when applying shipping charges via weight, however i only get the error if the item i am checking out has a weight entered. If i leave it with a weight of zero it applies the correct shipping charges for zone one and two. If i apply a flat fee shipping rate it works, and if i apply a shipping rate per category it works also so i dont think the issue is with the ISO codes at all because it seems to pick up the correct ISO code when there is no weight

i was told to try this link http://www.cubecart.com/site/forums/index....&hl=cannot+ship

This link refers to ups shipping, all i am trying to do is ship by weight. This is really doing my head in, the software seems so good but this little glitch is a real pain.

Things i have tried to date

I have now downloaded and installed locally the 3.09 version on Cubecart. I installed it as United Kingdom as you dont have the option to initially install it as Australia which is where i am.

I set the cart up, dumped a few products into it

The changes i made were changing the following

in the general setting page i changed the country to Australia

on the taxes page i change the country to australia and change the tax rate to the right rate

on the currencies page i change the currency to australian dollars and disable the rest

on the shipping page i configure by weight as follows

Zone 1 countries - i put AU in this box with is the iso code for australia as per the countries & Zones page

Zone 1 handling fee i leave blank

Zone 1 shipping first class i enter 1:4.00

Zone 2 shipping i leave blank

i disable all other types of shipping

back on the general settings page i change the default currency to austalian dollars, tell it not to include tax in prices and turn off sale mode. i also tell it not to show stock levels

Then once the store is showing Aussie dollars i notice two things

The products i enter seem to have another currency rate applied to them - probably UK dollars. Any item i add as $ 100 dollars ends up being $ 233 aussie dollars on the site which is wierd

When i try to do shipping by weight, if the product has a weight entered against it, i get the no shipping set up for this country error.

I have tried as a test setting everything back to united kindom settings to see if it has something to do with it has to be as the country it was installed as and that doesnt work either

I am using the right iso codes, but i cant seem to get the thing working, every other shipping method works

The file suggested in the link doesnt exist on my system to edit either

What is going wrong here, what have i done, does shipping by weight only work in the US, is there anything i am missing.


late update, i dont know how this worked but when i originally looked in the modules folders under weight or whatver all i saw was an index.php file, after i fiddled with quite a few settings it turned into calc.php - Wierd

I have checked all products have weights

I have trialed it with tax applied or not

i have checked all calc.php files have the shippingvalue=true in the files - they all do

I added AU to the national category and left the module disabled

i have tried alot of little bits and pieces on all the forums but keep getting this cant ship to this country error

I have tried most of the tweaks on verison 3.08 and all the tweaks i can on 3.09

I cant believe that this can be such an issue, there must be something i am missing or does no one ship by weight or give up trying.

I am at a real loss now - tried creating a dummy country - no luck, once you give a product a weight - no go, tried two different versions, no luck, not very happy at the moment, spent a bunch of time trying to make something basic work. I will try one more time, install it as USA, try it before i customise it as australia, if that doenst work, i give up, ill try another package - its all too hard.

Reinstalled it now as US - basically no changes made to it at all, just setup shipping, everything else basically stock and the same error occurs. Very frustrating, i dont see how i could be getting anything wrong on two seperate complete systems on differnet servers and hardware, this is just rediculous. Two different people installed it too independantly surely we both cant be wrong

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...