Jump to content

Applied security patch and now I cant checkout


Guest jwm
 Share

Recommended Posts

Hey All,

I am running CC 3.0.10 and ever since I ran the recent security patch no one has been able to checkout on my site. :)

When a customer selects "credit card payment" and enters their info, card # and continues - the order fails every time and asks them to re-enter their information. Any clues that would be helpful in fixing this issue would be most appreciated!

PS>> Im using payPal Direct Payment (for credit cards) and Paypal Standard IPN for payPal Payments.

Thanks in advance!

Link to comment
Share on other sites

did u upgrade your shop to 3.0.12 as well as i think the patch is for 3.0.12

Thanks for the reply, no I have not upgraded to 3.0.12. I am still running the old version with the new security patch.

Link to comment
Share on other sites

Well my customers still cant checkout successfully. Is there anyone who knows something I could be doing wrong?? It worked fine before the patch and now it doesnt...

Link to comment
Share on other sites

Well my customers still cant checkout successfully. Is there anyone who knows something I could be doing wrong?? It worked fine before the patch and now it doesnt...

Are you running any mods on your store?

You may have done this already, but my advice would be to use your backup to get the shop to how it was before you installed the security updates, and then use the change log for the security update to manually update the relevant files.

Link to comment
Share on other sites

Well my customers still cant checkout successfully. Is there anyone who knows something I could be doing wrong?? It worked fine before the patch and now it doesnt...

Are you running any mods on your store?

You may have done this already, but my advice would be to use your backup to get the shop to how it was before you installed the security updates, and then use the change log for the security update to manually update the relevant files.

Thanks. Thats what I will be working on this morning ;)

Link to comment
Share on other sites

OK, so ive upgraded my shop to 3.0.12 (from .10) and everything seems to have worked fine there, however, I am still having issues with people checking out. ;) Im thinking it might be some configuration setting within the payPal CC gateway. What things should I be troubleshooting within that gateway option? Again, Thanks so much for everyone's help. Its greatly appreciated!

confused,

-- Jim

Link to comment
Share on other sites

OK, so ive upgraded my shop to 3.0.12 (from .10) and everything seems to have worked fine there, however, I am still having issues with people checking out. ;) Im thinking it might be some configuration setting within the payPal CC gateway. What things should I be troubleshooting within that gateway option? Again, Thanks so much for everyone's help. Its greatly appreciated!

confused,

-- Jim

I'd test one of the other modules, such as the bank transfer option, to see if it really is something to do with pay-pal, or if something has broken within the base checkout code.

Which php & SQL versions are you using?

Link to comment
Share on other sites

The standard payPal IPN is working (sort of) it passes the price variable through, however my shipping price does not get passed through so its like its giving people "free shipping" with that option. no good.

Im running php v. 4.4.2sf4 and MySQL v. 4.0.27-standard

Would it make sense for me to replace my new paypal gateway folders with the 3.0.10 ones that worked?

I dont want to have to do a clean install of everything! Please help!

Thanx in advance!

Link to comment
Share on other sites

I'm afraid my own knowledge of Cube Carts inner workings stop around here. The best advice I can offer is to re-install from your backup, and submit a ticket to CC support.

If you haven't got to many mods, a clean install isn't to painful (providing you backup your database) but failing that, I'd really go through the change log of the security update, and cross reference them against your own files, it's possible you've simply missed something small when adding the security update, as it does seem odd that all was working fine before it, and now it's broke.

Good luck with fixing it though.

Link to comment
Share on other sites

Thanx for the reply, I have upgraded everything to 3.0.12 and am still having these issues....

looks like a clean install may be in order. Unless someone has another idea...

Thanx.

Link to comment
Share on other sites

OK Fellas,

I installed a brand new version of my CC store (on another location from my live store) and set up the two payment methods there, and still no luck. Does that tell you anything besides it sounds like a paypal problem :) figures... They seemed to think it was a CC issue.. Any ideas?

Still cant check out...

Thanx for any help!

-- Jim

Link to comment
Share on other sites

Are you linking this store up to the same database?

If so, something in that could be failing. Try linking it to a fresh database, and if that's not it then I'm at a total loss.

Nope... totally new database... I just cant figure it out...

Does it matter what I have the "Debug" setting set to? It doesnt seem to matter, because it give me the cryptic order failed either way...

Thanx.

-- Jim

Link to comment
Share on other sites

This may interest you.

Yesterday I got a mail from someone, telling me they were unable to add items to the shopping cart, that as soon as they did, they were taken back to the previous page and their cart was empty. I've now tested the shop with three different versions of Windows XP & IE, Firefox & Opera. I've also tested it on my own Mac with all the major browsers and the shop has checked out every time.

I've no idea what is causing the checkout problems with this one customer, but it's certainly not effecting the majority of customers (could it be an over zealous security setting?) so I'm leaving the shop alone for now.

My advice would be to check your store on from another PC, and if that makes a difference, maybe we can track down which setting is causing the trouble.

Link to comment
Share on other sites

This may interest you.

Yesterday I got a mail from someone, telling me they were unable to add items to the shopping cart, that as soon as they did, they were taken back to the previous page and their cart was empty. I've now tested the shop with three different versions of Windows XP & IE, Firefox & Opera. I've also tested it on my own Mac with all the major browsers and the shop has checked out every time.

I've no idea what is causing the checkout problems with this one customer, but it's certainly not effecting the majority of customers (could it be an over zealous security setting?) so I'm leaving the shop alone for now.

My advice would be to check your store on from another PC, and if that makes a difference, maybe we can track down which setting is causing the trouble.

Thanx for the reply. I have tested this checkout process on multiple machines, at multiple locations, and still no luck. I have followed all set up directions to a T and still nothing works... Im at a loss... Could my hosting company have changed something that would be affecting this process?

Thanx.

-- Jim

Link to comment
Share on other sites

This may interest you.

Yesterday I got a mail from someone, telling me they were unable to add items to the shopping cart, that as soon as they did, they were taken back to the previous page and their cart was empty. I've now tested the shop with three different versions of Windows XP & IE, Firefox & Opera. I've also tested it on my own Mac with all the major browsers and the shop has checked out every time.

I've no idea what is causing the checkout problems with this one customer, but it's certainly not effecting the majority of customers (could it be an over zealous security setting?) so I'm leaving the shop alone for now.

My advice would be to check your store on from another PC, and if that makes a difference, maybe we can track down which setting is causing the trouble.

Thanx for the reply. I have tested this checkout process on multiple machines, at multiple locations, and still no luck. I have followed all set up directions to a T and still nothing works... Im at a loss... Could my hosting company have changed something that would be affecting this process?

Thanx.

-- Jim

If it's a fresh install and a fresh database, I honestly can't think of anything else which may suggest why Cube Cart is failing you. If you've got the cash, you could always hire somebody very experienced with CC to do an install for you, and let them figure out what's going wrong.

Link to comment
Share on other sites

I had the same problem after my server company upgraded its php to 4.4.4.. They did not include the curl library, so I had them re-compile to include the curl and everything started working.. I did several installs in seperate databases with both 3.012 and 3.011 and both versions did the same thing.. It would not only fail payments in direct paypal.. but it would not record any errors in the pear/tmp folder .. Its working fine now.. both versions..

Link to comment
Share on other sites

I had the same problem after my server company upgraded its php to 4.4.4.. They did not include the curl library, so I had them re-compile to include the curl and everything started working.. I did several installs in seperate databases with both 3.012 and 3.011 and both versions did the same thing.. It would not only fail payments in direct paypal.. but it would not record any errors in the pear/tmp folder .. Its working fine now.. both versions..

Thanks for the heads up! That may very well be the problem then! I will talk to them and let you know how I make out. I really do appreciate everyone's help in the matter!

-- Jim

Link to comment
Share on other sites

*UPDATE*

ALL FIXED! My host needed to update the curl settings on my account and once they did, everything started to work! Many thanks to everyone on this forum who helped me solve this issue! I really do appreciate it!

I only hope that this thread will help others with similar problems in the future!

Kind Regards,

-- Jim

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...