Jump to content

Reset passwords not e-mailed


Guest TomM
 Share

Recommended Posts

I'm just setting up CC for the first time, and have created two test accounts. When I try the reset password feature, I get a "success" page, but no e-mails are sent. Two different e-mail accounts, two different ISPs.

On the other hand, the bulk mail feature DOES work, so I know the SMTP settings are correct.

The hosting company isn't helpful about getting access to mail logs or queues, so I can't debug that way. I'm a newbie at PHP so I'm not really sure which files to monkey around with.

The store is at http://www2.martinspretzels.net/orders/index.php

Any help?

Link to comment
Share on other sites

Thanks, but using mail() isn't working either. I've tried it with and without authentication, pointing at the external mail server, pointing it at localhost.

The bulk mail continues to work in all these variations, but the password messages do not. The password IS being changed, however, because after I make the request the original password doesn't work.

Link to comment
Share on other sites

Found the answer: it has to do with mail servers that are running qmail. Servers running sendmail aren't as strict. For some reason the body of the password reset message has bare linefeeds in it, which is forbidden by 822bis section 2.3. The code that's built into smtp.php isn't enough to fix these.

Around line 142 find these lines:

$body = str_replace(CRLF.'.', CRLF.'..', $this->body);

$body = $body[0] == '.' ? '.'.$body : $body;

and replace them with

$body = preg_replace('#(?<!\r)\n#',CRLF,$this->body);

$body = str_replace(CRLF.'.', CRLF.'..', $body);

$body = $body[0] == '.' ? '.'.$body : $body;

Found the answer here: http://www.phpguru.org/PariahBB/static/MIME/172

Link to comment
Share on other sites

  • 9 months later...

Around line 142 find these lines:

$body = str_replace(CRLF.'.', CRLF.'..', $this->body);

$body = $body[0] == '.' ? '.'.$body : $body;

I can't find these lines anywhere in CubeCart, I am haveing the same exact problem as described here though and would appriciate greatly any help.

Thanks

Link to comment
Share on other sites

Guest dtmswebmaster

Around line 142 find these lines:

$body = str_replace(CRLF.'.', CRLF.'..', $this->body);

$body = $body[0] == '.' ? '.'.$body : $body;

I can't find these lines anywhere in CubeCart, I am haveing the same exact problem as described here though and would appriciate greatly any help.

Thanks

For me it was located in /classes/smtp.php on lines 141 - 143. Hope this helps. :)

Link to comment
Share on other sites

Guest dtmswebmaster

For me it was located in /classes/smtp.php on lines 141 - 143. Hope this helps. :)

What version of CC are you running?

CubeCart 3.0.16

Link to comment
Share on other sites

Guest pixelsdesign

For me it was located in /classes/smtp.php on lines 141 - 143. Hope this helps. :)

What version of CC are you running?

CubeCart 3.0.16

Hi, I tried that. Nothing happen. Any other suggestion?

thanks.

Link to comment
Share on other sites

Guest pixelsdesign

walter4, did this fix your problem?

I did exactly as described and went and tested. no email reply.

Please help! :)

Link to comment
Share on other sites

  • 1 month later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...