Jump to content

Archived

This topic is now archived and is closed to further replies.

Al Brookbanks

New Nochex APC Module

Recommended Posts

Guest johnp.

Hi

I have just upgraded to .15 from .12 and most things are working as I would expect - still got various mods to install again.

However first thing i wanted was the Nochex gateway.

I already had Nochex as a gateway even though it did not pass back to the site properly.

Everything appeared to work OK ie I was passed to Nochex, payment made, no obvious payment complete window which was disturbing (customers will want that sort of confirmation) then I was passed back to my site home page. Mostly fine - no confirmation window - however the shopping cart did not update properly. It still showed the item in the cart. However when I tried to pay again it only then confirmed the cart was empty.

Can this be sorted, have I something to do to set it up.

I have done nothing to re set up the gateway and cannot see how to access the module to do things like a test item.

Comments welcome.

This is a very important mod so thanks to those making this work.

Nochex is much more friendly to the customer who just wants to pay by card without registering, its British so keeps the money here, has a good reputation, works just as well for those who register. Its pretty low cost.

Share this post


Link to post
Share on other sites

Guest johnp.

Hi

Followin up on my last post. Yes there is a clear payment confirmed page at the Nochex site, must have been on Auto pilot.

However when returned to site the shopping basket does not empty and can be paid for again.

Share this post


Link to post
Share on other sites
Guest johnp.

Hi, following my last posts its all sorted!

OK we are now cooking and the gas must be on high.

I had upgraded via the upload from 12 to 13 then uploads to.14 and .15

The upload for .15 contains the ammended confirmed.inc.php file. However it does not contain the Nochex files contained in the CubeCart_Nochex_APC.1.2.zip. I installed these seperately from the downloaded .zip file, ran the sql querie using phpMyAdmin - thats a bit daunting. I just ran it as an sql querie.

Then back to the admin gateway on my site and there was a new Nochex gateway.

And it works.

I like the new Nochex page, nice and clear, quite a few boxes to tick but helps clarify the Nochex appearing on the transaction statement. Will our sellers reference appear as well eg Nochex Ann Millers Mushrooms

Then back to the web site and confirmation of the transaction.

All very smooth. In fact bloody brilliant.

May now consider upgrading to a Merchant account.

Thanks to all, hope this helps others. Love it.

:dizzy:

Share this post


Link to post
Share on other sites
Guest martino

Hi,

I have recently upgraded my store from 3.12 to 3.15.

Installed the new Nochex module from CubeCart_Nochex_APC.1.2.zip

Have hit a couple of problems with this module though.

1) Shipping charges are not being added to payment at Nochex

2) Not being returned to store after making payment.

This is with the module set up for a Seller account not a Merchant account.

Have tried this module on 2 stores with the same result.

Any clues where to start looking to fix it???

Cheers

Martin

Share this post


Link to post
Share on other sites
Guest martino

Just to add to my post above,

I have found that if I set the Nochex Account Type to Merchant but leave the Merchat ID empty the shipping information is passed over correctly.

Don't know what the implications of this would be with Nochex though.

I have tried this on 2 different servers and got the same result.

Can't believe I am the only person using a Nochex Sellers account that is having this problem lol!!

Share this post


Link to post
Share on other sites
Guest nochex_uk

Hi Martino,

it would seem from johnp's comments above that he's a Nochex Seller Account holder and not reporting these problems.

I have notified the person who wrote the module - can I please make you aware it was not written by Nochex and Nochex does not offer direct support for it, however we are trying to help where possible.

I will PM johnp to see if he's having similar issues or could offer you any tips.

HTH

S

Just to add to my post above,

I have found that if I set the Nochex Account Type to Merchant but leave the Merchat ID empty the shipping information is passed over correctly.

Don't know what the implications of this would be with Nochex though.

I have tried this on 2 different servers and got the same result.

Can't believe I am the only person using a Nochex Sellers account that is having this problem lol!!

Share this post


Link to post
Share on other sites
Guest martino

Hi Martino,

it would seem from johnp's comments above that he's a Nochex Seller Account holder and not reporting these problems.

I have notified the person who wrote the module - can I please make you aware it was not written by Nochex and Nochex does not offer direct support for it, however we are trying to help where possible.

I will PM johnp to see if he's having similar issues or could offer you any tips.

HTH

S

Hi,

Many thanks for your reply.

I have contacted Nochex Support directly about this just on the off chance that it was something to do with my Nochex account.

I really don't understand why it works when set to Merchant account but not when set to Sellers account.

Guess I could just upgrade to a Merchant account lol!!!

Thanks for your help

Martin

Share this post


Link to post
Share on other sites
Guest johnp.

Hi

I did not have any problems with Nochex feeding back to the site. However one possible reason is that I had previously had a similar problem witt Paypal.

I solved this by inserting a 5 second delay in the \includes\content\confirmed.inc.php file. This would also be in operation for Nochex. For Paypal I understand the the delay was needed for the two sites to communicate effectively - info for this came from the Paypal gateway discussion. Would be worth a try.

The following are my notes on the 5 seconds delay.

1 allows Paypal to confirm payment details with Cubecart & for Cubecart to update. Otherwise customer returns and despite a completed transaction it does not show as such. \includes\content\confirmed.inc.php

*/sleep(5); inserted at start:

| confirmed.inc.php

| ========================================

| Order Confirmation

+--------------------------------------------------------------------------

*/sleep(5);

Could it be that the misinformation about the Merchant account creates a delay thus allowing communication?

Its a fairly quiet time on our site just now but we have only had one transaction that completed and did not feed back correctly - not sure where the problem lay but our site did not mark the order as "processing" though it had been successful. About 15-20 successful nochex transactions so far. Have a look www.annforfungi.co.uk

Has anyone experience of a merchant account using the new gateway? Would certainly be interested in seeing the site and hearing your experiences.

Hope this helps.

Just to add to my post above,

I have found that if I set the Nochex Account Type to Merchant but leave the Merchat ID empty the shipping information is passed over correctly.

Don't know what the implications of this would be with Nochex though.

I have tried this on 2 different servers and got the same result.

Can't believe I am the only person using a Nochex Sellers account that is having this problem lol!!

Share this post


Link to post
Share on other sites
Guest martino

Hi Johnp,

Many thanks for your response.

I have tried what you suggested but unfortunately it did not make any difference

At a complete loss with this one lol!

Many Thanks

Martin

Hi

I did not have any problems with Nochex feeding back to the site. However one possible reason is that I had previously had a similar problem witt Paypal.

I solved this by inserting a 5 second delay in the \includes\content\confirmed.inc.php file. This would also be in operation for Nochex. For Paypal I understand the the delay was needed for the two sites to communicate effectively - info for this came from the Paypal gateway discussion. Would be worth a try.

The following are my notes on the 5 seconds delay.

1 allows Paypal to confirm payment details with Cubecart & for Cubecart to update. Otherwise customer returns and despite a completed transaction it does not show as such. \includes\content\confirmed.inc.php

*/sleep(5); inserted at start:

| confirmed.inc.php

| ========================================

| Order Confirmation

+--------------------------------------------------------------------------

*/sleep(5);

Could it be that the misinformation about the Merchant account creates a delay thus allowing communication?

Its a fairly quiet time on our site just now but we have only had one transaction that completed and did not feed back correctly - not sure where the problem lay but our site did not mark the order as "processing" though it had been successful. About 15-20 successful nochex transactions so far. Have a look www.annforfungi.co.uk

Has anyone experience of a merchant account using the new gateway? Would certainly be interested in seeing the site and hearing your experiences.

Hope this helps.

Share this post


Link to post
Share on other sites
Guest notting

Hi Johnp,

Many thanks for your response.

I have tried what you suggested but unfortunately it did not make any difference

At a complete loss with this one lol!

Many Thanks

Martin

Hi

I did not have any problems with Nochex feeding back to the site. However one possible reason is that I had previously had a similar problem witt Paypal.

I solved this by inserting a 5 second delay in the \includes\content\confirmed.inc.php file. This would also be in operation for Nochex. For Paypal I understand the the delay was needed for the two sites to communicate effectively - info for this came from the Paypal gateway discussion. Would be worth a try.

The following are my notes on the 5 seconds delay.

1 allows Paypal to confirm payment details with Cubecart & for Cubecart to update. Otherwise customer returns and despite a completed transaction it does not show as such. \includes\content\confirmed.inc.php

*/sleep(5); inserted at start:

| confirmed.inc.php

| ========================================

| Order Confirmation

+--------------------------------------------------------------------------

*/sleep(5);

Could it be that the misinformation about the Merchant account creates a delay thus allowing communication?

Its a fairly quiet time on our site just now but we have only had one transaction that completed and did not feed back correctly - not sure where the problem lay but our site did not mark the order as "processing" though it had been successful. About 15-20 successful nochex transactions so far. Have a look www.annforfungi.co.uk

Has anyone experience of a merchant account using the new gateway? Would certainly be interested in seeing the site and hearing your experiences.

Hope this helps.

I am having the exact same problem re postage costs, under the exact same circumstances.

If I turn the cubecart settings to merchant this will make the postage add to the final payment? Can anyone see any potential problems with this?

Notting

Share this post


Link to post
Share on other sites
Guest antony734

hi guys,

im losing money!! :)

help! basically i wasnt aware this nochex apc modul was NEW??? but i installed it and started taking payments , ppl checkout with it and pay for the item however it doesnt include the postage costs in the total costs of the item once checkout in my cubecart site???

any1 had this problem or know a FIX??

any help much appreicated

thanks

ant

ps im running cc 3.0.17

Share this post


Link to post
Share on other sites
Guest jod

Hi ant,

I think this thread is about the same problem and might help you:

http://forums.cubecart.com/index.php?showtopic=29334

hi guys,

im losing money!! :)

help! basically i wasnt aware this nochex apc modul was NEW??? but i installed it and started taking payments , ppl checkout with it and pay for the item however it doesnt include the postage costs in the total costs of the item once checkout in my cubecart site???

any1 had this problem or know a FIX??

any help much appreicated

thanks

ant

ps im running cc 3.0.17

Share this post


Link to post
Share on other sites
Guest Rog

Hi Martino,

it would seem from johnp's comments above that he's a Nochex Seller Account holder and not reporting these problems.

I have notified the person who wrote the module - can I please make you aware it was not written by Nochex and Nochex does not offer direct support for it, however we are trying to help where possible.

I will PM johnp to see if he's having similar issues or could offer you any tips.

HTH

S

Hi,

Many thanks for your reply.

I have contacted Nochex Support directly about this just on the off chance that it was something to do with my Nochex account.

I really don't understand why it works when set to Merchant account but not when set to Sellers account.

Guess I could just upgrade to a Merchant account lol!!!

Thanks for your help

Martin

Hi,

I'm having exactly the same problems. If I select seller account (as I have a seller account) It appears Notchex doesn't pass back info to my shop. The order is not set to 'processing' and the stock count isn't lowered. It also doesn't take the postage costs over to Notchex. Using the merchant account setting works fine, but I don't have a merchant account.

Could this cause any problems?

The link above explains the postage not adding to the order but not the lack of feedback of info from Notchex. Did anyone manage to work out what is going on here?

Thanks,

Rog

Share this post


Link to post
Share on other sites

×
×
  • Create New...