Jump to content

Payment received for orders- Orders do not exist in database!


Guest valencia
 Share

Recommended Posts

Guest valencia

I have been having a reoccuring problem with my customer orders . At first it was just a once a blue moon occurence, but now I have seen it with some amount of frequency.

1. I receive payment notification for an order, no order report comes from cubecart, and the customer does not show up as a customer at all and no orders in the database for them. At this point I have to do the unprofessional thing to ask the customer for what they ordered.

OR

2. I receive payment notification for an order, and an order report from cubecart, the customer is registered under customers and it shows that there is an order, but the actual order does not show under orders. When you click the order number under customers, it says that there is no order for that customer in the database.

OR

3. Cubecart send out an order status report from the customer with a total that does not match the payment. When you log into cubecart, the order has changed but that order change was never sent out. Why do the order reports not match- the ones sent out and the actual order in cubecart?

I really need this cleared up as it is also affected my sales stats report. If the order is not in the system, then it cannot be picked up and accounted for as sales by the mod.

Please advise on how I need to proceed to prevent this re-occuring.

This has happened to no one else?

Even if it has not happened to anyone else, can anyone shed some light on this. Point me in teh right direction at least...

Link to comment
Share on other sites

Guest Starzstuff

I used to have the same problem with OS commerce. Maybe its a paypal problem. I ended us not installing paypal onto cube cart because of it.

Richard

I have been having a reoccuring problem with my customer orders . At first it was just a once a blue moon occurence, but now I have seen it with some amount of frequency.

1. I receive payment notification for an order, no order report comes from cubecart, and the customer does not show up as a customer at all and no orders in the database for them. At this point I have to do the unprofessional thing to ask the customer for what they ordered.

OR

2. I receive payment notification for an order, and an order report from cubecart, the customer is registered under customers and it shows that there is an order, but the actual order does not show under orders. When you click the order number under customers, it says that there is no order for that customer in the database.

OR

3. Cubecart send out an order status report from the customer with a total that does not match the payment. When you log into cubecart, the order has changed but that order change was never sent out. Why do the order reports not match- the ones sent out and the actual order in cubecart?

I really need this cleared up as it is also affected my sales stats report. If the order is not in the system, then it cannot be picked up and accounted for as sales by the mod.

Please advise on how I need to proceed to prevent this re-occuring.

This has happened to no one else?

Even if it has not happened to anyone else, can anyone shed some light on this. Point me in teh right direction at least...

Link to comment
Share on other sites

I can't offer any help for the first 2 issues, but for the 3rd I have a possible explanation.

When a customer places an order, but does not complete the payment process, they are sometimes able to go back in to their cart and edit the contents of the order and go through the checkout process again. This changes the contents of the order from what was originally emailed to the admin.

The first 2 issues appear at first glance to be an issue with MySQL on the server.

Link to comment
Share on other sites

Guest valencia

I can't offer any help for the first 2 issues, but for the 3rd I have a possible explanation.

When a customer places an order, but does not complete the payment process, they are sometimes able to go back in to their cart and edit the contents of the order and go through the checkout process again. This changes the contents of the order from what was originally emailed to the admin.

The first 2 issues appear at first glance to be an issue with MySQL on the server.

Thanks....I believe you are right.

It would help if the updated order is sent out as well by Cubecart. Sometimes I am on the road and cannot login but rely on my email notifications, when the order notification from cubecart does not change as it is edited, it can be quite a bummer :P

Incidentally, I noticed a customer, made an order which was then paid for. It did not reflect in Admin/orders, so I went into the database, found it and got it reflecting in admin. The order was set to processing.

2 days later the customer logs in again, somehow edits the order which now moves up to the top as a new pending order. The original order is nowhere to be found under the original order date. What the heck is this and how does cubecart account for this...

Better yet, a customer shows 2 orders, one with an obvious edit, with an extra item but with the same cart total.

Is there a problem with me or is this a bug..... I love Cubecart, but days like this gives me a splitting headache.... :unsure:

Link to comment
Share on other sites

Guest Brivtech

This is exactly why I've put this post and ones like it together - This topic was the inspiration.

I'm not convinced that the problem here has been examined in enough detail - Not enough to satisfy me at least.

Once we can get confirmation of certain common bugs, then I can add them into the bug report so that Al can do something to address them.

I'm going to try and see if I can reproduce any of these errors, such as the changing the basket after checkout. That's something that definetly shoudn't happen.

Link to comment
Share on other sites

Guest valencia

In continuation of my woes. I cannot get the original order that a customer placed to show up in admin. I changed the id as usual from 0 in database but since the customer went in and made/altered the order I cannot get the original order to show.

The customer's original order was paid for and she chose 21-44 days delivery. She has subsequently made another order/altered order which shows up in admin with a 5-9 days delivery.

Customer is now hounding me re delivery time as the newest order shows express. While I have the Paypal payment of the lower priced order, it would make life easier if this glitch was not happening.

Any ideas on how orders may be manipulated by customers?? :yeahhh:

Link to comment
Share on other sites

  • 2 weeks later...
Guest estelle

(3) can occur often. The reason it is designed like this is so that if payment fails, the basket still contains their items so the customer can then try to make payment again. It is impossible to get the original order to show, because it has been updated with the customers latest order choices.

The reason why only one email is sent out is so that Admin is not flooded with emails. But, if you use an online gateway which clears the basket after successful payment, it is really unusual for a customer to be able to change their order *after* payment...

You could make changes to gateway.inc.php so that an email is sent to admin every time a customer progresses past the "Select gateway" page. Locate the two lines containing this:

if($basket['mailSent']==0){ // send only if not sent already for current order number

And change to this:

if(true){ // *always* send

(1) and (2) are dodgy, and personally i don't think they are related to any faults in CubeCart. Perhaps there is an issue with your web server causing database records to be deleted. Perhaps your hosting company made a boo boo. Perhaps someone has access to your admin area and is messing with your head by deleting orders. I have no idea :huh:

Link to comment
Share on other sites

Guest valencia

(1) and (2) are dodgy, and personally i don't think they are related to any faults in CubeCart. Perhaps there is an issue with your web server causing database records to be deleted. Perhaps your hosting company made a boo boo. Perhaps someone has access to your admin area and is messing with your head by deleting orders. I have no idea :rolly:

No apparent attempts of log in to my admin area and Bluehost says it is an issue with the cart, so at this point I really do not know...

If it was a one off occurrence I could have ignored it, but ever so often it happens, I just can't seem to spot a trend or pattern, but I am going to go back to Bluehost support to see if there is anyway they could be the problem in any way.

Thanks estelle :D , I am also going to try to institute the fix and let you all know if that works for problem 3.

Link to comment
Share on other sites

  • 2 weeks later...
Guest markyt

Perhaps I can shed some light here.....

I have the same issues on occasion (issue 2 I think), what happens is the order will be added to the CubeCart_order_sum table without a customer ID name or address (don’t ask me how or why). The order IS there, complete with delivery address and all the items (if you dig). When this happens I simply jump into the DB, look at the delivery address, find the customer in the CubeCart_customer table and copy and paste their customer ID, Name and details into their record in CubeCart_order_sum.

Bobs your uncle, fanny is your aunt and your order will appear. You will also need to jump into CubeCart_customer and increment their number of orders field by 1 to allow you to see it in the customer view as well as the order view.

I spot these easily because I have a mod that shows how many processing orders there are outstanding on the main page (if it says 5 but I can only see 4 in the orders screen I know we have a ghost order).

Why this happens, I dont know. It does look like a bug to me, but I can spot it easily and this fix works every time. I get about one of these a month.

With regards to the order being different and the amounts not adding up... I used to have this issue about 8 months ago but I believe the latest patches fix that.

Hope that helps!

Mark

Link to comment
Share on other sites

This last post makes me wonder if maybe letting customers purchase without registering might be involved in the issue.

I've never had the issue of orders not being associated with a customer, but then again I also require all customers to register an account. If this IS a bug in Cubecart, then maybe it's in the handling of non-registered customers.

It's something to check at least.

Link to comment
Share on other sites

The next thing to check would be whether any mods may have affected the order process.

Sometimes, you can follow the instructions for a mod perfectly, yet if the mod itself is buggy, then a bug still gets introduced into the code. If those who are having the issue would list the mods they have installed, maybe we can help narrow down the possibilities.

Link to comment
Share on other sites

Guest estelle

mark, i'm really glad you thought of this. I think this is the exact cause of the missing orders issue. This has happened to me once. I'm assuming it happens when a customer sits on a particular page (probably the gateway selection page) for long enough that they are logged out. But at this stage they would not be requested to log in again... the order is simply written straight to the database and the customer is sent off to make payment.

Link to comment
Share on other sites

Guest markyt

I am running 3.0.6 (I know, I know) with the security patches, SEO mod, order overview mod, some cosmetic mods and about 7-10 of my own little modifications (improved search, customised shipping modules, dispatch date reporting, cost price field, product sorting feild etc). Sorry its vuage but I have lost track of all the little tweaks I have made over the last year.

I accept that my own mods could have caused this issue, which is why I have lived with it for a few months and thought nothing of it. I was just suprised to see others with the (possibly) same issue.

I have heard that users that open multiple frames and start progressing through a single order in two windows may be able to cause mischeif. It was my understanding that the later patches fixed this type of problem.

Link to comment
Share on other sites

Guest markyt

Estelle...

That sounds spot on! Ill try it now on my cart. Ill sit it on the payment stage, pretent to have lost my card and go tidy the house and come back to it in 30 mins. ;)

Mark

Link to comment
Share on other sites

Guest valencia

Estelle...

That sounds spot on! Ill try it now on my cart. Ill sit it on the payment stage, pretent to have lost my card and go tidy the house and come back to it in 30 mins. :)

Mark

Let me know how it goes... I guess if all the mods I have might be the cause of this, then maybe I will have to start accepting the fact that I have to search carefully thru my orders and payments. Bummer, but I would not be giving my mods for this problem, annoying tho it be.... :D

Incidentally, all my 'lost' orders are thru the paypal gateway alone, never thru my CCavenue gateway

Link to comment
Share on other sites

Guest eltazaar

Hey Guys

First post to this forum from New Zealand!!

I have this problem as well. Customer made order, payment received through pay pal and no confirmation email or details of their address!! Is there a fix for this anyone????

Link to comment
Share on other sites

Guest valencia

Estelle...

That sounds spot on! Ill try it now on my cart. Ill sit it on the payment stage, pretent to have lost my card and go tidy the house and come back to it in 30 mins. :D

Mark

Tried this and I did not receive the error...signed up as a new customer, went away came back, checked out with paypal and sat on the payment page, order came up in admin, store did not log me out, the cart picked up right where I left it, so maybe that idea is a bust

Link to comment
Share on other sites

  • 2 years later...
Guest dannedrama

(3) can occur often. The reason it is designed like this is so that if payment fails, the basket still contains their items so the customer can then try to make payment again. It is impossible to get the original order to show, because it has been updated with the customers latest order choices.

The reason why only one email is sent out is so that Admin is not flooded with emails. But, if you use an online gateway which clears the basket after successful payment, it is really unusual for a customer to be able to change their order *after* payment...

You could make changes to gateway.inc.php so that an email is sent to admin every time a customer progresses past the "Select gateway" page. Locate the two lines containing this:

if($basket['mailSent']==0){ // send only if not sent already for current order number

And change to this:

if(true){ // *always* send

(1) and (2) are dodgy, and personally i don't think they are related to any faults in CubeCart. Perhaps there is an issue with your web server causing database records to be deleted. Perhaps your hosting company made a boo boo. Perhaps someone has access to your admin area and is messing with your head by deleting orders. I have no idea ;)

Hi Estelle or anyone else who can help me with this!

First off, thanks a lot for helping out with the e-mail issue. But I have another problem I reeally need help with..

When a customer places an order they get an ordernumber, proceeds to paypal och pays it. So far everything good. But when the same customer places a new order, might be the same day or the next (this actually happens to me quite often) the order gets the same ordernumber as the first one. The old order gets replaced in the database but that's allright since I receive the e-mail. However, my big issue is that paypal denies the customer to pay this order and says that it is allready paid for even though the amount is different! This makes it impossible for my customers to proceed with the payment after checking out and I receive a ton of e-mails.

Please, any help with this would be appreciated!! Can't the customer get a new ordernumber so that they can pay their next order as well!?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...