Jump to content

SSL Nightmare


Guest mlbracewell
 Share

Recommended Posts

Guest mlbracewell

I have read all the posts on SSL and have not found the help I need.

I have a dedicated SSL

Running on a Linux server

My admin settings are:

/webstore/

https://www.domain.com/webstore

When I turn ON the SSL, like so many others I cannot access ADMIN or the CART.PHP

I have downloaded the editconf.php file and turned OFF the SSL so I can get back into the ADMIN, but I cannot figure out what is wrong.

The SSL instructions seem simple and I have followed them to a tee. But no luck.

Can someone pleeaazzz help?

Link to comment
Share on other sites

Guest Cassera

Look at the settings in your global.inc.php file. The settings for your SSL are likely the same except with an https:// instead of http://

:D

Yah I tired that it dosent work. hmmm what I did was edit the /includes/sslSwitch.inc.php file. what i did was change where it says $enableSSl = 1; like on the 20th line or something like that after the copyright info at the top and change it to $enableSSl = ""; click save and then it will be back to normal. (note ssl will not be enabled if you do this) but if you want to enable it again then where you most likely put your link as http:// put https:// then click save then it will be good

it didnt seem to respond when i added the s in https:// directly from the file so just do it like how i just said

Link to comment
Share on other sites

What you did didn't fix the problem, it just prevented the problem from manifesting itself. You need to get the paths straight for it work properly.

I can tell you that the next version of CubeCart will help by auto-detecting most of your path settings.

:D

Link to comment
Share on other sites

Guest mlbracewell

OK - thanks for all the replies, but . . . .

1. I tried without the trailing slash /webstore (which doesn't even make sense since everything says to use it) and that didn't work. It locks me out of admin again

2. I went into the global.inc.php again and my settings are correct (I just added the s after http)

3. I'm not sure why I would go into the /includes/sslSwitch.inc.php file to turn off the SSL when you can use the editconf.php file to do that and more.

But that doesn't change the fact that I can't get the cart to work with SSL and the site is ready to go live except I can't get it to work with SSL!!!!

4. I looked at the last post about SSL not working with some hosting environments - This site is hosted by Network Solutions. I'll look into this and see if this is my problem.

I thought Cube Cart was the best, but I've never had this problem with a cart before. This is crazy to have so much trouble getting a cart to work under SSL.

Link to comment
Share on other sites

2. I went into the global.inc.php again and my settings are correct (I just added the s after http)

Thats your problem please make sure the value in global.inc.php is http not https.

Otherwise it will redirect from secure to secure and make an infinite loop.

To summarise:

In the global.inc.php

storeURL: http://www.domain.com/webstore

rootRel: /webstore/

In Admin:

Root Public HTML Path: /webstore/

HTTPS URL: https://www.domain.com/webstore

Link to comment
Share on other sites

You don't make it https in the global.inc.php file, you make that change in the control panel.

And you should never change sslSwitch.inc.php. Once your settings are right in admin, you should be fine. I'm guessing they're still wrong there.

You use the editconf.php to change the ssl switch in the config to let you back into admin to make the necessary changes.

If you're still having issues, e-mail or PM me FTP and ACP details and I'll be happy to help you get it up and running.

:D

Link to comment
Share on other sites

Guest mlbracewell

2. I went into the global.inc.php again and my settings are correct (I just added the s after http)

Thats your problem please make sure the value in global.inc.php is http not https.

Otherwise it will redirect from secure to secure and make an infinite loop.

To summarise:

In the global.inc.php

storeURL: http://www.domain.com/webstore

rootRel: /webstore/

In Admin:

Root Public HTML Path: /webstore/

HTTPS URL: https://www.domain.com/webstore

I was trying to say I did not make any changes to the global.inc.php file. I simply looked in the file and yes it is http:// no "s"

My settings are what you have listed. That's why I can't figure out why the store won't work under SSL

You don't make it https in the global.inc.php file, you make that change in the control panel.

And you should never change sslSwitch.inc.php. Once your settings are right in admin, you should be fine. I'm guessing they're still wrong there.

You use the editconf.php to change the ssl switch in the config to let you back into admin to make the necessary changes.

If you're still having issues, e-mail or PM me FTP and ACP details and I'll be happy to help you get it up and running.

:D

BLESS YOU! I will email you with the FTP info, but what are ACP details?

Link to comment
Share on other sites

Guest mlbracewell

If you want to send a support ticket with FTP details and admin access we will investigate this for you. :D

Thanks I will. I bought more support time last night, but it said support was offline and I couldn't send a ticket.

Link to comment
Share on other sites

Guest Cassera

Look at the settings in your global.inc.php file. The settings for your SSL are likely the same except with an https:// instead of http://

:D

Yah I tired that it dosent work. hmmm what I did was edit the /includes/sslSwitch.inc.php file. what i did was change where it says $enableSSl = 1; like on the 20th line or something like that after the copyright info at the top and change it to $enableSSl = ""; click save and then it will be back to normal. (note ssl will not be enabled if you do this) but if you want to enable it again then where you most likely put your link as http:// put https:// then click save then it will be good

it didnt seem to respond when i added the s in https:// directly from the file so just do it like how i just said

Hmm worked for me now everythings fine must be different computers or something like that

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...