Jump to content

Shipping by Weight problems


Guest zappow
 Share

Recommended Posts

Guest zappow

Hi All

I am having big problems getting the shipping by weight working and would appreciate some guidance.

I have the following settings;

The unit weight I am shipping is 0.1 KG (100 grams) and this is what is set in the product desription.

I have set zone 1 in the shipping by weight module to GB and 0.1:4.30,0.5:4.75,1:6.00,2:7.75,10:19.45

However I still get 'Sorry

The total weight of your order it too high. Please contact us to see if we can make an alternative arrangement or reduce the amount of items in your basket.'

I have tried setting silly parameters (ie 10000000:20,00) but still get the same message.

What am I doing wrong?

Link to comment
Share on other sites

Guest hardnut33

i know its obvious but have you set your rate to KG in general settings...

also. have you tried entering the weights like this

0.050:1.00, 0.250:2.00, 0.500:2.50 rather than 0.1:4.30, so it looks like 0.100:4.30, 0.200:8.60,

im just going by how mine is working and yours isnt but i also have a space after every comma before the next weight and cost...i aint by any means an expert but its worth a try!!

Link to comment
Share on other sites

Guest zappow

Yes I have the weight set to KG in general and I have also tried what you suggested hard nut but I still have the same issue. I am still struggling with this does anyone have any ideas for rectifying this?

Link to comment
Share on other sites

  • 3 weeks later...
Guest RWheldon

Any more ideas on this???

Hi Zappow, I'm afraid I'm not going to be much help, but I am having exactly the same problem as you. Mine was set up as yours is and worked fine. The following day I have the 'overweight' problem and I haven't changed anything! It may be a bug in the latest release. I hope you get an answer.

Richard.

Link to comment
Share on other sites

Guest RWheldon

DOES ANYONE KNOW THE ANSWER!!!!!!

If not then the meaning of life? will do as a backup answer.

Hi Zappow,

I have got mine working properly, but I think it was more luck than actually fixing it.

Firstly, I removed the 'GB' from the zone 1 countries, replacing it with 'UK' (was just a hunch).

That didn't actually work, so I removed the '0' from zone 1 handling fee. This didn't work either.

I then switched the status to 'diabled'. Then re-enalbled it, switched the UK to GB and put the 0 back

in handling fee and applied it.

Now it works fine. I don't know what actually fixed it, but try doing the same, step by step as I did above.

Good luck.

Richard.

Link to comment
Share on other sites

Hi I have just done an upgrade for a client from V 3.0.0 to 3.0.16 and find that his shipping by weight is not working too. It appears to be the same issue as reported here. I have tried the various fixes none of which work. I assume this bug has happened on the latest update, problem is I have done 7 updates in one so cant roll back to the one before, if this problem has just started happening for users?

Please can anyone advise urgently how to resolve this as my clients store is effectively out of action as many of his items are heavy and weight is amajor factor. He also has Royal Mail configured for other items.

If more info is required please contact. Cheers Peter

http://www.supachitdesigns.com/

Link to comment
Share on other sites

Hi

I have just set up the postage by weight and it appears to work. For tests anyway. I found the country codes from someone else to fill in It is GB for the UK region for example. The below is an exact copy of the entries I wrote in Notepad and copied into the admin setup screen so I know they work exactly as printed here.

One peculiarity is that the price bands are for 136 grams more than my weights here as all of my books packaging are assumed to weigh 136 grams i.e instead of the price for 250g the table ias set up for the weight of 114 gr etc.

I use the postage by weight option rather than Royal Mail as unless I am missing something they are worked in the same way. I would appreciate input from anyone who knows why the Royal Mail module differs.

POSTINGS USED. (Note I have put a carriage return atr the end of rows to make post manageable but hter are NO GAPS at all in the strings of company abbreviations, or the prices.)

UK

GB

Europe

AL,AD,AM,AT,AZ,BA,BE,BG,BY,CY,CZ,DE,DK,EE,ES,FI,FO,FR,GI,GL,GR,HU,HR,IS,IE,IT,KZ

,LI,LT,LU,LV,MK,MT,PL,PT,SE,SI,SK,SM,RU,UZ,UA,TM,TR,TJ,CH,MD,MC

Rest of World

AX,AF,DZ,AS,AO,AQ,AI,AG,AR,AW,AU,BS,BH,BD,BB,BZ,BJ,BM,BT,BO,BW,BV,BR,IO,BN,BF,BI

,KH,CM,CA,CV,KY,CF,TD,CB,CL,CN,CX,CC,CO,KM,CG,CK,CR,CI,CU,DJ,DM,DO,TP,EC,EG,SV,GQ

,ER,ET,FK,FJ,FX,GF,PF,TF,GA,GM,GE,GH,GI,GD,GP,GU,GT,GN,GW,GY,HT,HM,HN,HK,IN,ID,IR

,IQ,IL,JM,JP,JO,KE,KI,KP,KR,CS,KW,KG,LA,LB,LS,LR,LY,MO,MG,MW,MY,MV,ML,MH,MQ,MR,MU

,YT,MX,FM,MN,CS,MS,MA,MZ,MM,NA,NR,NP,NL,AN,NC,NZ,NI,NE,NG,NU,NF,MP,NO,OM,PK,PW,PA

,PG,PY,PE,PH,PN,PR,QA,RE,IE,RO,RW,KN,LC,VC,WS,ST,SA,SN,CS,SC,CL,SG,SB,SO,ZA,GS,ES

,LK,SH,PM,SD,SR,SJ,SZ,CH,SY,TW,TH,TG,TK,TO,TT,TN,TC,TV,UG,AE,US,UM,UY,VU,VA,VE,VN

,VG,VI,WF,EH,YE,YU,ZR,ZM,ZW

PLEASE NOTE

1. Prices are not included as they change them all the time.

2. You need to remove the spaces (use Notepad Search and Replace),they are added here so the post wraps nicely.

Enjoy!

UK 1st Class

0.114:1.38,0.364:1.84,0.614:2.38,0.864:2.92,1.114:4.25,1.364:5.00,1.614:5.75,1.8

64:6.50,2.114:7.25,

2.364:8.00,2.614:8.75,2.864:9.50,3.114:10.25,3.364:11.00,3.614:11.75,3.864:12.50

,4.114:13.25,

4.364:14.00,4.614:14.75,4.864:15.50,5.114:16.25

UK 2nd class:

0.114:1.20,0.364:1.52,0.614:1.92,0.864:2.30,1.114:4.25,1.364:4.95,1.864:5.68,3.8

64:8.24,5.864:9.35,

7.864:10.67,9.864:11.45,19.864:13.33

Europe Airmail

0.124:1.86,0.144:1.96,0.164:2.08,0.184:2.20,0.204:2.30,0.224:2.40,0.244:2.50,0.2

64:2.60,

0.284:2.70,0.304:2.80,0.324:2.90,0.344:3.00,0.364:3.10,0.384:3.20,0.404:3.30,0.4

24:3.40,0.444:3.50,

0.464:3.60,0.484:3.70,0.504:3.80,0.524:3.90,0.544:4.00,0.564:4.10,0.584:4.20,0.6

04:4.30,0.624:4.40,

0.644:4.50,0.664:4.60,0.684:4.70,0.704:4.80,0.724:4.90,0.744:5.00,0.764:5.10,0.7

84:5.20,0.804:5.30,

0.824:5.40,0.844:5.50,0.864:5.60,0.884:5.70,0.904:5.80,0.924:5.90,0.944:6.00,0.9

64:6.10,0.984:6.20,

1.004:6.30,1.024:6.40,1.044:6.50,1.064:6.60,1.084:6.70,1.104:6.80,1.124:6.90,1.1

44:7.00,1.164:7.10,

1.184:7.20,1.204:7.30,1.224:7.40,1.244:7.50,1.264:7.60,1.284:7.70,1.304:7.80,1.3

24:7.90,1.344:8.00,

1.364:8.10,1.384:8.20

World Airmail

0.124:3.24,0.144:3.45,0.164:3.66,0.184:3.86,0.204:4.06,0.224:4.26,0.244:4.46,0.2

64:4.66,0.284:4.86,

0.304:5.06,0.324:5.26,0.344:5.46,0.364:5.66,0.384:5.86,0.404:6.06,0.424:6.26,0.4

44:6.46,0.464:6.66,

0.484:6.86,0.504:7.06,0.524:7.26,0.544:7.46,0.564:7.66,0.584:7.86,0.604:8.06,0.6

24:8.26,0.644:8.46,

0.664:8.66,0.684:8.86,0.704:9.06,0.724:9.26,0.744:9.46,0.764:9.66,0.784:9.86,0.8

04:10.06,0.824:10.26,

0.844:10.46,0.864:10.66,0.884:10.86,0.904:11.06,0.924:11.26,0.944:11.46,0.964:11

.66,0.984:11.86,

1.004:12.06,1.024:12.26,1.044:12.46,1.064:12.66,1.084:12.86,1.104:13.06,1.124:13

.26,1.144:13.46,

1.164:13.66,1.184:13.86,1.204:14.06,1.224:14.26,1.244:14.46,1.264:14.66,1.284:14

.86,1.304:15.06,

1.324:15.26,1.344:15.46,1.364:15.66,1.384:15.86

World surface

0.114:1.56,0.164:1.82,0.214:2.08,0.264:2.34,0.314:2.60,0.364:2.86,0.414:3.12,0.4

64:3.38,0.514:3.64,

0.564:3.90,0.614:4.16,0.664:4.42,0.714:4.68,0.764:4.94,0.814:5.20,0.864:5.46,0.9

14:5.72,0.964:5.98,

1.014:6.24,1.064:6.50,1.114:6.76,1.164:7.02,1.214:7.28,1.264:7.54,1.314:7.80,1.3

64:8.06,1.414:8.32,

1.464:8.58,1.514:8.84,1.564:9.10,1.614:9.36,1.664:9.62,1.714:9.88,1.764:10.14,1.

814:10.40

Link to comment
Share on other sites

Many thanks for all that. Have found that my client had the 1st & 2nd class rates reversed? Also the shipping drop down only appears if you are a registerd customer on go to the View Basket/Address page, so I guess its working okay, but guests would not have an idea of the P&P costs whilst browsing. Maybe this will be fixed in version 4?

I will pass on the info supplied and see what he wants to do. Thanks again

Peter

Link to comment
Share on other sites

  • 2 weeks later...
Guest loperland

I have been having the same problem. I went in and made it disabled. I saved it. Then I enabled it again. It works great now. I don't know why but it does. hope it helps you.

Link to comment
Share on other sites

Hi guys - I'm having the same problem - for the last week the shipping by weight has not been working. I can not figure out for the life of me why. I has worked fine for the last year and now suddenly doesn't. I did a upgrade to 3.0.13 last month and everything worked fine after it.

It doesn't seem to make much sense that it suddenly stops working.

I have tried a number of things to get it started again from the sane to the downright desperate!

I'm going to attempt a upgrade to 3.0.16 now to see if that will kick start it.

But I'm wondering if it could be a database issue?

Is it possible it can not read the values in the weight option? flat rate is working but royal mail isn't which also works on weight.

anyway these are my thoughts -if any of this sounds plausible or if anyone else has recommendations I'd love to hear them!

Thanks

Patricia

Link to comment
Share on other sites

  • 5 weeks later...
Guest Nasir

Can someone here explain to me, why there is Shipping 1st Class Rates and Shipping 2nd Class Rates? When should we put in values in 1st and/or 2nd

Link to comment
Share on other sites

  • 3 weeks later...
Guest AIRTIME

Hi All

I'm setting up CC at the moment and the shipping config is really getting to me as I can't work out whats wrong.

I'm trying to set up by weight this is what I have done so far:

Zone 1 countries just typed GB

Handling Fee Tried leaving this blank and adding 0, makes no difference

Zone 1 Shipping 1st Class rates 0.250:2.50,0.500:3.25,0.750:3.80,0.990:4.50,1:6.20,5:7.20,10:13.00,15:13.00,20:1

3.00,25:13.00

Status enabled, tax exempt, then click edit config.

General settings is set to KG. Products have weight added.

When you view basket I take it the shipping is supposed to show there, but all I get is Shipping n/a.

Could someone tell me if I am missing something really simple. I have searched but could not find any helpful instructions/how to.

Thanks

Link to comment
Share on other sites

Guest AIRTIME

Hi again

Forget most of what I have said above, I have now found it does work once you start to go through the checkout, but is it supposed to show when customer "Views Basket" ?

Thanks

Link to comment
Share on other sites

Guest asymptech

Hi All

I am having big problems getting the shipping by weight working and would appreciate some guidance.

I have the following settings;

The unit weight I am shipping is 0.1 KG (100 grams) and this is what is set in the product desription.

I have set zone 1 in the shipping by weight module to GB and 0.1:4.30,0.5:4.75,1:6.00,2:7.75,10:19.45

However I still get 'Sorry

The total weight of your order it too high. Please contact us to see if we can make an alternative arrangement or reduce the amount of items in your basket.'

I have tried setting silly parameters (ie 10000000:20,00) but still get the same message.

What am I doing wrong?

Are you still having problems with this? If so, let me know if this helps. Instead of using ISO3 codes which are 3 letters, change the ISO codes to the 2 letters Cubecart will recognize. It worked for me. I was staggering for a while and when I changed it, it started to function. Anyways, go to Countries and Zones on the left hand side of the Control Panel and once you click it you will see 2 sets of ISO codes, ones are only 2 letters and the other ones are 3 letters with all the countries listed. Use to "ISO" 2 letter ones (left side of the country). ;) That is all I got, hehe, hope it works!

Link to comment
Share on other sites

Hi again

Forget most of what I have said above, I have now found it does work once you start to go through the checkout, but is it supposed to show when customer "Views Basket" ?

Thanks

No, it doesn't show shipping costs until it has an address to base it on, which is not in view basket, but around step 3 of the checkout process.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...