Jump to content

SSL issue


Guest craftmouse
 Share

Recommended Posts

Guest craftmouse

Hi...I am a total non-programmer. I had to hire someone to do my cart skin for me, so please bear with me and please try and understand that all of this is like reading Chinese in braile...

I have a dedicated account with an SSL certificate. A programmer I worked with before who couldn't skin the cart as they promised (long story there) demanded I have SSL since there is a login/registration requirement. So I got it. Paid extra for it. Now looks like from what I've read I really didn't NEED it since the security where it's most important is delivered by my merchant gateway anyway. Ok so that was $170 wasted dollars but now my entire site gives errors when adding products to the cart sometimes like adds 2 or 3 of the same product, and it gives that lovely 'some items are unsecure' box repeatedly thruout the order process. Is there a way to fix this that won't require me having to pull my hair out trying to learn how to fix it?

I've looked thru the forum but everything I've read makes my eyes glaze over. I'm just a lady trying to sell some handmade stuff online, I'm not a programmer and I'm not a developer/designer. So please I beg of you please answer as if you were trying to explain it to your grandma. :huh:

Thanks in advance.

Oh and the domain in question is www.craftmouse.com/index.php

Link to comment
Share on other sites

Just tried your store with both firefox and IE and its working fine for me as far as adding products to the basket. You relaise that when you click on buy it already adds the item to basket so if you then look at the details of the product and click buy again you get 2. Anyhow I cant get that part to go wrong. The some items are insecure apears to be coming up because of the image in the bottom right Bizrate customer..... Check and make sure that image is in the same directory as the others.

Nice site by the way :huh:

Link to comment
Share on other sites

  • 10 months later...

Hi Guys - this was the only post in the forums that I could find that related to the problem I'm having at the moment. I'm generally a MAC based user and have never noticed this before but presumably its been happening since we installed the SSL certificate.

The shop www.seaweedskinfoods.co.uk has been running in its current state for about 2 years its running 3.0.13 with an SSL. But new computer and management has meant that we have PCs now and have noticed "This page displays both secure and unsecure items. Are you sure you want to display unsecure items?" error notices whenever you enter onto any of the Cart pages. It pops up on every page of the cart process - very off putting to say the least.

I know its a IE setting to have this level of "security" however our clients are generally slightly older and not that computer savy.

I would like to find out if there is a way round this.

I tried removing all the background images from the cart pages - but ofcourse the product image then throws up the error.

I'm confused as to why this is happening as the SSL should encompass the whole site right?

Any light on this weird issue would be greatly appreciated!

Many Thanks

Patricia

Link to comment
Share on other sites

ssl encompasses, only,

Login, Logut, account, cart, gateway, confirmed, reg and admin.

[i think tahts all of them]

the only one that may be out of place is your email addy at the bottom.

try installing a free contact us mod @.org

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...