Jump to content

Another install error


cb2004
 Share

Recommended Posts

Reported this in the bugs but if anyone misses it:

Fatal error: Corrupted encoded data detected in /home/sites/majesticit.co.uk/public_html/store/index_enc_zend.php on line 0

Any ideas?

Also an install category in the bug tracker would be a good idea.

Link to comment
Share on other sites

It's working ok for me using Zend (http://brooky.com/test/admin.php). It may have something to do with the way the file was uploaded (ASCII/binary).

You could always try the Ioncube method edit /includes/global.inc.php change:

$glob['encoder'] = 'zend';



to:




$glob['encoder'] = 'ioncube';

You will then need to upload the correct ioncube loader to /ioncube

Link to comment
Share on other sites

Guest Brivtech

By default, WS-FTP Pro transfers .php files by ASCII, unless you remove the extension from the ASCII configuration page in the settings - I tried this, got the same problem.

Also, There is no global.inc.php

There is a global.inc.php-dst - but it doesn't include the string you're suggesting to replace.

Link to comment
Share on other sites

Guest Brivtech

Also, There is no global.inc.php

There is a global.inc.php-dst - but it doesn't include the string you're suggesting to replace.

I edited my post, and crossed with your reply.

Link to comment
Share on other sites

Any information you want you can have mate. FTP details or anything.

I am trying to upload a changed global file and everytime i try and upload I get a critical transfer error (FileZilla). Could this file be messed up in the distribution?

[edit]I deleted the file and re-uploaded it and its fine with the change to ioncube. I have not uploaded a loader either[/edit]

Link to comment
Share on other sites

@cb2004 feel free to PM me FTP access & the URL and I'll have a look for you.

EDIT: I just uploaded the file for GRC Media and it worked fine. I am sure this is an issue with FTP Transfer Mode.

Please make 100% sure you use binary mode. We use "Transit" on Mac OSX but you can do this with all FTP cleints.

Link to comment
Share on other sites

We use "Transit" on Mac OSX but you can do this with all FTP cleints.

I used Transit at home when uploading the files. I will check tonight when I get home (can't FTP, etc at work).

Link to comment
Share on other sites

Guest Brivtech

I've uploaded this 3 times to make sure - Firstly, in Auto mode, secondly, removing .php from the ascii mode list, and finally, forced binary mode for all files - Same problem each time.

I have Zend installed on my server, my php.ini shows:

Zend Optimizer

Optimization Pass 1 enabled

Optimization Pass 2 enabled

Optimization Pass 3 enabled

Optimization Pass 4 enabled

Optimization Pass 9 enabled

I don't have ioncube, so I'm just downloading a loader for it now from: http://www.ioncube.com/loaders.php

Will update the quick-fix post when I have got this working.

Link to comment
Share on other sites

@cb2004 feel free to PM me FTP access & the URL and I'll have a look for you.

EDIT: I just uploaded the file for GRC Media and it worked fine. I am sure this is an issue with FTP Transfer Mode.

Please make 100% sure you use binary mode. We use "Transit" on Mac OSX but you can do this with all FTP cleints.

I dont think this is an upload error. I tried binary and ascii but no joy. Most ftp programs with auto detect upload PHP files in ASCII. Maybe something should be put in the readme.txt in the distribution file.

Link to comment
Share on other sites

We tried in auto mode through filezilla to start and recieved error message.

We have manually overwritten and tried in both ASCII and Binary modes, with different errors dependant on the mode, a good indication of transfer type.

in Binary mode we recieve the following error message:

Fatal error: This encoded file is corrupted. Please refer to http://www.zend.com/support/support_faq.php?id=loader_file_corrupt for further help in /home/gwub/public_html/index_enc_zend.php on line 0



in ASCII mode i recieve this message:




Fatal error: Corrupted encoded data detected in /home/gwub/public_html/index_enc_zend.php on line 0



My phpinfo() indicates the following settings




Zend Optimizer

Optimization Pass 1 	enabled

Optimization Pass 2 	enabled

Optimization Pass 3 	enabled

Optimization Pass 4 	enabled

Optimization Pass 9 	enabled

Zend Loader 	enabled

License Path 	no value

Server running PHP 4.4.6

Regarding admin i am getting the following error message

Fatal error: Incompatible file format: The encoded file has format ID 3120702, which is too old in /home/gwub/public_html/admin_enc_zend.php on line 0

Hope this helps solve the problem.

Link to comment
Share on other sites

Guest Brivtech

You will then need to upload the correct ioncube loader to /ioncube

This isn't as straightforward as it seems so far - Is anyone else able to shed some light on this?

I've downloaded an ioncube loader using the link I gave in my above post, and inside the package is an .exe file.

I've run it, and it turns out to be a mini-ftp program that uploads the ioncube files into an ioncube folder, like Al suggests. I installed it at the store root, however, I get:

Site error: the file /<path edited>/index_enc_ion.php requires the ionCube PHP Loader ioncube_loader_lin_4.3.so to be installed by the site administrator.

This indicates that it's finding the file ok, but there should have been some additional installation happenig somewhere.

So, looking in the ioncube/ folder, I came across /ioncube/ioncube-loader-helper.php

An ionCube Loader file is required by PHP to read files encoded with the ionCube Encoder. This page will determine how you can install Loaders on this particular server.

The loading of ionCube encoded files is not currently working correctly on this server.

If you have permission to edit the php.ini configuration file for this server, please follow the php.ini installation instructions.

If you do not access to the php.ini file, please follow the run-time loading installation instructions.

Please read the online documentation, or review the file readme.txt enclosed with the Loader bundle, for more help with Loader installation.

- I don't have permission to edit php.ini (Unless I do, and I don't actually know how to).

- I tried run time loading, was told it was not possible.

- I don't have FTP access to: /web/ or /usr/local/ on my server - It's shared hosting that doesn't give too much control.

:P

Link to comment
Share on other sites

Guest markyvuk

Even though our server says it has Zend loaded we have downloaded the ioncube loaders and these problems don't seem to be occuring.

We are able to work with both admin and store pages with some functionality. There are many issues still to be resolved but we were to expect that at this stage.

We have tried to use Zend and we get error messages when we do, so we are sticking with Ioncube for now...

Markyvuk

Link to comment
Share on other sites

@Brivtech

The file you upload should end .so not .exe. The message should tell you which file you need. If you download the seemingly correct file and it doesn't work you may find that you need the 64bit or 32bit version. For Linux it should be on one of these packages:

http://downloads2.ioncube.com/loader_downl..._lin_x86.tar.gz (32 Bit)

http://downloads2.ioncube.com/loader_downl...n_x86-64.tar.gz (64 Bit)

@ Markyvuk

CCv4 uses either Zend OR Ioncube not both. If you get an error asking for an ioncube loader you'll need to find the one it asks for from http://www.ioncube.com/loaders.php. If you get a Zend error you may need to check the files uploaded in binary mode.

Of course we will have better documentation about all this prior to final release. :P

Link to comment
Share on other sites

Guest Brivtech

@Brivtech

The file you upload should end .so not .exe. The message should tell you which file you need. If you download the seemingly correct file and it doesn't work you may find that you need the 64bit or 32bit version. For Linux it should be on one of these packages:

http://downloads2.ioncube.com/loader_downl..._lin_x86.tar.gz (32 Bit)

http://downloads2.ioncube.com/loader_downl...n_x86-64.tar.gz (64 Bit)

:P

It ended in .exe as it was the ftp installer option that ftp'd the files into place. It was the loader for Linux (x86-64). The result was the same as the files in the zipped links you gave above.

I've just deleted all the files, ready to do a clean binary upload, (instead of over-writing the files). Will try again through Zend, and failing that, re-try ioncube, with the 32-bit version next.

Link to comment
Share on other sites

Guest Brivtech

Cheers, I've got to pop into the warehouse to get some orders out, when I get back, I'll see if the fresh binary upload works, try the x86 version of ioncube failing that, and if all else fails, expect a PM! :)

I've completely wasted the morning, :P and it's been great fun! :D

Link to comment
Share on other sites

Guest cntgifts

i isntalled ioncube and now i get this

Warning: fopen(/home/chris/public_html/cube/cache/lang.en.common.inc.php) [function.fopen]: failed to open stream: No such file or directory in /home/chris/public_html/cube/classes/cache/cache.php on line 73

Warning: fwrite(): supplied argument is not a valid stream resource in /home/chris/public_html/cube/classes/cache/cache.php on line 77

Warning: fclose(): supplied argument is not a valid stream resource in /home/chris/public_html/cube/classes/cache/cache.php on line 80

Cache not writable! Please disable cache functionality or make it writable.

i have chache permissions set at 777

Link to comment
Share on other sites

I got those errors when I tried doing an upgrade (on a copy of my main store files and a copy of the database) and the errors were because I had a /tmp directory for the cache and the permissions where not set correctly.

It's a permission issue somewhere, depending on what folder is set to be the cache folder. On a fresh install, it was the /cache/ directory on my system.

That's all the help I can offer on this one.

Link to comment
Share on other sites

Guest thereefstop

I delted my site, set my FTP to Binary, then uploaded the files again, this time it finally created the global.inc.php file however I cannot access the admin panel, it wont load.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...