Jump to content

Can't get site live on Windows Server


Guest
 Share

Recommended Posts

I have just moved my Local installation on a MAC to a Windows server and it really is a pain.

Now I am getting this message:

MySQL Error Occured

1146: Table 'ocal1_ocal.CubeCart_config' doesn't exist



QUERY = SELECT array FROM CubeCart_config WHERE name = 'config'



I asked the hosting company for server path, so paths should be okay. Here they are anyway




$glob['rootDir'] = 'D:\hshome\ocal\mysite.com';

$glob['rootRel'] = '/';

$glob['storeURL'] = 'http://www.mysite.com/';

What does this all mean?

Thanks

Link to comment
Share on other sites

Guest Brivtech

You need to update your configuration:

$glob['rootDir'] = 'D:\hshome\ocal\mysite.com';

is wrong, because this indicates it's on a local drive, not a server - The D: is the giveaway

$glob['rootRel'] = '/';

Probably right

$glob['storeURL'] = 'http://www.mysite.com/';

Probably right, if you actually put your site's URL in there.

Link to comment
Share on other sites

You need to update your configuration:

$glob['rootDir'] = 'D:\hshome\ocal\mysite.com';

is wrong, because this indicates it's on a local drive, not a server - The D: is the giveaway

$glob['rootRel'] = '/';

Probably right

$glob['storeURL'] = 'http://www.mysite.com/';

Probably right, if you actually put your site's URL in there.

HI thanks for that. Tried to change the root Directory but still the same.

What I really need is, am I getting this error because my paths are wrong or because there is something up with the Database.

Link to comment
Share on other sites

There might be something up with the database. To be sure, you need to visually inspect the table names of your store's database using something like phpMyAdmin.

See a write-up about this here:

http://www.cubecart.com/site/forums/index....st&p=130180

Basically, if your IIS6 has a MySQL system variable set a certain way, lettercase of table names become an issue. You said you had copied your development installation over to your production environment. What OS is your MAC running? That *nix variant? And what is the value of that system variable in your MAC's installation of MySQL? Are the table names in all lower case?

For a good explanation of the consequences of that system variable, "lower_case_table_names", search the MySQL developer's site's MySQL manual pages for it.

Link to comment
Share on other sites

Guest JodieR

I had terrible trouble with this also when I first tried to set things up. I actually found it easier to change my hosting over to Linux (instead of windows) and help immensely.

Link to comment
Share on other sites

MySQL Error Occured

1146: Table 'ocal1_ocal.CubeCart_config' doesn't exist



QUERY = SELECT array FROM CubeCart_config WHERE name = 'config'
Verify what you have in your \includes\global.inc.php: The name of your MySQL database as installed on your Windows server (dbdatabase) is 'ocal1_ocal'. You have not set a prefix (dbprefix) for CubeCart's set of tables in this database. It's a zero-length string.

$glob['rootDir'] = 'D:\hshome\ocal\mysite.com';

$glob['rootRel'] = '/';

$glob['storeURL'] = 'http://www.mysite.com/';

For the rootDir path, try this - for every backslash, make it four backslashes. That is:

$glob['rootDir'] = 'D:\\\\hshome\\\\ocal\\\\mysite.com';

And for the storeURL, try not putting the trailing slash on it.

See what happens - let us know.

Link to comment
Share on other sites

Guest hrioo

I had the same problem moving a CC installation from a Windows server to Linux server. I finally figured out it was a uppercase/lowercase issue, since Linux is case sensitive but Windows not. And since i had originally installed CC on the Windows machine it installed all references to "Cubecart_xxx" as "cubecart_xxx" in the database.

The easiest way i found was to manually open the database file and change all references to "cubecart_xxx" to "CubeCart_xxx" and upload it to the Linux machine to replace the old db.

Link to comment
Share on other sites

MySQL Error Occured

1146: Table 'ocal1_ocal.CubeCart_config' doesn't exist



QUERY = SELECT array FROM CubeCart_config WHERE name = 'config'
Verify what you have in your \includes\global.inc.php: The name of your MySQL database as installed on your Windows server (dbdatabase) is 'ocal1_ocal'. You have not set a prefix (dbprefix) for CubeCart's set of tables in this database. It's a zero-length string.

$glob['rootDir'] = 'D:\hshome\ocal\mysite.com';

$glob['rootRel'] = '/';

$glob['storeURL'] = 'http://www.mysite.com/';

For the rootDir path, try this - for every backslash, make it four backslashes. That is:

$glob['rootDir'] = 'D:\\\\hshome\\\\ocal\\\\mysite.com';

And for the storeURL, try not putting the trailing slash on it.

See what happens - let us know.

Hi

Thanks for all the advice. Tried what you said but this didn't work. Inspected the DB and found nothing out of the ordinary but chnaged a few things. Re uploaded the DB and suddenly it worked.

But then the Admin was spitting out errors and could't get access. Since I have been trying to get this to work for the last week and half I decided to move to a Unix Server. And guess what. I works flawlessly!

So the only lesson I have just learnt is stay away from Windows and PHP. The hosting company could not tell me why this was happening. Very frustrating. I wil never try that again, really not worth it.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...