Jump to content

Can't login to admin


Guest gwizard
 Share

Recommended Posts

Guest gwizard

I've just installed Beta2.1 on my localhost XAMPP (Windows, Apache 2, MySQL, PHP5) and for some reason I cannot login to admin.

Front works ok (a little slow though), but when I try to login into admin it just goes back to the regular login screen. No errors, no nothing. Tried in multiple browsers - nothing.

Any ideas ? :D

Link to comment
Share on other sites

Guest Brivtech

I'm stumped on this one myself. I'm guessing you've probably tried clearing cookies.

Are you using the admin with SSL? if so, you need to first check the use secure mode box, then enter your details after the page refreshes.

Link to comment
Share on other sites

Guest gwizard

I'm stumped on this one myself. I'm guessing you've probably tried clearing cookies.

Are you using the admin with SSL? if so, you need to first check the use secure mode box, then enter your details after the page refreshes.

Cookies are not the issue here since I used 2 separate "virgin" browsers.

SSL is not enabled since this is the first time I am trying to access the admin.

I am thinking it might be license issue, so I've double checked that the license key is intact and correct.

It is and on the CP it shows localhost as my host. Perhaps this still is a license issue and it doesn't support 127.0.0.1 as IP ?

Al ?

Link to comment
Share on other sites

I'm stumped on this one myself. I'm guessing you've probably tried clearing cookies.

Are you using the admin with SSL? if so, you need to first check the use secure mode box, then enter your details after the page refreshes.

Cookies are not the issue here since I used 2 separate "virgin" browsers.

SSL is not enabled since this is the first time I am trying to access the admin.

I am thinking it might be license issue, so I've double checked that the license key is intact and correct.

It is and on the CP it shows localhost as my host. Perhaps this still is a license issue and it doesn't support 127.0.0.1 as IP ?

Al ?

definitely not a licence issue, you'd know if it was. sounds like some kind of sessions/cookie problem, we had this before. haveyou got any kind of netfiltering/firewall software running?

Link to comment
Share on other sites

Guest gwizard

Since CC is on localhost I fail to see how firewall can be an issue. Specially, since the install went fine and I can browse front end without a problem.

Proxy is disabled.

Cookies and JS are on.

No filtering software.

What else could it be ?

Link to comment
Share on other sites

  • 2 weeks later...

This is known COOKIE domain name parameter issue. The quick solution:

classes/session/cc_admin_session.php

SEARCH FOR

setcookie($name, $value, $expires, $GLOBALS['rootRel'], $this->get_cookie_domain($GLOBALS['storeURL']));

USE THIS CODE

setcookie($name, $value, $expires, $GLOBALS['rootRel']);

Do the same for classess/session/cc_session.php if you would like to login as a customer :(

Link to comment
Share on other sites

done a bit of research, and grilled al about it all, and apparently its all to do with the callback from some payment module-or-other

can someone who had this trouble, try out this bit of code for me....

change

setcookie($name, $value, $expires, $GLOBALS['rootRel'], $this->get_cookie_domain($GLOBALS['storeURL']));

to


setcookie($name, $value, $expires, $GLOBALS['rootRel'], '.'.$this->get_cookie_domain($GLOBALS['storeURL']));

and let me know if it still works

Link to comment
Share on other sites

@estelle, qwizard

welcome :(

done a bit of research, and grilled al about it all, and apparently its all to do with the callback from some payment module-or-other

can someone who had this trouble, try out this bit of code for me....

change

setcookie($name, $value, $expires, $GLOBALS['rootRel'], $this->get_cookie_domain($GLOBALS['storeURL']));

to


setcookie($name, $value, $expires, $GLOBALS['rootRel'], '.'.$this->get_cookie_domain($GLOBALS['storeURL']));

and let me know if it still works

sorry, doesnt work. Using WAMP5 (PHP v5.2.2) on WinXP.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...