Jump to content

INSTALLING VERSION 3.0.17 FROM SCRATCH


Guest gratifize
 Share

Recommended Posts

Guest gratifize

I have followed all instructions to install 3.0.17 to my website. I removed the old store and everything that went with it, because I kept having too many problems with it. I had version 2.0.3 at first, but I want the newest possible version right now. I don't know what's wrong. I have installed all of the files as the instructions said, I'm using a new database, and yet nothing is happening when I go to the store main page. To see what I mean, go here:

My Store's Root Page

Any help you guys can offer is greatly appreciated. Thanks.

Awaiting a speedy reply,

GG

Link to comment
Share on other sites

In your FTP client, can you see index.php at:

/catalog

What happens if you create a different directory -ie /test

and upload a simple test HTML/image file and try to view it in your browser?

At what stage of the install process are you? - Did you run the install script, or have you not got that far?

I can't see an uploads directory anywhere, there is either a server problem, you've uploaded into the wrong location, or you've removed it (ie completed installation)

Jason

Link to comment
Share on other sites

Guest gratifize

Index.php is there, yes. I haven't tested a regular HTML page at all yet, so I'll try that and see what happens. There is no upload directory, because the instructions just told me to upload all of my files to the main directory, which in my case is "catalog." I didn't want the folder named "upload" to be apart of my URL when it comes time to direct people to my store. That's why I didn't make an upload folder. I did upload all of the "upload" folder contents into my "catalog" folder.

I didn't run the install script. This is what the directions told me to do:

1. Upload all of the files from the "upload" folder into a directory of my choosing, which was "catalog."

2. Then enter that URL in my browser, which in my case is http://www.gratifizegifts.com/catalog. When I did that, nothing happens. Should I be entering www.gratifizegifts.com/catalog/install instead???

That's all I have done so far.

Thanks for any help.

GG

In your FTP client, can you see index.php at:

/catalog

What happens if you create a different directory -ie /test

and upload a simple test HTML/image file and try to view it in your browser?

At what stage of the install process are you? - Did you run the install script, or have you not got that far?

I can't see an uploads directory anywhere, there is either a server problem, you've uploaded into the wrong location, or you've removed it (ie completed installation)

Jason

Link to comment
Share on other sites

Guest gratifize

Okay, I entered the "test" directory like you suggested and uploaded a picture file, which I was able to see. You can also see it here: Temporary Photo

I tried earlier today renaming the "catalog" folder to "upload" and enclosing that directory inside a new "catalog" directory. I then entered that URL in my browser to see if that made a difference. It didn't. So I reverted back to my original setup with "catalog" as the directory with all of my cubecart files in it. I don't know what else I need to be doing. Someone please help me.

GG

Link to comment
Share on other sites

Guest gratifize

I keep getting error 403, access forbidden. I had already tried that. Sorry, forgot to mention that in my earlier post today. Thanks anyway.

GG

Link to comment
Share on other sites

Guest gratifize

I decided to try the manual installation instructions since the automatic way was not working. These are the instructions I had for manually installing cubecart 3.0.17:

2. Manual Method

+------------------------------------------------

a. Upload all the files and folders to your server from the "Upload" folder. DONE

b. Make sure you have installed a MySQL Database which has a user assigned to it

DO NOT USE YOUR ROOT USERNAME AND ROOT PASSWORD DONE

c. Visit https://www.cubecart.com/build/ DONE

This will create two files for you:

1. global.inc.php

2. dump.sql

d. Open includes/global.inc.php and paste in the code created for you. The upload

this over the existing globlal.inc.pgp on your server. DONE

e. Create text file called dump.txt and paste in the code created from our site. Rename

this file to dump.sql and it can then be imported into your database using a tool

such as phpMyAdmin (http://www.phpmyadmin.net). Please make sure you import the

database into the one specified when you created the dump. DONE

f. If you have a Linux/Unix make sure the following folders are writable.

images/upload/ (Linux/Unix - Chmod to 0777)

images/upload/thumbs/ (Linux/Unix - Chmod to 0777) ALREADY WRITABLE

d. Your store should be installed and fully functional.

Okay, so having done all of this, my darn store still isn't working!!! If someone could please maybe send me a private message who is willing to help me work through this, I would be most appreciative - or post here please. I REALLY WANT TO GET THIS OVER AND DONE WITH. This has been a very frustrating switch from my old store to this one. That's why I was avoiding upgrading or reinstalling altogether for so long. Please help me, someone.

GG

Link to comment
Share on other sites

Guest gratifize

Some ideas -

What FTP client did you use and are you uploading in Auto/Binary or ASCII?

Have you tried changing any directory permissions?

How are you doing the current redirect? - Im wondering if an .htaccess file is causing the problem.

FYI - You do not need to install CubeCart in a directory such as /catalog you can just install it in the root folder if you wish which is sometimes called "public_html" or "www." or "htdocs".

I'm using SmartFTP in binary mode, which takes you directly to the main folder (without showing any "public_html" or "www" or "htdocs," nothing like that.

I haven't changed any permissions, but when I checked the images folders as the directions said, they were already set at 777 for read/write permissions

The redirect on my main page is a javascript program, but I've been using that for a long time and it's never interfered with anything. It only redirects someone to my store's URL, which used to be /catalog/upload, but now it's going to just be /catalog.

Also, I realize that I didn't need to upload to any specific folder, but I wanted to keep it close to the way it was so that when the store is up and running, I can use my old URL on my stationery and in other areas.

Thanks for replying.

GG

Link to comment
Share on other sites

Guest gratifize

Just as an experiment, I tried https: and got a SSL certificate valid for LiquidNet.

After accepting everything, all I got was the text "forkleft.net". Does that ring a bell anywhere?

I'm glad you brought this to my attention. I was unaware of this forkleft.net site. Somehow if you go use HTTPS at the beginning of my site's main URL, you are redirected to their site. I'm not sure how this is happening, but I'm going to work on finding out. LiquidNet I know about, but not forkleft.net. Thanks.

GG

Link to comment
Share on other sites

Guest gratifize

OK you're all set now. Your paths were wrong and the .htaccess file was preventing the site from validating.

:) You're a godsend, Roban. It's amazing to me how quickly you are able to get to the root of the problem. Thank you SO MUCH for all your help. Now, I've got to get used to this new system.

GG

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...