Jump to content

"Security Error. Domain Name Mismatch"


Guest Spoiled One
 Share

Recommended Posts

Guest Spoiled One

I've been having this problem for about 2 weeks, and my web host is completely incompetent! I've spoke to 9 different people and they don't know whats going on. ARG! They also have no knowledge of CubeCart so that doesn't help.

My store isn't live yet, obviously until this is fixed. When I first try to visit the front page of my store this is the message that pops up.

-----

"You have attempted to establish a connection with "www.spoiledonepets.com" However, the security certificate presented belongs to "spoiledonepets.com". It is possible, though unlikely, that someone may be trying to intercept your communication with the web site.

If you suspect the certificate shown does not belong to "www.spoiledonepets.com", please cancel the connection and notify the site administrator."

-----

To me it looks like they issued me a certificate wrongly, they forgot the "www" part at the beginning. So when I asked them about this, they said at this .htaccess file and that should fix it. Well, it didn't. I'm not sure if they didn't put in the right address or what. My brain is mush trying to figure all of this out.

I know theres gotta be someone that knows what I should do. Please help if you can.

Link to comment
Share on other sites

Guest EverythingWeb

As they *have* issued the certificated without the www., although this could be a mistake either with them or their ordering process, or what you requested, there is a 'way' around it.

You can 'force' people to use the non-www version, or alternatively, get them to re-issue with cert with www.

You can use .htaccess... something along the lines of:

RewriteCond %{HTTP_HOST} !^example\.com$ [NC]

RewriteRule .* http://example.com/ [L,R=301]

Alternatively, you can put a couple lines of PHP in the top of index.php to force it there.

Link to comment
Share on other sites

Guest Spoiled One

Here is the .htacess they gave me.

RewriteEngine On

RewriteCond %{SERVER_PORT} !^443$

RewriteRule ^(.*)$ http://spoiledonepets.com/$1 [R]

But it still gives me that same error pop up. In my General Settings of CubeCart, would should I change?

Do I have this right?

HTTP Absolute URL: (should be) http://spoiledonepets.com

HTTPS Absolute URL: (should be) https://spoiledonepets.com

should I change the HTTPS root path?

Then enable SSL?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...