Jump to content

Not Adding Products to Basket when Ordering


marvso
 Share

Recommended Posts

One of my good customers called me today to tell me that he could not order from my website because when he clicked on the "Buy" button it would not add anything to the basket. While on the phone I asked him to refresh his browser to see if that changed anything...nope. I tried it on my computer while on the phone with him and the products added just fine. He tried it again and it still wouldnt add. He was using Internet Explorer. I tried it on both Firefox and Internet Explorer and it worked just fine here. Any ideas? This makes me nervous about other customers not being able to order.

Thanks!

Marv Sobolesky

www.marvsmusic.com

Link to comment
Share on other sites

Since upgrading to CubeCart 4 I have had several customers who have said they have been unable to place an order.

I have not been able to replicate their problem.

I know there is a bug which makes ordering a product from search results not possible - has this been reported/fixed in versions after 4.1?

Chris.

Link to comment
Share on other sites

Since upgrading to CubeCart 4 I have had several customers who have said they have been unable to place an order.

I have not been able to replicate their problem.

I know there is a bug which makes ordering a product from search results not possible - has this been reported/fixed in versions after 4.1?

Chris.

I am running version 4.2.2 I just upgraded to this version from 4.1.1 about two weeks ago. I wasn't aware of this problem. How many others have this problem?

Marv

Link to comment
Share on other sites

Guest hennaboy

I also have a few odd customers report this.

There is a thread about this on the forum posted by Estelle I believe.

Really tricky to reproduce....i never have a problem - i can have one customer come back to me saying they have a problem but 20 after them order in just fine.

Im wondering if this is ISP related....for example AOL who provide their own software. If thats the case then its not anything in CC4 its the ISP and this can be passed on to the customer having the problem.

I have had customers trying to order at home/work had this problem then the same customer goes to work/home different ISP and computer and was able to order.

With the amount of orders we process daily Id know if there was a serious problem with this.

Link to comment
Share on other sites

I also have a few odd customers report this.

There is a thread about this on the forum posted by Estelle I believe.

Really tricky to reproduce....i never have a problem - i can have one customer come back to me saying they have a problem but 20 after them order in just fine.

Im wondering if this is ISP related....for example AOL who provide their own software. If thats the case then its not anything in CC4 its the ISP and this can be passed on to the customer having the problem.

I have had customers trying to order at home/work had this problem then the same customer goes to work/home different ISP and computer and was able to order.

With the amount of orders we process daily Id know if there was a serious problem with this.

Just makes one wonder how many out there are having problems and not notifying me..

Marv Sobolesky

www.marvsmusic.com

Link to comment
Share on other sites

  • 1 month later...
Guest KinderKitz

Hello Marv

I just had one of my customers email me and say they were having trouble adding to the basket. They were trying to order one item. They even registered thinking that registering may help but it made no difference. My store is www.hotrodautosupply.com. I am running V4.11. So I was checking the forum and found your thread. I just tried your store and the first item I attempted to add to the basket would not add. It was the Schertler DYN-M-SET Mandolin Pickup. Without registering, I attempted to add more items and ithey all added just fine. I went and tried to add the Schertler DYN-M-SET Mandolin Pickup again and it added just fine. I read another thread that talked about just the first item adding was a problem. Not sure what the fix is but just thought you'ld like to know.

I immediatly tried my store again thinking it might be that ISP thing but was unable to duplicate the problem. Let me know if you get this wrestled into shape. Thanks for now.

Rod

www.hotrodautosupply.com

Link to comment
Share on other sites

I've had a few reports of not being able to add products or products disappearing from the shopping cart. I believe there was a definate problem with earlier V4's and AOL users. However the latest V4 CC release seems to be much better. The closest I've got to identifying a problem is that customers with problems ordering seem to use works computers and are always on a network. I put the problem down to some kind of cookie restriction their network is running. Which there seems to be no way around it is probably a very very small percentage of customers that run into this problem but they always insist other websites allow them to order fine. It may just be the customer messing about!!!

A similar problem that customers have reported is MSN Explorer (Almost no one uses this browser but their seems to be a few arkward users out there) which some customers confuse with Internet Explorer (Almost every using the MSN brower thought they were using IE) has some serious issues with loading my CC website. It seems to always miss the Login part off the page and sometimes the shopping basket too. I actually had someone ask "Where is the shopping basket?" I explained but it wasn't on their screen. If only everyone online would automatically update and use both Firefox and IE then if one didn't work the other would for sure.

Link to comment
Share on other sites

Guest KinderKitz

Hello Marv

Rod here again. Because your site seems to having the same trouble that I am and I was able to duplicate it with your site, I thought I would try a few things. I am not using a masked ISP like AOL. I am not on a network. I do not use a Mac. I use a PC on a dedicated line not wireless. I test using IE 7 and Fire Fox 2.0.0.15. I cleared all my cookies and went back to your site testing with both browsers. Both browsers produced identical results. The first item never adds to the basket but each item thereafter will. I also tried using just one item and the first time I clicked "buy" nothing was added to the basket but the "View Basket" button does flash. The second time I clicked the "Buy" button the item was successfully added to the cart.

I immediatly went to my site, www.hotrodautosupply.com, and performed the same tests. Items were added to the basket successfully the first and every time thereafter. I am running CC4 V 4.1.1. Frustrating because I can duplicate the trouble my customers are having but only on your site. May be let me know if you stumble onto the solution. Thanks again for now. Cheers

Rod

Link to comment
Share on other sites

Guest hennaboy

See this topic

Especially the bits mentioned by estelle and check your cart config.

http://forums.cubecart.com/index.php?showtopic=34573

Actually I would DEFINITELY check your global.inc file

I just checked your website again. 1st try was at http://marvsmusic.com added a product....view basket flashed but nothing in the basket. I then changed it to www.marvsmusic.com and reloaded the page..... there it is in the basket.

Changed back to without www and nothing is in the basket.

Note that you can use .htaccess to do a 301 redirect to stop people using your domain without the www

Link to comment
Share on other sites

  • 4 months later...
Guest horseflyuk

I'm finding that if you turn your security settings up to high and try to add a product to basket it wont add.

I have had a few customers tell me they can't add products and i think this is why!

Anyone have a fix to it?

Thank you

Jon

www.kitchenwastebin.co.uk

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...