Jump to content

moving CubeCart_inventory (only)


jerseyjoe
 Share

Recommended Posts

I have a v3 store on Server A. I have recreated the exact same store on Server B - except that B has no products and no categories and no products. I have deleted the Test Category and Test Product from B.

From A, using phpMyAdmin, I have exported the table CubeCart_inventory. In doing that I chose the option of exporting as an MS Excel CSV.

When I try to import that file into B I get an error that there is a field count error in line 1. The number of titled columns (which I am thinking is the same as "fields") appears to be the same in both the A file and the one in B. The db names are different (if that matters).

Any idea what's the cause (and cure) of the problem?

If someone who understands the issue wants access to both servers or a copy of the exported file, I can provide.

TIA

Link to comment
Share on other sites

You need to do the categories and intermediatory tables as well. Can't remember the exact table names. I'm guessing that is the problem, as the products need to know which category to display in.

Also make sure the prefix and DB name is correct in the exported file, for the import destination.

Link to comment
Share on other sites

You need to do the categories and intermediatory tables as well. Can't remember the exact table names. I'm guessing that is the problem, as the products need to know which category to display in.

Also make sure the prefix and DB name is correct in the exported file, for the import destination.

First of all, thanks for the prompt response. This is way beyond my skills. May I send a PM with the access to both versions and ask you to look at it/ if you think you can do what needs doing, I'd be happy to pay you.

BTW (isn't there always a BTW) the reason I am not trying to import the Categories is the Server A installation is corrupted. It's a mess. The main problems is there are Categories that claim to have products but do not - and therefore can't be deleted. And there are Reptitons of products even though they are assigned only one Category.

Rather than try to repair that, but while trying to avoid the need to reenter all the 320 products, it seemed to me that a fresh installation on another of my servers, would work. In recognition that the new installation would need Category IDs, and in order to eliminate copying over the corrupted Categores from the Server A, db, I striped out the CAt ID from the Server A exported of CubeCart_inventory - and replaced them with all one Cat_ID. The idea would be that the site owner would then only need go back through and re-assign the CaAts in the ACP's Products interface

Obviously - as I said - I'm incompetent to fix the problem. Please let me know if you are open to being paid to fix the problem.

Thanks again, Joe

Link to comment
Share on other sites

You could always add a default category and add a column in the data you are trying to import to category 1. It will mean having to reassign all the categories, but it sounds like you need to do that anyway.

I would also export the file as a sql database and reimport it that way. It's more reliable and the import will create any table it is missing when it does it.

Also, are the versions the same? Perhaps the extra field is one that was added from version A store to version B store, so you might want to run the database upgrade script on version a to add that field before you export the data.

Link to comment
Share on other sites

Thank you for your suggestions. But, as I said to Robsta, those are way above my MySQL skills. I think it would be fair to say that my blundering around has only made the situation worse.

I need to pay someone to fix this.

If you are interested in doing that, please PM me.

BTW - the CC versions are the same. The dbs have different names. You are right that Cats need to be assigned to the products after the file i imported and accessible and my client is ready to do that herself. But we need help to get the products file installed.

Thanks, Joe

You could always add a default category and add a column in the data you are trying to import to category 1. It will mean having to reassign all the categories, but it sounds like you need to do that anyway.

I would also export the file as a sql database and reimport it that way. It's more reliable and the import will create any table it is missing when it does it.

Also, are the versions the same? Perhaps the extra field is one that was added from version A store to version B store, so you might want to run the database upgrade script on version a to add that field before you export the data.

Link to comment
Share on other sites

Hi Joe, this sounds like the old issue which occurs when they double click on the 'add' link to add a product to an additional category. Simply remove it from the category (single click once) and problem solved.

I'm happy to take a look.... however remember this is not the third-party forum ;)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...