Jump to content

Unable to "Insert/Edit Image"


Guest PanicAttack
 Share

Recommended Posts

Guest PanicAttack

I am getting errors when I try to add an image to a product description.

I click on the "Insert/Edit Image" icon. The Image Properties window appears. If I click on "Browse Server" I get a pop-up window that says

Forbidden

You don't have permission to access /admin/includes/rte/editor/filemanager/browser/default/browser.html on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

If I click the upload tab and browse to an image, I get an alert that says "Invalid type specified". This is happening with all types of image files.

I do not have a problem adding the main product image and thumbnail, just when I try to add images to the description.

CubeCart Version: 4.3.0

PHP Version: 5.2.8

MySQL Version: 5.0.51a-community

Image upload folder size: 923.5 KB

Server Software: Apache/2.2.10 (Unix) mod_ssl/2.2.10 OpenSSL/0.9.8i DAV/2 mod_auth_passthrough/2.1 mod_bwlimited/1.4 FrontPage/5.0.2.2635

Client Browser: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.5) Gecko/2008120122 Firefox/3.0.5

Link to comment
Share on other sites

  • 2 months later...

  • 1 month later...
Guest naturalstudio
  • 1 month later...
Guest maksum

I got this resolved for myself... here is my experience posted below. Hopefully someone will find it useful

The posted fix (in this thread) didn't work with me... but I talked to cubecart support and got this response:

The issue you have can be caused for a number of reasons.

1. If you have upgraded from an older version of CubeCart you may have old JavaScript files stores in your browser cache. Please clear your browser temporary internet files and restart your browser.

2. If the issue persists try uploading the /admin/includes/rte files & folders again. It's a fairly substantial folder and problems sometimes occur if the FTP session didn't complete resulting in corrupt or missing files. The clear your browsers temporary internet files, restart the browser and see if it works.

3. If the issue still persists it may be caused by a server security module blocking some of FCKEditors files from loading. The last resport is to contact your hosting provider and ask them if either 'mod_security' or 'suhosin' can be disabled in the /admin/includes/rte folder and all folders below it.

A bug report was posted to FCKEditor concerning this which can be found here: https://dev.fckeditor.net/ticket/2875

I tried steps 1 and 2 but it didn't fix it, so I talked to my host (hostgator.) They did something which fixed it - so now I can click that image button and "browse server". When I click on the upload button and try to upload that way I still get the "Invalid Server Type" error. The hostgator support person (who was VERY helpful) thought that this was not on their end, but an error with the fck editor. Who knows where the problem actually lies, BUT the good news is that you can upload images through that same window that pops up when you click "browse server" and uploading that way seems to work just fine... so functionally speaking the problem is resolved for me.

I asked the hostgator support person what he did and this is how he tried to break it down for a less-savvy person such as myself:

The way "mod_security" works is that there is a different pattern for each way that a site can be hacked. When hackers find a new way into a site, we add a rule that matches that pattern to prevent it in the future. That rule gets an ID number. Some of the rules are overly generic and sometimes block harmless things like what you were trying to do. In this case, I just added a whitelist for your site to that rule. So when things happen on your site for that one particular rule, it won't trigger the error.

Good luck!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...