Jump to content

"View Product" function error on ver 4.3.4


Guest
 Share

Recommended Posts

I have just recently updated to CC ver 4.3.4 and is very happy with the added features.

However, has anyone face the problem that exist in the "View Product" function when the 2nd click reports and error as follow:

"Warning: main(admin/sources/products/index?_g=products/index.inc.php) [function.main]: failed to open stream: No such file or directory in /home/efabricb/public_html/admin_enc_zend.php on line 620

Fatal error: main() [function.require]: Failed opening required 'admin/sources/products/index?_g=products/index.inc.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/efabricb/public_html/admin_enc_zend.php on line 620"

I have checked if the admin_enc_zend.php file exist in my public_html directory and it did and yet the error message was reported.

To be sure I am understood correctly, the first click on "View Product" in the CC Admin panel works perfectly. The error reports only at the subsequent page click.

Can anyone confirm if the same problem is faced? And how to rectify this issue?

Any help will be appreciated. :(

Eddie

http://efabric.biz

Link to comment
Share on other sites

Guest Stellargroup

I am getting the same error when I go to 2 or 3rd page of View Products , the first page seems fine.

Warning: main(admin/sources/products/index?_g=products/index.inc.php) [function.main]: failed to open stream: No such file or directory in /home/content/p/e/t/........./html/cubecart/admin_enc_zend.php on line 620

Fatal error: main() [function.require]: Failed opening required 'admin/sources/products/index?_g=products/index.inc.php' (include_path='.:/usr/local/php5/lib/php') in /home/content/p/e/t/.........../html/cubecart/admin_enc_zend.php on line 620

Any help will be greatly appreciated

Stellargroup

Link to comment
Share on other sites

I am getting the same error when I go to 2 or 3rd page of View Products , the first page seems fine.

Warning: main(admin/sources/products/index?_g=products/index.inc.php) [function.main]: failed to open stream: No such file or directory in /home/content/p/e/t/........./html/cubecart/admin_enc_zend.php on line 620

Fatal error: main() [function.require]: Failed opening required 'admin/sources/products/index?_g=products/index.inc.php' (include_path='.:/usr/local/php5/lib/php') in /home/content/p/e/t/.........../html/cubecart/admin_enc_zend.php on line 620

Any help will be greatly appreciated

Stellargroup

Ok, we can now verify one thing. This is a common problem after the update to ver 4.3.4. If we can get more verifications from similar users, then we can inform CubeCart on this matter.

Please, post your feedback to further verify the matter.

Thanks.

Eddie

Link to comment
Share on other sites

Guest Stellargroup

I am no longer getting the error above. When I turned off "friendly urls" in General settings in Admin and updated the error did not occur.

If you say "yes" to friendly urls (SEO section) you need to install the htaccess file.

Link to comment
Share on other sites

I am no longer getting the error above. When I turned off "friendly urls" in General settings in Admin and updated the error did not occur.

If you say "yes" to friendly urls (SEO section) you need to install the htaccess file.

I did as you have suggested and it now works perfectly. Thanks for the assistance and it is really appreciated.

Link to comment
Share on other sites

Guest compusol

I am also getting the same error when trying to view 2nd or subsequent product pages.

This is a brand new installation, htaccess was enabled for friendly URL's.

Turn off the friendly URL's feature and the product pages work correctly.

Strangely enough everything was working correctly yesterday as the client added a load of new products and could access them all correctly then!

Thanks

Phil

Link to comment
Share on other sites

Guest Roger Huston

See this bug report which should fix it. http://bugs.cubecart.com/view.php?id=1596

Thank you, the fixed worked, however, for others it is a hack. The fix will only work with those who have SEF turned on, if you turn it off, things will be broken. The fix is to simply switch the comment below in functions.inc.php. Turn off the second line and turn on the first.

# $currentPage = sanitizeVar($_SERVER['PHP_SELF']);

$currentPage = ((bool)$config['sef']) ? sanitizeVar($_SERVER['REQUEST_URI']) : sanitizeVar($_SERVER['PHP_SELF']);

Perhaps the better solution would be to simply switch the IF statement on the second line. If you have SEF turned on, it will use the PHP_SELF version, if SEF is off, it will use the REQUEST_URI function which I believe is the intent.

## Get current page

# $currentPage = sanitizeVar($_SERVER['PHP_SELF']);

$currentPage = ((bool)$config['sef']) ? sanitizeVar($_SERVER['PHP_SELF']) : sanitizeVar($_SERVER['REQUEST_URI']);

This option is working for me and is perhaps a cleaner alternative than the one given in the bug.

Thank you,

Roger

Link to comment
Share on other sites

Guest Roger Huston

Roger, if you have not already done so it would be worth adding your comment to the bug report so that the developers will read it.

How do I do that? Do I have to get an account for that system? Can I add it anonymously?

Link to comment
Share on other sites

  • 3 weeks later...

I am no longer getting the error above. When I turned off "friendly urls" in General settings in Admin and updated the error did not occur.

If you say "yes" to friendly urls (SEO section) you need to install the htaccess file.

I did as you have suggested and it now works perfectly. Thanks for the assistance and it is really appreciated.

hello dear

can you tell us how you did that ?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...