Jump to content

Customer data problems after 3.0.16 to 4.3.4 upgrade


djf
 Share

Recommended Posts

Just spent a long time reading, understanding and following the upgrade process from 3.0.16 to 4.3.4 and after making many stupid mistakes I finally got it all working.

Went into my customer listings to check what my test purchase settings were and page 1 lists the customers O.K. but when i click on page 2 this appears:

Warning: main(admin/sources/customers/index?_g=customers/index.inc.php) [function.main]: failed to open stream: No such file or directory in /home/socalpet/public_html/shop2/admin_enc_zend.php on line 620

Fatal error: main() [function.require]: Failed opening required 'admin/sources/customers/index?_g=customers/index.inc.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/socalpet/public_html/shop2/admin_enc_zend.php on line 620

I can only access page 1 out of several hundred customers.

Any ideas please?

David

Link to comment
Share on other sites

Also try this bug fix for the first error http://bugs.cubecart.com/view.php?id=1596

Thanks, I'll try the bug fix but overnight I had another problem arise.

A customer placed an order through my separate Google listings and this has migrated into my shop somehow. I'm setting up v4 in a separate directory rather than using my live shop, fortunately as it happens. I exported all my data from the shop and then imported it into the v4 shop with no problems except the one mentioned above. The Google customer was definitely not in the export data but is now in the customer and order details in the v4 shop. I had Google checkout selected as alternative payment method.

Coupled with this I have received 10 new order notifications and 10 payment received emails for this order. She's ordered 1 item at $35.99 but 1 of the order details emails has the same item listed 3 times with a total invoice of $35.99

David

Link to comment
Share on other sites

Also try this bug fix for the first error http://bugs.cubecart.com/view.php?id=1596

Thanks, I'll try the bug fix but overnight I had another problem arise.

A customer placed an order through my separate Google listings and this has migrated into my shop somehow. I'm setting up v4 in a separate directory rather than using my live shop, fortunately as it happens. I exported all my data from the shop and then imported it into the v4 shop with no problems except the one mentioned above. The Google customer was definitely not in the export data but is now in the customer and order details in the v4 shop. I had Google checkout selected as alternative payment method.

Coupled with this I have received 10 new order notifications and 10 payment received emails for this order. She's ordered 1 item at $35.99 but 1 of the order details emails has the same item listed 3 times with a total invoice of $35.99

David

P.S. Just did the bug fix and that solved the pagination problem. Thanks Ausy.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...