Jump to content

can't upgrade from 3.0.17


Guest axiommod
 Share

Recommended Posts

Guest axiommod

I am using the 30-day license key.

For my v3.0.17 Ihave a commercial license with my webhost. It seems that when I try to access the main store front...I get MYsql error like the one that is shown here.

normal_error_accessing_session.jpg

It seems to be like cubeCart_sessions doesn't have the 'IP' field in te cubeCart_sessios table after I did an import of my old store's db. I tried to do the import DB after upgrading the shopping cart. I want to keep my products, catalogs , inventory, customers' data and all that from 3.0.17.

Here is what i think happend. I used the tick mark on MYPHPADMIN when exporting my old v3.0.17 cubecart database. I told it to select 'ADD/DROP' tables if exist already. I think after I run the upgrade script for cube cart 4.4.3 and then go to MYPHPADMIN in my cPanel in my webhost to do an import. It truncates vital information for v.4.4.3.

Here is what my tables look like in MYPHPADMIN for the the store I have at : http://axiom-mods.com/home/index.php.

cube_cubecart_sessions.jpg

Here is another thread about my situation at cubecartforums.org

My other thread pertaining to situaton

Thanks.

Link to comment
Share on other sites

The v4 upgrade maintains the data in the database and upgrades the tables for use with v4. You will not need to import v3 data into a v4 database, this is asking for problems.

As Ausy says, you will need to restore the database back to v3, and then run the v4 upgrade wizard on it again to upgrade the database to v4.

Link to comment
Share on other sites

Guest axiommod

well I have finally finished upgrading. This is been an ordeal I rather forget and get behind me. Thanks everyone. I still do not know what happened. I think through various config issues with the webhost or maybe file corruption. I know I did everything right. I know I won't be using AutoFTP manager anymore. It has a little X in red that makes me think stop connection. But it means to delete files without warning. I thought that if I transfered files locally from one folder to another on the webserver itself that would eliminate the problem of corruption. So , I had the webhost download the cubecart v4.4.3 archive ,and uncompress on their end. In asking them to do it, they also agreed to help me 'upgrade' the new shopping cart. That's when many factors that ultimately led to my frustration began. I had 3 or 4 shopping carts installed in parallel. All cubecart 4.4.3. I just renamed to th stores root relative directory to home_old, home_fresh, cubecart4, and home. And I probably spent 2 weeks figuring it out.

The webhost was trying to be nice and in end it messed it up more.

Thanks to everyone here and have a Happy Holidays.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...