Jump to content

USPS shipping does not appear in checkout in 5.0.9


stevemills
 Share

Recommended Posts

I can get various other shipping options to appear in checkout, but not the one I need. I only ship by USPS Priority or USPS Priority International.

I have set up my business account with USPS, I entered my username and zipcode as directly by this shipping module, but it just won't appear at checkout.

What have I missed?

Link to comment
Share on other sites

I finally have USPS up and running quite well after 2 days of struggling. I called USPS Tech Support at 1-800-344-7779 andf got my Username and password with some clear explanations. I have used USPS for mailing for years personally but this is a specific username for APIS, not the one I use for day to day shipping account..

I just enables USPS by clicking in shipping area of admin control. Check or uncheck what countries you want , I just did US and Canada, both working great. I only enabled first class and priority.priority intl. Get rid of red x's of things you want. Need weights to 2 decimal places on everything to compute rates effectively. I had no cube cart experience and just read help and played with it to figure things out.

Whenever you enable items under shipping save them and then go back to see if green checks are still green, had some problems with finding things red x ed after supposedly setting them to enable.

NW Jig Co

Make sure you have countries you will mail to active as well. I needed to add in $2.00 handling fee to cover shipping costs to various markets with insurance in most cases. Sales tax had me struggling as well but the light finally came on after making specific tax rule to cover my state situation.

Link to comment
Share on other sites

I have entered the specific username for my USPS account.

I have selected or de-selected all countries.

I enabled USPS, and the green check is on.

All my items have a shipping weight in 0.00 format, and my shipping package also has a weight.

I am in a no-sales-tax state, and have sales tax disabled.

As far as I can tell, everything is correct, yet my basket never shows shipping. I see the basket weight correctly, but that's as far as it will go.

Link to comment
Share on other sites

I have pasted in my settings with a few corrections for security. # = digits obviously.

I am running Version 5.08

allowed zones in shipping module are US and Canada.

I have used a john Doe entry with 3 addresses for testing, my own, an east coast USA, and a BC Canada address show under my log into my store as a customer. I switch addresses and the shipping swaps out to cover the new address or country.

As soon as I select a product I have it jumping to shipping cart as a default and the shipping appears as a charge.

Thats about all I can help you with, I am a novice at Cube Cart but have figured out taxes, shipping and options defaults which were giving me fits when selecting my products.

Module Settings:

Status: checked green

User: ####South####

Origin Zip 98275

Pkg Wt .1

Handling 2.00

Tax eXEMPT

pKG sIZE rEGULAR

cONTAINER : vARIABLE

sIZE 12 X 12 X 4

mACHINABLE CHECKED GREEN

CHECKED dOMESTIC 1ST CLASS

pRIORITY

PARCEL FLAT

pRIORITY iNTL (FOR MY cANADA SHIPPPING)

Link to comment
Share on other sites

That would coincide with my settings. I can't see anything I have failed to check, but it doesn't work. So far I have only used myself as a customer, so maybe I need to borrow someone from my old records and see what happens for them.

The only difference I can notice is I don't have the shopping cart on automatic.

Thank you!

Link to comment
Share on other sites

Here's something I am pondering. I just reviewed the Request Log, and for every attempt I have made to get shipping fees to show, this has been the report:

Response received

<Error> <Number>80040b1a</Number> <Description>Username exceeds maximum length.</Description> <Source>UspsCom::DoAuth</Source> </Error>

I am using exactly the username that I established with USPS (my email address) but that seems to be a bad move. Time to look deeper, but I think the cause of my problem is now obvious.

Link to comment
Share on other sites

Maybe you should just register again and get a new API username?? https://secure.shipp...m/registration/

I've learned about that from the USPS since my last post, and acquired the credentials. I do not, however, understand how to test them, or where within CubeCart to find an API that asks for them. Only the generic USPS module I described, which asks for a USPS username and a zipcode.

Can you point me in a better direction?

Thank you.

Steve

Link to comment
Share on other sites

I understand. Sounds like it's time to get help from the 3rd party forum, although that usually means paying for it

I'm still hoping for help from the ticket I opened with Devillion, but who knows.

Are you saying the USPS module you use asks for both the username and password? I can't find anything USPS in my 5.0.9 store that asks for a password.

I've added my username, and have at least seen this response from USPS:

Response received

<Error> <Number>80040b1a</Number> <Description>Authorization failure. You are not authorized to connect to this server.</Description> <Source>UspsCom::DoAuth</Source> </Error>

Link to comment
Share on other sites

No - just the username. You're probably still on the test server they use. As near as I can remember you have to use that first and then let them know you're ready for the live server. They then notify you when you're on the live one. I'm sorry it's all so hazy now.

Link to comment
Share on other sites

No - just the username. You're probably still on the test server they use. As near as I can remember you have to use that first and then let them know you're ready for the live server. They then notify you when you're on the live one. I'm sorry it's all so hazy now.

I think that's what will happen. I sent an email to their tech people with a quote from that server call, hoping that will satisfy the "test" and they will make me live. I'm really disappointed with the documentation surrounding CC5, but I certainly appreciate the improvements they have made in the past 2-3 years.

Link to comment
Share on other sites

I was traveling yesterday and couldn't get back to you.

I am afraid you are over engineering this a bit.

I showed you the exact format my user name came from USPS after talking with them.

4 digits, 4 Letters and then the 2nd group of digits

Had no connection to my e-mai or USPS shipping account username which is totally different than this user name was.. When calling they find me in their system with my e-mail and phone number but they issued me a separate user code for the e-commerce which does not have a password that I am aware of. I never entered a password into Cubecart.

I also was glazing over the USPS tutorials you were, they told me I didnt need to do any of that, those procedures are meant more for developers of shipping gateways................. I did not do any testing, etc.

my second call to USPS tech said I should be fine without testing and getting response back from them etc.

All I can say that I was functioning at that point with US Domestic priority and 1 st class, additionally I can ship to Canada with first class and intl priority. My John Doe account at my store has 3 different addresses so I can verify different zip codes change rates and I also have a BC Canada linked to J Doe so I can see rates put out for INtl Priority by just selecting different shipping addresses on my site as the same customer account.

Now setting up FEDEX has proven to be another matter, they want user account and meter # in Cubecart, Fedex says they don't use meter # after this month. I am getting nothing there.

Link to comment
Share on other sites

I was traveling yesterday and couldn't get back to you.

I am afraid you are over engineering this a bit.

I showed you the exact format my user name came from USPS after talking with them.

4 digits, 4 Letters and then the 2nd group of digits

Had no connection to my e-mai or USPS shipping account username which is totally different than this user name was.. When calling they find me in their system with my e-mail and phone number but they issued me a separate user code for the e-commerce which does not have a password that I am aware of. I never entered a password into Cubecart.

I also was glazing over the USPS tutorials you were, they told me I didnt need to do any of that, those procedures are meant more for developers of shipping gateways................. I did not do any testing, etc.

my second call to USPS tech said I should be fine without testing and getting response back from them etc.

All I can say that I was functioning at that point with US Domestic priority and 1 st class, additionally I can ship to Canada with first class and intl priority. My John Doe account at my store has 3 different addresses so I can verify different zip codes change rates and I also have a BC Canada linked to J Doe so I can see rates put out for INtl Priority by just selecting different shipping addresses on my site as the same customer account.

Now setting up FEDEX has proven to be another matter, they want user account and meter # in Cubecart, Fedex says they don't use meter # after this month. I am getting nothing there.

I was, yes. Way over. :) The way I was using my email address had to do with another tool they can set you up with, but one I do not need. I have that format for a username now, and expect by tomorrow they will make me live. In the mean time I have a lot of products to add to my store. All looks good for now. Thanks for all your help!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...