Jump to content

Resolved - CC5.1 Maintenance - Rebuild Sitemap: Failed


SimChris
 Share

Recommended Posts

Hi folks...

had the CC staff do upgrade to 5.1 from 4x over past couple of days, and have been going through and trying to ensure we're back and working with the payment gateways, emails, etc. ...

Ran into one problem, when I go to CC maintenance > database > rebuild sitemap

I get the red error "Failed to Rebuild Sitemap" message.

Where is the directive to build sitemap first time, or does there need to be empty 777 sitemap.xml file added to the store root ?

Before I start messing with the skins or anything else wanted to make sure all the "base" stuff is back in place and working correctly since this is a production site.

Any pointers or suggestions would be helpful before I put in a support ticket or check the bug dbase. :-)

Link to comment
Share on other sites

Who are you trying to submit the sitemap to? Google accepts the sitemap.xml.gzp file.

SimChris - I just rebuilt mine without a problem - you don't have to do anything to get it to work normally. Since CC staff did the upgrade for you this should be supported by them. Please contact with the error message and any other problems you're having.

Link to comment
Share on other sites

  • 2 weeks later...

Hi

as expected, due to my Linux RHES server, having the /store/ folder permissions at 755 and not 777, required me to upload a blank unix/utf8 file with the filename: sitemap.xml.gz, then set that as 777.

My server error log correctly identified the stream error, not having permission to write the file to

/store/sitemap.xml.gz

So, problem solved. Not first time I've had to do this in 17 years of web stuff with cgi scripts, shtml, and now php.

Anybody else having this problem, you just need to make a blank file and CHMOD it 777; then it works first time. :-)

(doh.)

Not sure how to mark this "resolved" .. but it's done so.

ALSO: fyi, dirtybutt' - I did put in support ticket, but the CC support crew's initial response was not enough memory; and I have the available memory set for php to 128MB. Since I have a WP site with 6500 pages that only takes 32MB and about 8 seconds to do sitemap, I was pretty sure our services portal with less than 100 items, and less than 20 categories, wasn't going to need 256MB to build a pesky sitemap. Today was first chance i had to go and actually double check the error logs.

NOW: to sort out why clients can't reset their passwords! (sigh)....

looks like if you try to login couple of times with wrong info, then have it send you a new password link,

when you actually go to change your password with the key populated from email, it says you can't do so,

apparently while being locked out from trying to login with wrong password ... (double DOH!!!!)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...