Jump to content

Resolved - Setup issue Cubecart 5.1.1


Guest rmblnron
 Share

Recommended Posts

Guest rmblnron

I'm trying to do a fresh install of 5.1.1. I get the following warning and the install will not continue.

Warning
: session_start() [
]: open(/var/php_sessions/sess_549c55bc38a1fa8fad0928c67bc401eb, O_RDWR) failed: No such file or directory (2) in
/hermes/waloraweb068/b2705/hy.rmblnron/catalog/setup/index.php
on line
18

Also, compatibility checks for PHP, mySQL 4.1+, GD Image Library and cURL are green with the following error.

Either Ioncube Loader or Zend Optimizer is required to use CubeCart 5. This can be configured after setup is complete.

Any suggestions?

Link to comment
Share on other sites

  • 2 months later...

Hi having the same issue.

zend optimizer installed but not detected

Have had the optimizer installed by 1and1 internet support and the path they input in the php.ini file at the server root is

zend_optimizer.optimization_level=15

zend_extension=/kunden/homepages/30/d242004205/htdocs/Zend2/ZendOptimizer-3.3.9-linux-glibc23-i386/data/5_2_x_comp/ZendOptimizer.so

this is correct and phpinfo says the optimiser is installed.(see attached)

The php.ini file in the folder where CC v5 is extracted (store) has

zend_optimizer.optimization_level=15

zend_extension=/kunden/homepages/30/d242004205/htdocs/Zend2/ZendOptimizer-3.3.9-linux-glibc23-i386/data/5_2_x_comp/ZendOptimizer.so

allow_fopen_url=off

#disable_functions = show_source, system, shell_exec, passthru, exec, phpinfo, popen, proc_open

memory_limit=16M

safe_mode = 0

register_globals = 0

 

 

 

The set up gives the warning Either Ioncube Loader or Zend Optimizer is required to use CubeCart 5. This can be configured after setup is complete.

allows me to enter database info etc but when clicking continue after that info I get a blank screen and a server 500 error in the page tab?

If I try to goto the store folder which should have the front end I get this error

Site error: the file /homepages/30/d242004205/htdocs/homepages/themixbromleycouk2009/store/index_enc_ion.php requires the ionCube PHP Loader ioncube_loader_lin_5.2.so to be installed by the site administrator.

I don't know what to do now as nothing seems to work.

I have installed CC v4 with Zend Optimser on another server without any similar issues, but that server has no more sql db's available.

Hope someone can advise.

Thanks

Peter

I have attached the phpinfo read out.

phpinfo().htm

Link to comment
Share on other sites

If CC is looking for ionCube, and using index_enc_ion.php, then the installer defaulted to be using ionCube instead of Zend. Here is what you need to do:

In the file /includes.global.inc.php, change $glob['encoder'] = 'ioncube'; to $glob['encoder'] = 'zend';

You have this in the phpinfo:

Zend Engine v2.2.0, Copyright © 1998-2010 Zend Technologies

with Zend Optimizer v3.3.9

And that is the correct version for PHP 5.2.x and earlier.

I have determined there is a bug in the detection process.

Link to comment
Share on other sites

Hi Thanks did that now get

Parse error: syntax error, unexpected T_VARIABLE in /homepages/30/d242004205/htdocs/homepages/themixbromleycouk2009/store/includes/global.inc.php on line 10

at http://www.themixbromley.co.uk/store/

Still have zend not installed when at http://www.themixbromley.co.uk/store/setup/

The following errors were detected:

  • Either Ioncube Loader or Zend Optimizer is required to use CubeCart 5. This can be configured after setup is complete.

Link to comment
Share on other sites

To fix the false negative on finding Zend, open the file /includes/functions.inc.php at around line 511, find:

if (preg_match('#Zend Optimizer(+?) v(d.d(.d)?)#i', str_replace(' ', ' ', $info), $matched)) {

return $matched[1];

}

Change the return $matched[1]; to return $matched[2];

Make sure line 9 of global.inc.php has a trailing semi-colon:

$glob['encoder'] = 'zend';

Link to comment
Share on other sites

did that had missed the closing ;

now have

Site error: the file /homepages/30/d242004205/htdocs/homepages/themixbromleycouk2009/store/index_enc_ion.php requires the ionCube PHP Loader ioncube_loader_lin_5.2.so to be installed by the site administrator

I dont know why ionCube is still being referenced when Zend is installed?

Also tried set up again still shows Zend not installed and after entering db info get the HTTP 500 Internal Server Error.

I'm thinking the CC install may be corrupt?

Link to comment
Share on other sites

Let's be clear about something: I am discussing Cubecart 5.1.4. Please verify you are running CC514.

Changing $match[1] to $match[2] in the function file should now resolve to true if "Zend Optimizer" is showing in the General Info block (which according to your attachment, it is.) I'll look further along if this still gives a false negative.

But manually changing this line to $glob['encoder'] = 'zend'; should allow CC to show the storefront normally using the index_php5.2_enc_zend.php file and not the index_enc_ion.php file.

Link to comment
Share on other sites

Thanks.

Yes I am using CC 5.1.4 downloaded today,

So still get

Either Ioncube Loader or Zend Optimizer is required to use CubeCart 5. This can be configured after setup is complete. at start of setup.

Get Site error: the file /homepages/30/d242004205/htdocs/homepages/themixbromleycouk2009/store/index_enc_ion.php requires the ionCube PHP Loader ioncube_loader_lin_5.2.so to be installed by the site administrator.

at http://www.themixbromley.co.uk/store/

As the install is not complete then the storefront wont show will it?

The mysql db is inpopulated due to set up not completeing? However global.inc.php has the db info in it?

Link to comment
Share on other sites

I noticed that your PHP installation is running under CGI/FastCGI. Please contact your hosting provider to ask if they installed some sort of script caching mechanism.

If the installation succeeded once, then the /includes/global.inc.php file should exist and its contents should have at least these variables (there will be more than just these):

$glob['dbdatabase'] = 'cubecart'; // Your database name may be something else

$glob['dbhost'] = 'localhost';// Your database host may be something else

$glob['encoder'] = 'zend'; // Manually changed to 'zend', and make sure it stays that way!

$glob['installed'] = '1';

Link to comment
Share on other sites

I do have the variables as shown with others.

I will contact 1and1 internet support tomorrow to see if they can advise. They did say however they cant advise on Cubecart itself.

The install has not suceeded on this server at all.

I have CC v4 on another server which is a shared server where I have not got access to server settings I can change.

I tried switcjing of CGI/FastCGI but it had no effect on the errors nor the setup still saying zend is not installed?

These are the default setting on the problem server.

WebDav : active FastCGI : inactive SSL support : active Perl as Apache module : CGI-Programm PHP module : CGI-Programm Memory usage : 131072 kB Process timeout : 60 seconds Maximum simultaneous processes : 100

Will update if I get any advice from 1and1.

Link to comment
Share on other sites

I managed to install on my other server using similar set up and changing global.inc.php to zend on 9. Having tried again on the problem server even though phpinfo shows zend is installed the setup script insists its not? Setup does not complete. Tried with a fresh download of CC v5. So not sure. The only difference between the 2 installs is that the problem server has a Joomla site as the domain and the "store" folder is installed within the folder structure of that domain. I would not have thought that should cause the problems?

Still need to contact 1and1,

Link to comment
Share on other sites

Have spent some more time on this. 1and1 cant advise further as they dont support CC.

Summary of where I am now.

The zend optimizer is shown to be installed when I run phpinfo which is inside the "store" folder where CC files are located. I have also installed the 5.2 version of Zend Optimizer ".so" file inside the store folder as well as the php.ini.php file which has the path to the zend optimezer inside the store folder. This path is also confirmed by php info. (this is the same set up I used sucessfully on my other shared server - the path in php.ini is of course different for each server)

The main issue is therfore that the CC set up insists Zend Optimizer is not installed when it is? It also crashes with the 500 server error as stated before.

Is anyone from CC aware of any issue with CC v5 running on a managed server (1&1 Server 2012 L 4 Core i Managed) as oposed to a virtual pro shared server with 1and1 where I have been able to install CC5 from the same downloaded file set. The only change was again I had to change includes/global.inc.php, change $glob['encoder'] = 'ioncube'; to $glob['encoder'] = 'zend';

to get it to install without any errors.

This is proving to be a pain?????

Anyone have a solution please?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...