Jump to content

Deleteing images/folders and rebuild sitemap errors


Guest johnnytv
 Share

Recommended Posts

Guest johnnytv

I was running version 5.0.7 and was having issues deleting images or folders through the file manager (just an error: Failed to delete file.showed up) and also under maintenance the sitemap rebuild always brings up an error too.

I've updated to the most recent version this morning and still have this issue.Can anyone help point out something I can try to fix it?

My site is also running very slowly compared to before the upgrade, the admin area especially. It's on my reseller account with no speed issues with any other sites so it doesn't appear to be down to the hosting.

Any help would be much appreciated.

Link to comment
Share on other sites

Hi,I thought I posted solution to sitemap rebuild error elsewhere in forum this month from my own 4x to 5.1.1 upgrade.

If you get error trying to rebuild sitemap, and never had a sitemap to begin with, it means the folder with your store doesn't have high enough write permissions to create new files (this is common with many apps in public root of a website/domain also).

The simple fix, is to either increase write permissions on the store folder if not already 750 or as noted in the docs; -or- what I did instead was create blank unix text file (I use TextPad on Win7, or BBEdit on Mac), called sitemap.xml and upload to my store root folder (e.g., /ecom/ or /store/) and CHMOD the file to 777; then rebuilt sitemap, and worked first time.

Problem is store doesn't provide blank empty file to write to, and directory permission on Linux servers defaults to 750 I believe so can't create a blank file there to built map first time.

If having problems with image folders, you may need to check the permissions on the image folders to change them to 777 also, or as per your particular server environment.

At least these helped my situation; your mileage may vary :-)

Link to comment
Share on other sites

Guest johnnytv

Thought I'd just add to this, I couldn't get things sorted (thanks for the pointers re the sitemap but it still wouldn't work for me) so opened a support ticket and it was sorted very quickly, I'd recommend using them if going round in circles!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...