Jump to content

Resolved - Re Order won't work


Guest cybahous
 Share

Recommended Posts

Guest cybahous

I'm new, I know, but I don't seem to be able to get the reorder function to work whilst I'm building my store. I came across the problem first when I was creating Categories, then Products and now in Site Documents. I can delete the items and create them again in a different order, but the function 'drag to reorder' isn't working and if I delete products and start again, I get my IDs messed up because my new product starts from where i left off.

If someone could answer the reorder problem that would help.

Ta Stew

Link to comment
Share on other sites

Welcome cybahous! Glad to see you made it to the forums.

In CC5.1.3 (if I recall correctly), there was an issue with the javascript-powered auto-submitting of drop-selectors. That issue was worked around with CC514. I do not recall any issues with the javascript-powered drag-n-drop functionality, however.

So, just to be sure, the drag-n-drop feature of a list that can be ordered is accomplished by click-dragging the up-down arrow symbol. The mouse cursor should change to a four-headed arrow when hovering over the sort symbol. When the cursor is that symbol, click and hold while dragging the row and dropping it between the two rows where you want it. The capability even allows for dragging the only row in a one-row list. So you can be sure the capability is functioning without having to make another category or document.

Please reply that understand what to observe and how to make the move, and whether that worked for you or not.

Link to comment
Share on other sites

Guest cybahous

Hi, thanks for the prompt reply.

On mouse hover the 4 arrows appear and when I click and move the mouse up or down, the product/category doesn't move, but the highlight does.

So, in reply, I hover over the product that wants to be moved, the mouse changes to 4 arrows, I click and drag, it doesn't move, but the highlight does. I've also tried it using Chrome just in case it was explorer, but no joy.

Stew

Link to comment
Share on other sites

Guest cybahous

Hi, the CC version is 5.1.5, but I don't know where to look for the jQuery question.

Tried it again this morning in ie9 and the drag and drop doesn't work. I logged out and opened up Chrome, tried the drag and drop, it worked. Odd one I know.

Stew

Link to comment
Share on other sites

Odd that javascript programs are hit-n-miss with Internet Explorer? No, not so odd.

If you can find a friend's computer with Firefox, Opera, or IE-not-9, try the drag-n-drop with that. If the code is not malfunctioning, it should work for you in Firefox, as that is what I used to verify and give you instruction above, and I know it works.

Link to comment
Share on other sites

Guest cybahous

Thanks for your help. Store coming along nicely now and I've been using Chrome if I need any drag and drop. We don't use Firefox here, but it might be an idea to install it.

Regards

Stewart

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...