Jump to content

Payment gateway in ver 5 seems to freeze


peterp
 Share

Recommended Posts

Hi all,

I have created an order as a customer and proceed thru the processes where it has to be paid for, I have 2 selections one is paypal and the other is supposed to be direct deposit. However when I select Print_order_Form it seems to do nothing, if I go to the admin screen and slect the appropriate pending order then I am able print it but unfortunately there are no banking details the gateway just print Print_Order_Form obviously useless to the customer who wants to deposit maney for goods into our bank.

Any suggestions as to how to get the invoice/order printed at the customers end and also how to display/print the necessary banking details

Much appreciated

Link to comment
Share on other sites

Works fine on the store I'm testing at the moment so it's not a bug with the actual package. 

 

Have you tried enabling debug under Store Settings/Advanced to see what it's trying to do when the screen is blank?

 

Also make sure that you've enabled the banking section of the form. It has to be enabled in addition to the form itself.

Link to comment
Share on other sites

Thanks Kraken,

                       Enabling debug settings didn't help me as I have no idea what I'm looking for everything seems to be OK. When I said the check out payment selection freezes I ment that when I check 'Print_order_form' the program doesn't print anything. This is when I'm a customer who is going to pay via direct deposit, also there is no email sent to my email address that has been setup in admin screens. When I log on as administrator I can see the pending order and I can print it however there are no banking details printed.

So I have come to the conclusion that I have missed some very important setup steps.

I am using the v5 lite on a local host setup i am not conected to any remote server yet.

Any help would be appreciated.

Link to comment
Share on other sites

"when I check 'Print_order_form' the program doesn't print anything"

 

When you choose Postal Order Form (POF, or whatever name you gave the module in its control panel), then click the Continue button, CubeCart should then send a page to the browser that includes a Close and a Print button for the customer to print that web page.

 

If this does not happen, that is, based on what you say, clicking the Continue button does not bring a new web page (hopefully the Direct Deposit page, as you describe it), then we can look for what is going wrong. (For the moment, make sure Allowed and Disallowed Zones are blank.)

 

In Store Settings, Features tab, Misc group, CubeCart will send an email to the admin(s) on an order going to either Pending or Processing -- except perhaps when using the POF. (And the customer won't get one either since the customer has a printout in their hand).

Link to comment
Share on other sites

Hi bsmither,

The processess that I have gone thru are create an order as a test customer who isn't a registered customer all of the fields are filled in during the order process the checkout button is pressed and then the screen is refreshed wait to check the feight at which case all is well so the checkout button pressed again at which time I get to choose either paypal or print_order_form (print_order_form) is listed twice, I select one of the print_order_form Buttons and then thew screen is refreshed but this time what get is the choose payment screen again but only showing the two print_order_form buttons and a continue button, pressing the continue button seems to do nothing.

Hope this helps with what steps I have taken. The result I expect is as a customer who is going to pay via a bank transfer would get a printed order/invoice showing the details of their order and also the banking details of our site which we have setup in the admin screen

Thanks for any help

Link to comment
Share on other sites

"I get to choose either paypal or print_order_form (print_order_form is listed twice), I select one of the print_order_form Buttons and then thew screen is refreshed but this time what get is the choose payment screen again but only showing the two print_order_form buttons and a continue button."

 

Hmm... Having Print Order Form being listed twice in the list of gateways during checkout is a bad thing.

 

If you have a utility like phpMyAdmin to view the database directly, please let us know what you see regarding this:

CubeCart_modules -- 'folder' column -- Do you see more than one Print_Order_Form record?

CubeCart_config -- 'name' column -- Do you see more than one Print_Order_Form record?

 

If yes to either, delete the duplicate records leaving only one Print_Order_Form record in each of the tables.

 

If no, we will look some more.

Link to comment
Share on other sites

Hi bsmither,
                That was the answer when I removed one of the print_order_form from the database it all worked, however when I try and print the same order in the admin section the printout is not the same as the one that is printed out for the customer or maybe it shouldn't be. If I want to customise this will I have to do it thru the print.css or can I do it through the html thats if I can find the html any clues?

Link to comment
Share on other sites

"print the same order in the admin section the printout is not the same as the one that is printed out for the customer or maybe it shouldn't be."

 

The customer gets an opportunity to print a 'receipt' from their customer account screens. The Print Order Form serves a specific purpose. The admin prints a 'shipping manifest' also known as a 'packing list'.

 

You say you want to change what the admin's packing list shows?

/admin/skins/default/templates/orders.print.php

Link to comment
Share on other sites

Hi Bsmither,

                  Thanks for your help with these queries, don't so much wish to change the packing slip but I want to rearrange the billing and delivery addresses to be separated as at this point they don't seem to be separated, its as though they are printed on top of each other.

Link to comment
Share on other sites

Hi Bsmither,

                 Unfortunately I cannot give you a web address at the moment we are running on a localhost type server as we are in evaluation mode which I might add is looking pretty good. How can I attach a pdf document that will show you what I'm talking about

Link to comment
Share on other sites

As I said, I don't need your domain name. I want everything after the domain name.

 

I want the page you are viewing that you want to change. Something like:

index.php?_g=rm&type=gateway&cmd=call&module=Print_Order_Form&cart_order_id=130328-001407-6601

index.php?_a=vieworder&cart_order_id=130226-093409-4402

admin.php?_g=customers&action=edit&customer_id=1#general

admin.php?_g=orders&node=index&print[]=130201-205931-1807

files/print.{32_character_hash}.php

 

It is difficult to attach things to posts in these forums. Others use the services of free filesharing sites.

 

You can help me to know what page you have an interest in editing by giving me the stuff you see in the web browser's address bar -- even if you include 'localhost' as the domain, I am not interested in that part and I will ignore it. I can have my copy of the CubeCart code show me what it is you are wanting to edit.

Link to comment
Share on other sites

"If I go to the admin screen and select an order to view from the list of Orders, I want to print that which the Print_Order_Form gateway presented to the customer to print."

 

Is this the essence of what you want?

 

If an order used the POF gateway, you wish to have the ability to get a hard-copy of what the POF originally gave the customer to print and mail in?

Link to comment
Share on other sites

Hi bsmither,

                 Yes that is exactly what I trying to achieve, also below is the the web address That is being used to print the order

http://localhost/tulanesclosetxara/shop/files/print.01dfef9999dded6a9747a8ff94d91881.php

 

Hope this helpful and thankyou again



Hi Bsmither

localhost/tulanesclosetxara/shop/files/print.01dfef9999dded6a9747a8ff94d91881.php this is the address that the system is using to print the order

Link to comment
Share on other sites

Hi Bsmither,

                 Thanks for the help, I have taken a look at details in the attached address and this looks like what I'm trying to achieve, however when my packing list/shipping manifest is printed it seems to have printed the Delivery address incorrectly. What seems to be happening is that company name of the delivery address is printed then followed by the persons name, the nextline is the company name of the delivery address is printed again and then it seems to be printing the rest of the address correctly. also whereas I was get the company logo printed it seems to have stopped for some reason both at the payment screen and the customers invoice screen and printout.

In the mean time I will try your earlier suggestion and let you know, thanks again

Link to comment
Share on other sites

"What seems to be happening is that company name of the delivery address is printed then followed by the persons name, the next line is the company name of the delivery address is printed again and then it seems to be printing the rest of the address correctly."

 

For that customer, view the customer details and verify if the customer put their company name on address line 1, followed by their actual address on address line 2.

Link to comment
Share on other sites

Hi bsmithers,

When I view the customer record in the admin page the correct customer details are entered in the right places, however what I have noticed is that there are two red crosses at the bottom of the page under the save button that do not have any description as to what they are for or do, if you click on them they do change to a green tick however don't know what they are for.

What I did do is tried the suggestion from the previous link you provided and found this to be useful in the future but In the file /admin/skins/default/templates/orders.print.php where the details are being printed there is no break(<br />) between company name and customer name when I put one in I at least get the company name and customer name on separate lines.

Let me know whether this is OK to do

Link to comment
Share on other sites

"I have noticed that there are two red crosses at the bottom of the page under the save button."

 

So this must be the Edit Address on the Edit Customer Addresses tab. The bottom two check marks should have legends of: Billing Address and Default.

 

If you look at the code in the file adminskinsdefaulttemplatescustomers.index.php, near lines 155 and 156, you should see:

<div><label for="billing">{$LANG.address.billing_address}</label><span>.....
<div><label for="default">{$LANG.common.default}</label><span>.....

The variables {$LANG.address.billing_address} and {$LANG.common.default} get replaced by Billing Address and Default respectively.

 

As you say, there are no legends. Be sure they are actually not in the HTML sent to the browser. Use the browser's View Source to verify that. If the HTML actually looks like: <div><label for="billing"></label> (that is, nothing between the <label> tags), then you have a problem with the language file you are using. What language is your admin screens using?

 

Also, at the end of those two statements, you may as well put in the missing closing span tags:

.....class="toggle" /></span></div>


 

Link to comment
Share on other sites

hi BSmithers,

I have had a look at the admin.php?_g=customers and found that the code that you suggest should be there is there however the input type is set to "hidden" I think that this maybe the problem, what do you think.

Link to comment
Share on other sites

The inputs are "hidden" because we actually want to see and use the green-check/red-x indicator that is tied to the input element via javascript instead of the actual checkbox.

 

But do you see the words Billing Address and Default I asked about?

Link to comment
Share on other sites

So the words are in the HTML as revealed in the browser's View Source. That means the words are white on a white background. Or are actually hidden by some means (not the input tag).

 

Please find and install Firefox and the Firebug add-on. We will use it to look deeply at the area where these words should be.

Link to comment
Share on other sites

Start Firebug and then go to the admin page where the words are missing. In Firebug, be sure to be on the HTML tab. On that menu bar, click once on the tool icon that looks like a rectangle with the tip of a blue mouse cursor in it.

 

Then hover your mouse cursor over where the words should be showing to the left of the red-x or green-checkmark. There will be a blue-ghost outline where the words should be. Then click inside the blue-ghost outline.

 

In Firebug, the HTML will be highlighted. You should see the label tag and the words Billing Address (or Default). In the right-hand pane, you will see the CSS.

 

Please determine if any CSS has colored the words white. Please determine if anything is out of the ordinary.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...