Jump to content

CubeCart 4 to CubeCart 5


Recommended Posts

I am trying upgrade form cubecart 4 to cubecart 5 keep having problems with it all

 

my host has told me to do the following 

 

Note that Zend Optimizer is used for PHP 5.2, and it's replaced by Zend 
Guard in PHP 5.3.

We have PHP 5.3 with Zend Guard Loader v3.3. You can enable Zend Guard 
for your account by adding this line to your global php.ini file:
zend_extension = /usr/local/Zend/ZendGuardLoader.so

 

as on my host the ioncube PHP loader v4.4.0

 

any input on the matter

Link to comment
Share on other sites

i got this message and stops at 60%

 

zend_extension = /usr/local/ioncube/ioncube.so

zend_extension = /usr/local/Zend/ZendGuardLoader.so

register_globals = Off

magic_quotes_gpc = Off

post_max_size = 20M

memory_limit = 200M

upload_max_filesize = 20M

max_execution_time = 120

expose_php = Off

session.save_path = /tmp

mysqli.default_socket = /tmp/mysql5.sock

mysql.default_socket = /tmp/mysql5.sock

error_reporting = E_ALL & ~E_NOTICE & ~E_DEPRECATED

Link to comment
Share on other sites

"We have PHP 5.3 with Zend Guard Loader v3.3. You can enable Zend Guard for your account by adding this line to your global php.ini file:
zend_extension = /usr/local/Zend/ZendGuardLoader.so"

 

"From the phpinfo read out

...with Zend Guard Loader v3.3"

 

====

zend_extension = /usr/local/ioncube/ioncube.so

zend_extension = /usr/local/Zend/ZendGuardLoader.so

register_globals = Off

magic_quotes_gpc = Off

etc.

====

 

My feeling is that when you were instructed to add a line to your global php.ini file, maybe you edited the wrong file.

 

The "...with Zend Guard Loader" phrase means this is installed. But there is a zend_extension for ioncube. But there is no "... with ionCube 4.4" phrase that would be there if ionCube was loaded.

 

Please download to your computer the CC524 package (link is at www.cubecart.com) and unzip it. Then, compare the following files from the package with the files that are on your server:

/ini.inc.php

/includes/global.inc.php

Link to comment
Share on other sites

Hi,

 

The upgrade process should work to completion regardless if zend or ioncube is working or not. After successful upgrade (or install) it will soon tell you if it's not working. Enabling zend or ioncube after upgrade or install is just fine.

 

If the upgrade fails then there is another problem. From experience I expect that the upgrade ran out of memory or times out. This can happen if you have a significantly sized inventory. We have experienced this a number of times when upgrading stores for our clients. 

 

Normally its not possible to increase the resources available in a budget or shared hosting account so in these circumstances we copy the store to a local development environment then rack up the memory limit and time out as high as we can. The upgrade then normally works and we then transfer this back up to the production server. 

 

If you are still having problems and require assistance please post back here or you could order our upgrade service if you would like us to do this. The cost covers an hour of our time but we will get it done regardless of how long it takes. I have known some to take 12 hours or more but we won't let you down. 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...