Jump to content

Blank screen on admin after install...


spink
 Share

Recommended Posts

I installed cubecart through Mojo directly to my hosting account.  So, it setup everything including the database.  However, after the install I got nothing but a blank screen when trying to access the admin area (http://www.seriouslypink.co/store/admin.php).

 

All yesterday I tried reading through the forum threads to see if I could find the fix, but to no avail.

 

------------------------

I tried renaming and then subsequently, deleting the cubecart setup folder, but still no access to the admin.

 

-----------------------

I tried changing the /includes/global.inc.php encoder code to state 'zend' instead of 'ioncube', because that's what I original thought I had, but it created an error (see below). 

 

Fatal error

: Incompatible file format: The encoded file has format major ID 4, whereas the Loader expects 5 in /home4/seriout2/public_html/store/admin_php5.3_enc_zend.php on line 0

 

------------------------

So, after the error I installed ioncube instead and changed the /includes/global.inc.php back to 'ioncube' for the encorder.  Here is the phpinfo:

 

This program makes use of the Zend Scripting Language Engine:
Zend Engine v2.2.0, Copyright © 1998-2010 Zend Technologies
with the ionCube PHP Loader v4.4.4, Copyright © 2002-2013, by ionCube Ltd., and
with Zend Optimizer v3.3.9, Copyright © 1998-2009, by Zend Technologies

 

Can anyone assist with helping locate the problem?

 

Thanks so much!

 

Link to comment
Share on other sites

/store/admin_php5.3_enc_zend.php is being called because it seems your version of PHP is at 5.3.

 

The encoded file has format major ID 4, whereas the Loader expects 5.

Zend Optimizer v3.3.9 (Runtime for PHP 5.2 and earlier)

 

You may need to install v5.5.0.

 

But the ionCube loader should have worked.

Link to comment
Share on other sites

(I am not a tech person, but I can figure some things out with instructions.)

 

Thanks for your quick response.  It is appreciated :)


I just found the PHP config under my cpanel.  However, it only offers up to:

 

PHP 5.4 (FastCGI)
All files with the extension .php will be handled by PHP 5.4 FastCGI processes.

FastCGI for PHP makes all your PHP applications run through mod_fastcgi instead of mod_suphp. This eliminates the overhead of loading the PHP interpreter on every hit. Since it is always in memory ready for the next hit, the responses will be generated faster.

 

Could this possibly solve the problem?  Or do I specifically need 5.5?

Link to comment
Share on other sites

Yeah, I was hoping the ionCube loader would have solved the problem as well.  I even crossed my fingers really hard, but all I got was a white screen.  This is how the line reads now:  ;$glob['encoder'] = 'ioncube';

 

Oops, I changed the PHP version to 5.4, but prior to my change it was PHP 5.2 (Single php.ini).

 

I will change it back and see if I can find a way to upgrade to get Zend Optimizer v5.5.0.

 

Can you think of anything else that might be the issue?

Link to comment
Share on other sites

  • 2 months later...

I am using PHP 5.4.2 and getting a blank screen for admin and store, is this the problem?

 

I checked all your other posts index.php and more and all seems well.

 

www.vickiechristensen.co/public_html/phpinfo.php

 

 

 

After install of CubeCart and IonLoader
1. www.vickiechristensen.co/phpinfo.php shows that ionloader is installed
This program makes use of the Zend Scripting Language Engine:
Zend Engine v2.4.0, Copyright © 1998-2013 Zend Technologies
    with the ionCube PHP Loader v4.5.2, Copyright © 2002-2014, by ionCube Ltd.
 
CubeCart - Compatibility Check
 
5.4.24 PHP 5.2.3+
5.1.73 MySQL 4.1+
Installed GD Image Library
Installed cURL
Installed IonCube PHP Loader or Zend Optimizer
Optional Features
 
Not Installed APC
Installed bz2
Installed EXIF
Installed FileInfo
Installed Hash
Installed mCrypt
Not Installed memcache
Installed mysqli
Not Installed XCache
Not Installed XDebug
Installed ZIP
2. www.vickiechristensen.co/public_html/setup shows that CubeCart is ready for Administration
Installation Complete
 
Your store has been successfully installed. You should log in your Admin Control Panel, and configure your store, and add products.
Admin Control Panel
Store Front
 
3. Upon selecting Admin Control Panel or Store Front my browser renders blank
 
4. Purchased CubeCart reinstalled with Key - the screen renders blank upon selecting Admin Control Panel or Store Front
 Invoice/Receipt #87298
 
I would so appreciate your help.
Link to comment
Share on other sites

Welcome Vickie! Glad to see you made it to the forums.

 

Currently, CubeCart offers encoded files built for PHP5.4 and ionCube versions 4.4, 4.0, and 3.1.

 

The question is, does the ionCube loader version 4.5 work with files encoded for ionCube version 4.4?

 

Unless something else is wrong, evidence suggests there is this incompatibility.

 

Devellion should be along shortly.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...