Jump to content

php 5.2 - 5.4 (to use ioncube).


Nik Grey
 Share

Recommended Posts

Any idea where to look for and change the Character set ?

 

I have been trying to figure out the differences between the working version of the 'Lettering Tool' taken from my Live site and the no longer working (no more fonts displaying - that old chestnut) with Beyond Compare.

 

I was hoping to see the changes Jonathan made but this is a nightmare of the very highest order. I will persist until I get there - the thoughts of just giving up fade after a nights sleep.

Link to comment
Share on other sites

ok, the file you sent has an obvious block of extra text which must be the conversion - that makes sense, I can see that.

 

But the original genimage.php's from both the working site and the test store are the same and DONT have that extra text so how on earth is the Live store working (characters appearing as expected)?

 

(BTW the file is in: modules/external/lettering/ajax).

 

I tried replacing the file you sent with that on the test store and clearing the browser cache and the admin cache but it still doesnt work :(

 

This is where the frustration comes in, why does One site work and the other doesnt with both having the same genimage.php file without that extra conversion text ?

 

At least with Jonathans new file I can see a difference, which gave me a fleeting flash of happiness :)

Link to comment
Share on other sites

That new file works on the Live store, I'm just downgrading the test store to 5.2.5 again to see what happens.

 

I wonder if this problem is because there is no Zend support in the later versions ? I wonder if it would just be a case of changing something from Zend to Ioncube somewhere in my Lettering Tool package?

 

I just found another instance of that conversion ($HTML401NamedToNumeric = array() in /ajax/config.php/

 

I wonder if that was missing from the version I am downgrading? I am doing quite a bit of 'Wondering' today.

 

No, its not working in 5.2.5 any longer.. something bad has happened :(

Link to comment
Share on other sites

..Edit, the spammy post above has since been deleted - I am not referring to my own post as Spam :)

 

Clearly a Spammy post above, dont click the links.

 

When visiting the forum today Google gave me a big red warning saying this was a bad site and not to visit.. hope this gets resolved soon.

Link to comment
Share on other sites

I reported it to Al, as I saw it, too. But I did not see it when I logged in just now. I don't know if that's because I entered the site anyway, or if it's been fixed. And I reported the Spammer, too. I'm not a mod any more, so I can't get rid of the spam post. Been following your saga from the beginning and praying you get a resolution to it all very soon.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...