Jump to content

Once again blank pages for admin & Store after upgrade


Recommended Posts

Last week I tried working on an upgrade from v3.0.0 Alpha-2 to v5.2.5.


Even then I only got blank pages for both. No errors were created in the directory and my server is a shared host and they do not parse the server logs specific for my domain .. I've tried searching what I was able to download to no avail.


Once I saw that 5.2.7 was out I thought just maybe that whatever issue cubecart has with PHP 5.4 would have been resolved. So after doing the upgrade tonight I was dismayed that it still does not work for me.


I tried using httpwatch to see if that would shine any light on the error but all I see are successful 200 requests.


My host is not giving us a choice on running PHP 5.4 and I don't have a lot of time to get this fixed. (I can't even do a fresh upgrade - I get the same results.)


This is my test site - http://www.folcvideo.com/moondragondesigns/store/ 


This is the master domain where I have the PHP info site stored - http://www.folcvideo.com/info.php


You can see that I am running IonCube Loader.



This program makes use of the Zend Scripting Language Engine:
Zend Engine v2.4.0, Copyright © 1998-2013 Zend Technologies
    with the ionCube PHP Loader v4.5.1, Copyright © 2002-2013, by ionCube Ltd., and
    with Zend Guard Loader v3.3, Copyright © 1998-2013, by Zend Technologies


As you can imagine, I am at my wits end here.


If anyone could please help I would be most appreciative.


If needed here is all my host information:


Apache version 2.2.26 PHP version 5.4.24 MySQL version 5.5.35-log Architecture x86_64 Operating system linux


Thank you


Link to comment
Share on other sites

Hello Annette, I am sure we can get the upgrade process to work. Saying this you should never have been using v3 Alpha! The upgrade system doesn't start from that far back.


We have an upgrade service you can purchase if you would like us to do this for you. If we are not able to do it we will of course refund your money. 

Link to comment
Share on other sites

It's not just the upgrade. A clean install does the same thing. I did that here http://www.acpcrepair.com/store/index.php


Again, no error file is created and I get just a blank screen on the store *and* the admin page. This web site is on the same host so all the information above applies to acpcrepair.com as well.



Link to comment
Share on other sites

I didn't. After your reply I opened a ticket with the host just trying to get specific log files regarding the issue. I'm going to guess that there was an issue on their end and they fixed it without admitting to having any issues on their end ... something that has happened in the past with them. 


They are *very* reliable with up time and turn around when I do open tickets and that is why I stick with them


Thank you for taking the time to read about the issue I was having.



Link to comment
Share on other sites

  • 5 weeks later...

I've done a fresh install this afternoon with this message at the start:


The following errors were detected:
  • Ioncube Loader is required to use CubeCart 5. This can be configured after setup is complete.
Compatibility Check
PHP 5.2.3+ 5.2.17
MySQL 4.1+ 5.0.77
GD Image Library Installed
cURL Installed
IonCube PHP Loader Not Installed


I progressed with it saying it can be sorted after the install, I got no errors throughout the install but once completed both the store and the admin page are just blank.


Any ideas?

Link to comment
Share on other sites

We recommend that you raise the issue with your hosting provider. Please ask them to verify if the ionCube Loader appropriate for PHP5.2 is available for your account.


CubeCart's install procedure does not require the use of ionCube, but CubeCart does require it's use after the install has completed.


It is true that after CubeCart completes the installation, you are presented with links that will take you to the store front or take you to the store administration. In both cases, ionCube needs to be installed.


However, if ionCube is not installed, then the ionCube encoded file, when called, is supposed to send to the browser a message saying that ionCube is needed and to please have your webmaster install it.


To get a blank page could mean something else is wrong. When making this fresh install, did you also make a fresh database?

Link to comment
Share on other sites



below is the response I've had back from my hosting company:

Below is are response from our sys admin team regarding your query:-

Each user on the newest system has their own php.ini file and can load extensions, however we would not necessarily support them achieving this.

I've found a php.ini in the cgi-bin folder on my web server. Is it as simple as just added code to the php.ini file?

Link to comment
Share on other sites

Please visit the ionCube Loaders page: http://www.ioncube.com/loaders.php


Download the latest loader for the server type of your hosting. If you are running Windows, and you know how to FTP into your site, you can download the Loader version.


Unzip the loader archive and FTP the enclosed loader file (probably ends in .so) to the cgi-bin folder. (The loader instructions may have a better suggestion.)


FTP the php.ini file to your computer. Using a programmer's text editor (Notepad++ is free and good), add the required statements as per the loader instructions. Replace the php.ini file.


Hopefully, the next time you request a page from your site, the edited php.ini file will be loaded in, the ionCube Loader will be loaded by PHP, and all will be good.

Link to comment
Share on other sites

I think I'm on Linux hosting.


Below is what my phpinfo page is saying.

System	Linux lws03.ldn5.groupnbt.net 2.6.18-164.11.1.el5 #1 SMP Wed Jan 20 07:39:04 EST 2010 i686
Build Date	Feb 15 2011 20:21:20
Configure Command	 './configure' '--build=i686-redhat-linux-gnu' '--host=i686-redhat-linux-gnu' '--target=i386-redhat-linux-gnu' '--program-prefix=' '--prefix=/usr' '--exec-prefix=/usr' '--bindir=/usr/bin' '--sbindir=/usr/sbin' '--sysconfdir=/etc' '--datadir=/usr/share' '--includedir=/usr/include' '--libdir=/usr/lib' '--libexecdir=/usr/libexec' '--localstatedir=/var' '--sharedstatedir=/usr/com' '--mandir=/usr/share/man' '--infodir=/usr/share/info' '--cache-file=../config.cache' '--with-libdir=lib' '--with-config-file-path=/etc' '--with-config-file-scan-dir=/etc/php.d' '--disable-debug' '--with-pic' '--disable-rpath' '--without-pear' '--with-bz2' '--with-curl' '--with-exec-dir=/usr/bin' '--with-freetype-dir=/usr' '--with-png-dir=/usr' '--enable-gd-native-ttf' '--without-gdbm' '--with-gettext' '--with-gmp' '--with-iconv' '--with-jpeg-dir=/usr' '--with-openssl' '--with-pspell' '--with-pcre-regex=/usr' '--with-zlib' '--with-layout=GNU' '--enable-exif' '--enable-ftp' '--enable-magic-quotes' '--enable-sockets' '--enable-sysvsem' '--enable-sysvshm' '--enable-sysvmsg' '--enable-wddx' '--with-kerberos' '--enable-ucd-snmp-hack' '--with-unixODBC=shared,/usr' '--enable-shmop' '--enable-calendar' '--with-mime-magic=/usr/share/file/magic.mime' '--without-sqlite' '--with-libxml-dir=/usr' '--enable-force-cgi-redirect' '--enable-pcntl' '--with-imap=shared' '--with-imap-ssl' '--enable-mbstring=shared' '--enable-mbregex' '--with-ncurses=shared' '--with-gd=shared' '--enable-bcmath=shared' '--enable-dba=shared' '--with-db4=/usr' '--with-xmlrpc=shared' '--with-ldap=shared' '--with-ldap-sasl' '--with-mysql=shared,/usr' '--with-mysqli=shared,/usr/bin/mysql_config' '--enable-dom=shared' '--with-snmp=shared,/usr' '--enable-soap=shared' '--with-xsl=shared,/usr' '--enable-xmlreader=shared' '--enable-xmlwriter=shared' '--enable-fastcgi' '--with-pdo-odbc=shared,unixODBC,/usr' '--with-pdo-mysql=shared,/usr' '--enable-dbase=shared' '--with-mcrypt=shared' '--with-mhash=shared'
Server API	CGI/FastCGI
Virtual Directory Support	disabled
Configuration File (php.ini) Path	/etc
Loaded Configuration File	/web1/user46445/website/cgi-bin/php.ini
Scan this dir for additional .ini files	/etc/php.d
additional .ini files parsed	(none)
PHP API	20041225
PHP Extension	20060613
Zend Extension	220060519
Debug Build	no
Thread Safety	disabled
Zend Memory Manager	enabled
IPv6 Support	enabled
Registered PHP Streams	https, ftps, compress.zlib, compress.bzip2, php, file, data, http, ftp
Registered Stream Socket Transports	tcp, udp, unix, udg, ssl, sslv3, sslv2, tls
Registered Stream Filters	zlib.*, bzip2.*, convert.iconv.*, string.rot13, string.toupper, string.tolower, string.strip_tags, convert.*, consumed

On the following page: http://www.ioncube.com/loader_installation.php


It details about installation on a Unix Server. I have no idea what this all means. :-/

Installation on a Unix Server

If your PHP is not threaded you need a Loader called:

ioncube_loader_<os type>_<php flavour>.so
If your PHP is threaded you need a Loader called:

ioncube_loader_<os type>_<php flavour>_ts.so
<os type> will be 'lin' for Intel Linux, 'fre' for FreeBSD, 'sun' for Sparc Solaris, 'ope' for OpenBSD, 'dar' for OSX and 'net' for NetBSD.

<php flavour> will be 4.0, 4.1, 4.2 or 4.3 - i.e the first 2 digits of your PHP version.

Edit your php.ini file and for non-threaded PHP add:

zend_extension = /<path>/ioncube_loader_<os type>_<php flavour>.so
and for threaded PHP add:

zend_extension_ts = /<path>/ioncube_loader_<os type>_<php flavour>_ts.so
Replace <os type> and <php flavour> with whatever is right for your system, and <path> with the path to where the Loader is installed, e.g. /usr/local/ioncube

If there are other zend_extension entries in the php.ini file place this new entry before the existing entries.

For example, with Linux running PHP 4.1.2 and Apache 1, you might add:

zend_extension = /usr/local/ioncube/ioncube_loader_lin_4.1.so
For FreeBSD running threaded PHP 4.3.1 with Apache 2, you might add:

zend_extension_ts = /usr/local/ioncube/ioncube_loader_fre_4.3_ts.so
Link to comment
Share on other sites

Thread Safety = disabled means the file you will use is: ioncube_loader_lin_5.2.so and you will FTP that file to the cgi-bin folder.


In the php.ini file, at the bottom add:

zend_extension = /web1/user46445/website/cgi-bin/ioncube_loader_lin_5.2.so

then FTP this edited php.ini to the cgi_bin folder, replacing the existing version of php.ini.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...