Jump to content

Resolved - CubeCart broken after Hosting Migration


mediadogg
 Share

Recommended Posts

I am using the free version of CubeCart on Hostmonster. It has been working well for years. Yesterday, they migrated my web site to a new server, and now the CubeCart installation is totally hosed. I cannot even access or sign in to the Admin portal.

 

What are my options? Is it possible to obtain or purchase support from CubeCart to help fix the installation?

 

I can see the database from the Hostmonster Admin panel, so my customer, product and sales data seems to be there. I wonder if it makes sense to just upgrade to a paid version of CubeCart and get help on restoring my business.

 

So far, the compatibility team at Hostmonster has not been successful in restoring my CubeCart storefront.

Link to comment
Share on other sites

I'm sorry to hear this. CubeCart v3 is ancient and hasn't been supported or developed for a long time. If you wish to purchase a CubeCart Pro Software license key with the upgrade service we can probably salvage what you have and upgrade it to the latest version. You can orders these at https://cp.cubecart.com.

Link to comment
Share on other sites

Hi

If by free, you mean V3 then this is out of support (with CubeCart directly anyway). You could upgrade to V5 (which is generally a great idea anyway regardless of this latest problem) and get some support ticket credits which could be used if it is still not working but as you dont say what "isnt working" it is not possible to say whether this would sort your problems. Be aware though that upgrading will lose all mods that you may have installed and also that skins are not compatible so you would need to choose a new skin

Thanks

Ian

Link to comment
Share on other sites

Assuming you can access the files and folders via FTP, please:

 

1. Note the file path to the store code. It may have changed on the new server. In fact, you may need to log in to your hosting Control Panel to learn the new path to use with your FTP program.

 

2. Retrieve the file /includes/global.inc.php and edit this statement:

$glob['rootDir'] = 'new/path/to/store'; // do not include a trailing slash

 

3. Send the edited file back to your site overwriting the old.

 

If you can't use FTP, then your hosting Control Panel may have a text editor tool that you can use.

 

On the new server, you may find that the version of PHP now in use will throw "Deprecated" warnings. Please search the CC3 forums at www.cubecartforums.org for "deprecated" for a simple edit to quash those warnings.

Link to comment
Share on other sites

Thanks for all replies and offers of assistance. It turns out that during the migration, some automatic plugin was triggered and attempted to convert CubeCart to V5. The Hostmonster staff did not realize that my application had originated on a prior version. Once we figured that out, they restored the correct configuration from a backup, without the trigger.

 

So, my site seems to be back online with the exception that past logins (including admin) are not working - authentication failures. I created a new registration and am able to login / logout, but not with past registrations. For the admin user, I requested a new password and it was sent, but login attempts still fail. even with the new password.

 

Any advice?

 

Once I get going again and get a good backup of the system, I will renew my efforts to migrate to a newer version of CubeCart (which starts with not spending my Paypal revenues until I accumulate enough new product sales to purchase the license.)

Link to comment
Share on other sites

Do you have access to the database via the hosting control panel? Have a check for a table called CubeCart_admin_users, you should be able to see if there are any users set up in there If it's empty, or the table does not exist (which for some reason I've seen happen occasionally), then that will need restoring from a backup again ideally. Either that, or you can just add in a new user yourself via the control panel, super user should be 1 and for the password, you would need to click on the options section for that field and select MD5, as it's an encrypted field

Link to comment
Share on other sites

@Toucan, many thanks. That worked. In Admin mode, I checked a few things at random, and everything seems OK.

 

Now, back to debugging my new product releases, and to make some dough for V5 upgrade, beer money and toys!

 

I would say that this forum support clinches my loyalty to the CubeCart product. I am looking forward to an upgrade to Pro someday - wish I could take advantage of the current promotion, but my business account is low at the moment.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...