Jump to content

Problems with Authorize.net in 5.2.8


djf
 Share

Recommended Posts

Test mode returns an error "invalid id, user password or account is inactive" neither of which is correct.

 

Live mode processes the payment and order but returns the following error:

 

"An error occurred while trying to report this transaction to the merchant. An e-mail has been sent to the merchant informing them of the error. The following is the result of the attempt to charge your credit card.

      This transaction has been approved.
It is advisable for you to contact the merchant to verify that you will receive the product or service."

 

Any help would be appreciated but I am a complete dummy when it comes to php so a simple (if possible) answer would be really appreciated.

 

Thanks in advance.

Link to comment
Share on other sites

@djf, are you using the SIM mode of Authorize?

 

If so, would you please try this experiment -- In the file Authorize/gateway.class.php, near line 81, find:

'x_receipt_link_url'    => $GLOBALS['storeURL'].'/index.php?_g=remote&type=gateway&cmd=process&module=Authorize'

Replace the sequence & with just &.

 

When I was using Authorize.net a few years back, I had to have a separate test account to run the Test mode of this module.

 

In Live mode, I could make more tests by having my Live account in test mode (set in the customer account control panel at authorize.net).

Link to comment
Share on other sites

I've checked and double checked the merchant ID and transaction codes and they are fine. There is a section at the bottom of the ad,in page that says :

Authorize.net Settings

The following read only settings needs to be set within the 3rd parties control panel interface.

Password required mode is set to Disabled, could that be the problem but if I set it to enable where do I enter the password?


Forgot to say that I'm not worried about test mode it's the 2nd. section of my original post that's more of a concern.

Link to comment
Share on other sites

I assume you have found the "Password Mode" in your Authorize.net merchant account control panel, and that it is set to 'disabled'.

 

If you set it to 'enabled', that will be a problem as the CubeCart module neither has a form field for you to enter it, nor will the module send it.


Also, just to confirm, the CubeCart module is asking for the Merchant ID, which is not your Authorize.net account username or password. Also, the Transaction Key is not any of your merchant account login credentials.

 

There will be a place in the merchant account control panel where these two items are created for you.

Link to comment
Share on other sites

I got the test transaction email from the test account I PM'd you. It has to be a setting. Please also check the username and transaction key has no whitespace at the start or end. It could be something silly like that. CubeCart should trim it really. 

**Please DO NOT REPLY to this message. E-mail [email protected] if you have any questions.

========= SECURITY STATEMENT ==========
It is not recommended that you ship product(s) or otherwise grant services relying solely upon this e-mail receipt.

========= GENERAL INFORMATION =========

Merchant : Al Brookbanks (306237)
Date/Time : 19-Feb-2014 10:31:36 PST

========= ORDER INFORMATION =========
Invoice : 140219-183048-9329
Description : Payment for order #140219-183048-9329
Amount : 8.71 (USD)
Payment Method : MasterCard
Type : Authorization and Capture

============== RESULTS ==============
Response : This transaction has been approved.
Authorization Code : Y0RBAG
Transaction ID : 2206978128
Address Verification : Street Address: Match -- First 5 Digits of Zip: Match

==== CUSTOMER BILLING INFORMATION ===
Customer ID : 
First Name : David
Last Name : Fitch
Company : 
Address : 20920 Tulsa St.
City : Chatsworth
State/Province : California
Zip/Postal Code : 91311
Country : US
Phone : 6613120283
Fax : 
E-Mail : [email protected]

==== CUSTOMER SHIPPING INFORMATION ===
First Name : David
Last Name : Fitch
Company : 
Address : 20920 Tulsa St.
City : Chatsworth
State/Province : California
Zip/Postal Code : 91311
Country : US

======= ADDITIONAL INFORMATION ======
Tax : 
Duty : 
Freight : 
Tax Exempt : 
PO Number :
Link to comment
Share on other sites

I assume you have found the "Password Mode" in your Authorize.net merchant account control panel, and that it is set to 'disabled'.

 

If you set it to 'enabled', that will be a problem as the CubeCart module neither has a form field for you to enter it, nor will the module send it.

Also, just to confirm, the CubeCart module is asking for the Merchant ID, which is not your Authorize.net account username or password. Also, the Transaction Key is not any of your merchant account login credentials.

 

There will be a place in the merchant account control panel where these two items are created for you.

Password mode within Cubecart won't allow changes. I understand the Merchant ID is not my username and have also generated a new transaction key within Authorize. Both these settings worked fine in CC 3.

 

I got the test transaction email from the test account I PM'd you. It has to be a setting. Please also check the username and transaction key has no whitespace at the start or end. It could be something silly like that. CubeCart should trim it really. 

**Please DO NOT REPLY to this message. E-mail [email protected] if you have any questions.

========= SECURITY STATEMENT ==========
It is not recommended that you ship product(s) or otherwise grant services relying solely upon this e-mail receipt.

========= GENERAL INFORMATION =========

Merchant : Al Brookbanks (306237)
Date/Time : 19-Feb-2014 10:31:36 PST

========= ORDER INFORMATION =========
Invoice : 140219-183048-9329
Description : Payment for order #140219-183048-9329
Amount : 8.71 (USD)
Payment Method : MasterCard
Type : Authorization and Capture

============== RESULTS ==============
Response : This transaction has been approved.
Authorization Code : Y0RBAG
Transaction ID : 2206978128
Address Verification : Street Address: Match -- First 5 Digits of Zip: Match

==== CUSTOMER BILLING INFORMATION ===
Customer ID : 
First Name : David
Last Name : Fitch
Company : 
Address : 20920 Tulsa St.
City : Chatsworth
State/Province : California
Zip/Postal Code : 91311
Country : US
Phone : 6613120283
Fax : 
E-Mail : [email protected]

==== CUSTOMER SHIPPING INFORMATION ===
First Name : David
Last Name : Fitch
Company : 
Address : 20920 Tulsa St.
City : Chatsworth
State/Province : California
Zip/Postal Code : 91311
Country : US

======= ADDITIONAL INFORMATION ======
Tax : 
Duty : 
Freight : 
Tax Exempt : 
PO Number :

Double checked there are no spaces, Merchant ID is correct and transaction key copied and pasted direct from Authorize.

Link to comment
Share on other sites

 

I assume you have found the "Password Mode" in your Authorize.net merchant account control panel, and that it is set to 'disabled'.

 

If you set it to 'enabled', that will be a problem as the CubeCart module neither has a form field for you to enter it, nor will the module send it.

Also, just to confirm, the CubeCart module is asking for the Merchant ID, which is not your Authorize.net account username or password. Also, the Transaction Key is not any of your merchant account login credentials.

 

There will be a place in the merchant account control panel where these two items are created for you.

Password mode within Cubecart won't allow changes. I understand the Merchant ID is not my username and have also generated a new transaction key within Authorize. Both these settings worked fine in CC 3.

 

I got the test transaction email from the test account I PM'd you. It has to be a setting. Please also check the username and transaction key has no whitespace at the start or end. It could be something silly like that. CubeCart should trim it really. 

**Please DO NOT REPLY to this message. E-mail [email protected] if you have any questions.

========= SECURITY STATEMENT ==========
It is not recommended that you ship product(s) or otherwise grant services relying solely upon this e-mail receipt.

========= GENERAL INFORMATION =========

Merchant : Al Brookbanks (306237)
Date/Time : 19-Feb-2014 10:31:36 PST

========= ORDER INFORMATION =========
Invoice : 140219-183048-9329
Description : Payment for order #140219-183048-9329
Amount : 8.71 (USD)
Payment Method : MasterCard
Type : Authorization and Capture

============== RESULTS ==============
Response : This transaction has been approved.
Authorization Code : Y0RBAG
Transaction ID : 2206978128
Address Verification : Street Address: Match -- First 5 Digits of Zip: Match

==== CUSTOMER BILLING INFORMATION ===
Customer ID : 
First Name : David
Last Name : Fitch
Company : 
Address : 20920 Tulsa St.
City : Chatsworth
State/Province : California
Zip/Postal Code : 91311
Country : US
Phone : 6613120283
Fax : 
E-Mail : [email protected]

==== CUSTOMER SHIPPING INFORMATION ===
First Name : David
Last Name : Fitch
Company : 
Address : 20920 Tulsa St.
City : Chatsworth
State/Province : California
Zip/Postal Code : 91311
Country : US

======= ADDITIONAL INFORMATION ======
Tax : 
Duty : 
Freight : 
Tax Exempt : 
PO Number :

Double checked there are no spaces, Merchant ID is correct and transaction key copied and pasted direct from Authorize.

 

Have just copied and pasted Merchant ID and transaction key from my CC3 site which works fine, I haven't upgraded that one yet and the new CC5.2.8 site still returns an error

Link to comment
Share on other sites

Would you look in CubeCart's admin Error Logs. If CubeCart rejected the receipt_link_url, it will be shown here.

Error logs are empty. One diference between the CC3 cart that works and this newly installed CC5 cart is that CC3 is running on a shared IP and SSl, the new one is a dedicated IP and purchased SSL. Don't know if that has any relevance.

Link to comment
Share on other sites

The IP/SSL makes no difference.

 

When I was using Authorize.net, I was able to talk to a real-live support person who could watch the traffic to my merchant account. I hope that support at Authorize.net could tell you in better detail why Authorize.net is giving CubeCart these error messages.

 

The error message implied there would be an email sent to you. Did the email have any better info?

Link to comment
Share on other sites

The IP/SSL makes no difference.

 

When I was using Authorize.net, I was able to talk to a real-live support person who could watch the traffic to my merchant account. I hope that support at Authorize.net could tell you in better detail why Authorize.net is giving CubeCart these error messages.

 

The error message implied there would be an email sent to you. Did the email have any better info?

Received an email in response to a live transaction as follows:

 

Your script timed out while we were trying to post transaction results to it.

   Transaction ID: 5944875745

Transaction Result: This transaction has been approved.

 

No email from the test transactions. Will try Authorize support tomorrow, probably too late now.

Link to comment
Share on other sites

I will take that to mean that Authorize.net tried to send a message to the address contained in this line:

'x_receipt_link_url'    => $GLOBALS['storeURL'].'/index.php?_g=remote&type=gateway&cmd=process&module=Authorize'

but the server did not respond with a 200 OK message within the allotted time. Or returned with something other than 200 OK.

 

Would you please confirm that the experiment which edited that statement now looks like this:

'x_receipt_link_url'    => $GLOBALS['storeURL'].'/index.php?_g=remote&type=gateway&cmd=process&module=Authorize'

Link to comment
Share on other sites

I will take that to mean that Authorize.net tried to send a message to the address contained in this line:

'x_receipt_link_url'    => $GLOBALS['storeURL'].'/index.php?_g=remote&type=gateway&cmd=process&module=Authorize'

but the server did not respond with a 200 OK message within the allotted time. Or returned with something other than 200 OK.

 

Would you please confirm that the experiment which edited that statement now looks like this:

'x_receipt_link_url'    => $GLOBALS['storeURL'].'/index.php?_g=remote&type=gateway&cmd=process&module=Authorize'

'x_receipt_link_url'    => $GLOBALS['storeURL'].'/index.php?_g=remote&type=gateway&cmd=process&module=Authorize'

Direct copy from the file however I notice there is a semicolon after remote& and gateway& but not in yours is this significant?

Link to comment
Share on other sites

Extremely significant. Please remove the semi-colons. Make the line look exactly as I have posted in post #17.

Have copied and pasted from above. Checked all the settings in CC and Authorize and still have the same problem. After selecting payment cy credit card I don't get the opportunity to fill in the ccard details, straight to the error message.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...