Jump to content

Forgot Password - Reset not working


djcaseanova
 Share

Recommended Posts

So, I forgot my password for my test account and did a "Forgot password". I received the email from the store and clicked the link.

 

It asks for my email address, a validation code (already inserted) and a New/Confirm password. I do all this and this is what has been returned each time I tried it.

 

 

The following errors were detected:

  • User login blocked. Please try again later
  • Failed to update your password.
  • Failed to update your password. Please check the email address and validation key are correct and verify the new password matches.

 

Any Ideas?? This is a good way to lose customers, especially if they can't reregister with an email address already in use.

Link to comment
Share on other sites

"I forgot my password."

 

In trying your password, did you fail at it for more than five times?

 

If so, wait 10 minutes before even trying to use any password, and also wait 10 minutes before trying to log in using the validation code.

 

If this does not represent your situation, we can look elsewhere.

 

If you can't wait 10 minutes, and you have access to your database, you can delete all the records in the CubeCart_blocker table.

Link to comment
Share on other sites

I did not try it more than 5 times. I have two separate test accounts. so it was one password or the other, or so I thought. I input the password a few times and no luck. I then decided it would be a good time to test the forgot password recovery system. It sent me a link and I went ahead and did that. When I did that that's when I got the info I posted above. I cleared my cache on my computer, redid the forgot password link again, and the email I received contained the same exact validation code as the first attempt. When I went through it the second time, it DID work.

 

Not sure if that was a caching issue or what. Does it always send the same validation code? Also, these test accounts were created in a the CC5 version before this latest one, and it was while still in "Lite" mode before upgrading. I wonder if that played a part in the database since the passwords did not take the first attempts?

Link to comment
Share on other sites

"Does it always send the same validation code?"

 

The code says no. The code uses a (good) random number generator, so, technically, two separate requests could send the same code. Not likely, however.

 

"Also, these test accounts were created in a the CC5 version before this latest one, and it was while still in "Lite" mode before upgrading. I wonder if that played a part."

 

I believe such would not be the case.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...