Jump to content

WordPay Error (Authorisation mode)


quantument
 Share

Recommended Posts

I checked my monthly sales today and found almost no payments through the Worldpay gateway. On running a test transaction I receive the following message:

 

Secure Payment Page Sorry, there was a problem processing your payment: The information sent from the merchant's site is invalid or incomplete. Please send the following information to the merchant:

The transaction cannot be processed for one or more of the following reasons:

  • The merchant account is suspended.
  • The order currency selected is not supported.
  • The authorisation mode is incorrect.
  • Test mode is unavailable.
  • The installation is not live.

  Server information 08/Oct/2014 10:01:04 Server ID ukdc2-pz-pay08 (WPReq-2745093)

 

I have contacted WorldPay and they tell me that my Auth Mode is set as 'E' whereas it should be set to 'A' for automatic (or nothing).

 

I've changed nothing on Cubecart and WorldPay say that nothing has changed at their end. There is nothing in the Gateway config screen to alter.

 

Does anyone have any ideas please?

Link to comment
Share on other sites

Hi

Version 5.2.13 made a very small change to the WorldPay payment gateway so guessing you have recently upgraded to this version

In modules/gateway/WorldPay/gateway.class.php a new line was added on line 37 setting 'authMode' => 'E',

As this wasnt present previously it was being taken as blank, but you can simply change this to 'A' instead and test

Thanks

Ian

Link to comment
Share on other sites

Yes, that's done it thanks.

 

It may be that that option needs to be put in the Gateway admin screen, or changed to 'A' in the next code update. The default 'E' means that the merchant must manually authorise each payment, whereas 'A' means that it happens automatically, which you would want for digital downloads.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...