Jump to content

Option Attributes displayed in admin but not on website


KRISTINVELLA
 Share

Recommended Posts

If you click on the following link: http://www.redroseinvitations.com.au/store/aqua-blue-wedding-invitation-with-ivory-pearl-cluster.html

It only shows 1 product attribute per product option, when some product options have up 5 attributes. 

This has not always been the case as I have had this website version of cubecart for over a year and it has only happened in the last week. As a possibility some of the coding may have been changed as I have having other problems with product options not displaying all together. I had Al from cubecart fix another problem with display issues and in fixing that, this problem has now been created. 

I have spoken to my website hosting provider and they have told me it has to do with my eCommerce program.

This problem occurs on every product I have, where there is more then one option, per product option. If I add a new product with the same scenario I still have the same issue.

I have attached files, showing you what I mean. 

 

Does anyone have any suggestions, as I am not sure why I havent heard back from Al from over a week ago, the last he said was he is unsure of how to fix it?

Thanks.


 

Link to comment
Share on other sites

I see nothing wrong with the skin you are using, so I would next suspect the file /classes/catalogue.class.php where the options are collected and organized for display.

 

Please let us know the exact version of CubeCart you are using: admin, Dashboard (what you see when first arriving in admin), Store Overview tab.

Link to comment
Share on other sites

I do not see any suspect changes between CC5.2.2 and CC5.2.14 in the catalogue class.

 

You mention there may be an edit to this file? I would like to see the file /classes/catalogue.class.php. Please do not post the contents of the file in the forums. You can email it to me.

Link to comment
Share on other sites

Use the FTP program to get to 'redroseinvitations'. Open the folder that (probably) is named 'html_docs' or something very similar. Then open the folder named 'store'. Then the folder named 'classes'. FTP the file named catalogue.class.php to your computer.

Link to comment
Share on other sites

Thanks for your help and resolving the issue Brian.

 

For anyone else reading this, my original problem was caused by assigning an option set to a product. It cause the options not to display in the order it needed to be and one of my product options I added singularly, had disappeared. 

I've also had the problem of negative pricing not sticking when an option set was applied. It would randomly turn in positive pricing roughly about a week later.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...