Jump to content

CC6 Setup - Incorrect database host, username and/or password


ploughguy
 Share

Recommended Posts

Hi,

I am trying to install CC691b for evaluation. I am running CC4 something in production on a hosted service and I have previously installed CC5 for evaluation successfully.

 

Installation platform is OS X running Mavericks.

 

MySQL 5.6.22 is installed and running.

 

phpmyadmin can connect to MySQL.

 - I believe this means that the Apache, PHP and MySQL installations are acceptable.

 

I have created a user atomacom with phpmyadmin

 - with a known password ( i.e. I am cutting and pasting the password to create the user and configure)

 - the user has access for all databases.

 

I have created a database cc601b

 

User atomacom has all permissions for the database but no administrator permissions.

 

The setup dialog for CC6 runs successfully up to the database settings step, whereupon I stall with:

 - Incorrect database host, username and/or password.

 

I have restarted it several time so it gets to repeat its checks - everything is green up to this point.

 

The values I am using are:

Database Settings:

 - Database host:    localhost

 - Username:           atomacom

 - Password:           <paste from same source that created the account>

 - Database Name: cc601b

 - Table Prefix:        cc601b

 

Store Settings:

 - Default Language: English  <this is not pre-initialised to its only possible value, even when page is represented for correction and the value was set previously>

 - Default Currency: AUD

 

Administrator Profile

 - User name:       admin (a user that has not been created - I believe this is a CubeCart internal user)

 - Password:        <same as above>

 - Other details    probably not relevant here

 

Advance Settings;

 - Drop Tables     Not selected (this is a new database and user)

 

Any thoughts about what might be causing the problem?

Link to comment
Share on other sites

Problem not necessarily solved, but I managed to get it to complete by feeding it user root.

 

After the red mist of frustration cleared, I did some more dining.  I have no idea what I did to fix it, but now I have a store user configured for host: localhost and it all now works.

 

I seriously have no idea what fixed it. The user was originally localhost - I change it to All hosts then attempted to copy it to create a separate localhost user (because "All Hosts", apparently, is not All at all - it excludes localhost.)

 

For reasons I do not understand, the copy function in phpmyadmin did an update instead and I ended up with just a localhost user.  However the installation process completed user the store-owner account and it works.

Link to comment
Share on other sites

Something came up and I didn't get to actually make the suggestion to make sure this new user was understood by the database to allow access from wherever - localhost?

 

I'm glad it got sorted.

 

Be aware though...

 

This! Is! Sparta! a Beta!

Link to comment
Share on other sites

bsmither said:

This! Is! Sparta! a Beta!

 

Understood!  

Before I switch from 434 I need to:

  • Learn about the new user-exit technology from CC5
  • Get the hang of PHP Classes
  • Learn about the new rendering engine used by the UI
  • Work out which of my hundred-odd enhancements and add-ons are now part of the product
  • And find or develop a solution for the remainder of them.

Probably not much change out of a year for that lot.  Hence the early start on V6.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...