Jump to content

Update/Upgrade from Cubecart Ver.4.4.5 to Ver6


Recommended Posts

We have a website that was done wayback in 2011 with Cubecart version 4.4.5, Php version 5.2.17, MySql Version 5.1.68-community-log. We cannot contact the person who set up this account anymore. We are totally clueless on what to do. Our questions are:

1. How can we update our Cubecart 4.4.5 into the latest version?

2. Do we also need to update the Php version?

3. Our domain name will also expire next month, how can we renew it?

4. Lastly, why is my admin screen looks like this? Do i need to install anything?

 

Sorry for these basic questions but we still want to continue our website. Your answers will be a great help. Thank you.

 

 

Link to comment
Share on other sites

You may wish to contact a professional application management service. Two that are prevalent on these forums are:

* HavenSwift Hosting

* CubeCart Ltd (monthly/annual maintenance plans)

 

CubeCart's upgrade procedure is relatively straightforward: FTP the files to a folder, run setup. (That's oversimplified, but there are knowledbase articles that will explain it a lot better.

 

The latest version of CubeCart will run on PHP 5.2.3 or better.

 

Renewing your domain name is tricky if the Domain Registrar that your domain was registered with (for example, GoDaddy), has the account listed under the developer's name. If you have the account name and password, then it should be easy. Log in  and you should be greeted with an advisory to renew your domain name.

 

Your admin pages look like that because, for some reason, your browser is not fetching, or your site is missing the CSS file for these pages.

Link to comment
Share on other sites

1. How can we update our Cubecart 4.4.5 into the latest version?

You can either upgrade your store to the latest V5 release or if you wait a few weeks, I would suggest going straight straight to V6 as this is due to final release in a week or so. What you need to be aware of is that if you have had any mods or changes done to the core installation then these will not work in V5 or V6 and also the skin you are using for V4 is not compatible so you would either need to choose one of the stock V5 skins, use the new V6 Foundation based skin or choose a third party skin designed for one of these versions

2. Do we also need to update the Php version?

Unless you are running on your own server which sounds unlikely you will probably not be able to upgrade the version of php you are running (some hosting control panels do allow you to choose between a selection of php versions) php V5.2 is extremely old and unsupported and MySQL V5.1 is even older - you need to be with a hosting company that updates this software a little more regularly

3. Our domain name will also expire next month, how can we renew it?

You would need to determine which company the domain is registered through - this can be done using whois websites or you should have emails from when you purchased or indeed as a reminder to renew it.

4. Lastly, why is my admin screen looks like this? Do i need to install anything?

Unsure why this is happening - maybe some underlying error is causing the problem

Ian

Link to comment
Share on other sites

You may wish to contact a professional application management service. Two that are prevalent on these forums are:

* HavenSwift Hosting

* CubeCart Ltd (monthly/annual maintenance plans)

 

CubeCart's upgrade procedure is relatively straightforward: FTP the files to a folder, run setup. (That's oversimplified, but there are knowledbase articles that will explain it a lot better.

 

The latest version of CubeCart will run on PHP 5.2.3 or better.

 

Renewing your domain name is tricky if the Domain Registrar that your domain was registered with (for example, GoDaddy), has the account listed under the developer's name. If you have the account name and password, then it should be easy. Log in  and you should be greeted with an advisory to renew your domain name.

 

Your admin pages look like that because, for some reason, your browser is not fetching, or your site is missing the CSS file for these pages.

Thanks for your reply. But I really have zero knowledge on this. I don't know how and where to start. The developer has the account name and password for the domain registration so I don't have the information anymore.

Link to comment
Share on other sites

1. How can we update our Cubecart 4.4.5 into the latest version?

We have an upgrade service and can do it for you. More info here:

https://www.cubecart.com/technical-support

Alternatively there are links to upgrade instructions on our downloads page:

https://www.cubecart.com/download

2. Do we also need to update the Php version?

The php version you have is fine.

3. Our domain name will also expire next month, how can we renew it?

You'll need to find out who your domain registrar is and contact them to renew the domain. The following link should help..

https://www.icann.org/resources/pages/who-2013-05-03-en

4. Lastly, why is my admin screen looks like this? Do i need to install anything?

There can be lots of reasons for this. Incorrect paths specified in the settings, missing file(s), wrong file permissions or server security software blocking a file loading. We have upgraded hundreds of stores and this is not going to be a barrier to upgrade.
Link to comment
Share on other sites

I hope Havenswift has some good advice. I don't.

There are a variety of things that can be done and we come across this a surprising number of times. It highlights the huge importance of people getting all login details for domain and hosting and ensuring that items such as domains are registered in their own names which unfortunately many developers simply dont do.

Talking to the lady concerned in this case to try and sort this for her before the domain expires.

The php version you have is fine.

While CubeCart will run on this version of CubeCart, support and maintenance releases for this extremely old version ended many years ago and there are known security issues with it, so anyone running on php 5.2.x is opening their site up to possible security problems. You should be running at least the latest version of 5.3.x and while this has also recently come to EOL, there are no known issues and is stable.

Ian

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...