Jump to content

Resolved - Google Base/Product Feed issue


Prebeat
 Share

Recommended Posts

I am having a real hard time getting the Google product feed approved.  So far out of over 4,000 products only 2 are active.  Amongst other errors this is one of the main ones...

Product identifiers provided but 'identifier_exists' set to false.

Anyone got any ideas ?

Link to comment
Share on other sites

Identifier_exists as false is a field I need, because we sell used toys that often do not have tags any more. The error message says you DO have UPC or other product identification. Do the 2 "active" ones actually have an identifier you failed to fill in? If so, fix those two. Then you could take the identifier_exists column off your feed entirely.

See http://www.datafeedwatch.com/blog/new-in-google-shopping-identifier-exists/

To take the field off, goto the hooks folder in the Google_Base directory in Modules, admin.product.import.format.php. It really should be set to not use that field at all IF 2 other identifiers exist (normally one of those is Brand). So if that's what you need, someone else will have to provide a code fix.

Link to comment
Share on other sites

Thank you for the reply - a little over my head, but something for me to investigate.  Indentifier Exists is showing as NO for both products active and not active.

 

As an example here is what it says is provided for one product :

Id
4099
price
£18.49
availability
In stock
product type
Music > Musical Accessories > Stands & Supports > Drum Stands
google product category
Arts & Entertainment > Hobbies & Creative Arts > Musical Instrument & Orchestra Accessories > Music Stand Accessories > Music Stand Bags
description
This high quality digital drum stand features tripod legs, secure height adjustment with locking pin and tilt/angle adjustment, so you can enjoy a comfortable and totally customised fit. Suitable for most digital drum controllers.
condition
new
ean
5021196705253
brand
New Jersey Sound Corp
identifier exists
No
Link to comment
Share on other sites

It wouldn't be NO even if you didn't have the brand and ean. It would be False. Can you do a Find/replace on your feed in a spreadsheet and take the No off all of them.Then add back on just those 2 that should say "false" without quotes?

(This is a temporary fix, just to get your products listed, until knowledgeable help arrives)

Link to comment
Share on other sites

Do you have access to the CubeCart files, either by ftp or cpanel?

In the admin/sources/products.export.inc.php about line 83 I have:

   $result['store_category'] = $GLOBALS['seo']->getDirectory($result['cat_id'], false, ' > ');
   $result['shopping_com_category'] = $GLOBALS['seo']->getDirectory($result['cat_id'], false, ' -> ');
   if (isset($result['mpn']) && empty($result['mpn']) && isset($result['gtin']) && empty($result['gtin'])) {
    $result['identifier_exists'] = 'FALSE';
   } else {
    $result['identifier_exists'] = 'TRUE';
   }

That should mean any product WITH either mpn or gtin should show as TRUE. There is evidently an assumption being made that brand is also given (not always true for me).

Link to comment
Share on other sites

My suggestion here isn't going to work.

See comment below:

Since you are filling in ean and the code seems to check only for gtin and mpn, please try making a backup copy of the products.export.inc.php file. Then EDIT the code from one line , replacing gtin with ean, so it looks like this:

if (isset($result['mpn']) && empty($result['mpn']) && isset($result['ean']) && empty($result['ean'])) {

Save the file and try another feed export, checking to see what happens in the indentifier_exists column. If it doesn't work, just delete your edited file and put the backup file back live.

Edited by Dirty Butter
edit doesn't look like it will work - see more recent comment
Link to comment
Share on other sites

Hello
Nipped in to the office today and have been having  a look at this and comparing it to a successful feed we have on our other website (not cube cart) and it does seem that the EAN for that feed is put in to the GTIN column on each product.  That must be done automatically we we only use EAN numbers there too.  In fact I don't even get what a GTIN is if I am being honest.

I will keep looking and get this resolved - although I have also noticed this is just a warning and not an error so isn't what is stopping the products being listed. 

Link to comment
Share on other sites

Interestingly enough if I change that code to this then that problem is no more - but this isn't the solution I don't think.  Then I had a brain waive, we use feedoptimise for our other website and the guy there knows is stuff - so he is looking at using his system to do clever things for this website too.  I will get this on PPC shopping ! lol.

    $result['identifier_exists'] = 'TRUE';
   } else {
    $result['identifier_exists'] = 'TRUE';
Link to comment
Share on other sites

A way around it with your current setup is to do a swap in the hooks file I previously mentioned in the Google_Base module folder.

In admin.product.import.format.php

Change where this line has gtin as the header and gtin as the field

	$header_fields = array('id', 'product_type', 'google_product_category', 'link', 'title', 'description', 'image_link', 'price', 'condition', 'shipping_weight', 'upc', 'ean', 'jan', 'isbn', 'availability', 'brand', 'gtin', 'mpn', 'identifier_exists');
	$fields  = array('product_id', 'store_category', 'google_category', 'url', 'name', 'description', 'image', 'price', 'condition', 'product_weight', 'upc', 'ean', 'jan', 'isbn', 'availability', 'manufacturer', 'gtin', 'mpn', 'identifier_exists');

To this where gtin is the header, BUT ean is the field

	$header_fields = array('id', 'product_type', 'google_product_category', 'link', 'title', 'description', 'image_link', 'price', 'condition', 'shipping_weight', 'upc', 'ean', 'jan', 'isbn', 'availability', 'brand', 'gtin', 'mpn', 'identifier_exists');
	$fields  = array('product_id', 'store_category', 'google_category', 'url', 'name', 'description', 'image', 'price', 'condition', 'product_weight', 'upc', 'ean', 'jan', 'isbn', 'availability', 'manufacturer', 'ean', 'mpn', 'identifier_exists');

.So if that was just a warning, and not what is keeping your feed from working, we'll need to look back to see what the real issue is.

 

Link to comment
Share on other sites

Really Really odd - overnight last night Google suddenly started approving our listings - we now have 3,000 items listed and have started taking orders today from those listings.  Of course, some other glitches have now appeared - but I have almost everything crossed they are simple fixes and the masters of Cubecart will sort it out.

 

Thank you again Dirty Butter for your replies and help.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...